]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- rel 3
[packages/cmake.git] / cmake.spec
CommitLineData
efafbc62 1Summary: Cross-platform, open-source make system
ac3ea35a 2Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 3Name: cmake
22f6d57e 4Version: 2.4.8
2d4d8045 5Release: 3
efafbc62 6License: BSD
72a696fa 7Group: Development/Building
08b6790a 8Source0: http://www.cmake.org/files/v2.4/%{name}-%{version}.tar.gz
22f6d57e 9# Source0-md5: f5dd061c31765a49dc17ae8bdc986779
923851a2 10Patch0: %{name}-ncurses.patch
286b1479 11Patch1: %{name}-lib64.patch
7503d318 12URL: http://www.cmake.org/HTML/Index.html
ece9e155
KK
13BuildRequires: libstdc++-devel
14BuildRequires: ncurses-devel
15BuildRequires: rpmbuild(macros) >= 1.167
efafbc62 16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
17
18%description
efafbc62
AG
19CMake is used to control the software compilation process using simple
20platform and compiler independent configuration files. CMake generates
21native makefiles and workspaces that can be used in the compiler
22environment of your choice. CMake is quite sophisticated: it is
23possible to support complex environments requiring system
24configuration, pre-processor generation, code generation, and template
25instantiation.
3fcbc09a 26
520c9eb8
JR
27%description -l pl.UTF-8
28CMake służy do sterowania procesem kompilacji oprogramowania przy
29użyciu prostych plików konfiguracyjnych niezależnych od platformy i
72a696fa 30kompilatora. CMake generuje natywne pliki makefile i workspace,
520c9eb8
JR
31których można używać w wybranym środowisku kompilatora. CMake jest
32dość przemyślany: może obsłużyć złożone środowiska wymagające
72a696fa 33konfiguracji systemu, generowanie preprocesora, generowanie kodu i
520c9eb8 34dziedziczenie szablonów.
72a696fa 35
3fcbc09a 36%prep
923851a2 37%setup -q
3fcbc09a 38%patch0 -p1
286b1479
ER
39%if "%{_lib}" == "lib64"
40%patch1 -p1
41%endif
3fcbc09a 42
ece9e155 43cat > "init.cmake" <<EOF
286b1479 44SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
ece9e155
KK
45EOF
46
3fcbc09a 47%build
ece9e155
KK
48export CC="%{__cc}"
49export CXX="%{__cxx}"
50export CFLAGS="%{rpmcflags}"
51export CXXFLAGS="%{rpmcxxflags}"
923851a2
AG
52./bootstrap \
53 --prefix=%{_prefix} \
54 --mandir=/share/man \
55 --datadir=/share/cmake \
ece9e155 56 --init=init.cmake \
923851a2
AG
57 --verbose
58
923851a2 59%{__make}
3fcbc09a
AG
60
61%install
efafbc62 62rm -rf $RPM_BUILD_ROOT
72a696fa
JB
63
64%{__make} install \
65 DESTDIR=$RPM_BUILD_ROOT
66
c4bbee29 67rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%files
efafbc62 73%defattr(644,root,root,755)
51ed65c6 74%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
75%attr(755,root,root) %{_bindir}/ccmake
76%attr(755,root,root) %{_bindir}/cmake
08b6790a 77%attr(755,root,root) %{_bindir}/cpack
72a696fa
JB
78%attr(755,root,root) %{_bindir}/ctest
79%{_mandir}/man1/*.1*
923851a2 80%{_datadir}/cmake
This page took 0.038541 seconds and 4 git commands to generate.