]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- sick...
[packages/cmake.git] / cmake.spec
CommitLineData
4d2fe254
JB
1# TODO: any valid CMAKE_BUILD_TYPE causes overriding of our optflags
2# (and default non-verbose makefiles are hiding it!)
ccca321d
KK
3#
4# Conditional build:
5%bcond_with bootstrap # use internal versions of some libraries
6#
efafbc62 7Summary: Cross-platform, open-source make system
ac3ea35a 8Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 9Name: cmake
ccca321d
KK
10Version: 2.6.0
11Release: 0.1
efafbc62 12License: BSD
72a696fa 13Group: Development/Building
ccca321d
KK
14Source0: http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
15# Source0-md5: e95ae003672dfc6c8151a1ee49a0d4a6
286b1479 16Patch1: %{name}-lib64.patch
7503d318 17URL: http://www.cmake.org/HTML/Index.html
ece9e155
KK
18BuildRequires: libstdc++-devel
19BuildRequires: ncurses-devel
20BuildRequires: rpmbuild(macros) >= 1.167
c342f103 21%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel}
efafbc62 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
23
24%description
efafbc62
AG
25CMake is used to control the software compilation process using simple
26platform and compiler independent configuration files. CMake generates
27native makefiles and workspaces that can be used in the compiler
28environment of your choice. CMake is quite sophisticated: it is
29possible to support complex environments requiring system
30configuration, pre-processor generation, code generation, and template
31instantiation.
3fcbc09a 32
520c9eb8
JR
33%description -l pl.UTF-8
34CMake służy do sterowania procesem kompilacji oprogramowania przy
35użyciu prostych plików konfiguracyjnych niezależnych od platformy i
72a696fa 36kompilatora. CMake generuje natywne pliki makefile i workspace,
520c9eb8
JR
37których można używać w wybranym środowisku kompilatora. CMake jest
38dość przemyślany: może obsłużyć złożone środowiska wymagające
72a696fa 39konfiguracji systemu, generowanie preprocesora, generowanie kodu i
520c9eb8 40dziedziczenie szablonów.
72a696fa 41
3fcbc09a 42%prep
923851a2 43%setup -q
286b1479
ER
44%if "%{_lib}" == "lib64"
45%patch1 -p1
46%endif
3fcbc09a 47
ece9e155 48cat > "init.cmake" <<EOF
286b1479 49SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
ccca321d 50SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
ece9e155
KK
51EOF
52
3fcbc09a 53%build
ece9e155
KK
54export CC="%{__cc}"
55export CXX="%{__cxx}"
56export CFLAGS="%{rpmcflags}"
57export CXXFLAGS="%{rpmcxxflags}"
ccca321d 58export LDFLAGS="%{rpmldflags}"
923851a2
AG
59./bootstrap \
60 --prefix=%{_prefix} \
61 --mandir=/share/man \
62 --datadir=/share/cmake \
ece9e155 63 --init=init.cmake \
c342f103 64 %{!?with_bootstrap:--system-libs} \
923851a2
AG
65 --verbose
66
923851a2 67%{__make}
3fcbc09a
AG
68
69%install
efafbc62 70rm -rf $RPM_BUILD_ROOT
72a696fa
JB
71
72%{__make} install \
73 DESTDIR=$RPM_BUILD_ROOT
74
c4bbee29 75rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%files
efafbc62 81%defattr(644,root,root,755)
51ed65c6 82%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
83%attr(755,root,root) %{_bindir}/ccmake
84%attr(755,root,root) %{_bindir}/cmake
08b6790a 85%attr(755,root,root) %{_bindir}/cpack
72a696fa
JB
86%attr(755,root,root) %{_bindir}/ctest
87%{_mandir}/man1/*.1*
923851a2 88%{_datadir}/cmake
This page took 0.051964 seconds and 4 git commands to generate.