]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- added fix for ruby 2.x b/c of moved RUBY_CONFIG_INCLUDE_DIR
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
eead9c17 10%bcond_without tests # do not perform "make test"
77f8acdd 11
efafbc62 12Summary: Cross-platform, open-source make system
ac3ea35a 13Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 14Name: cmake
aae1b476
JB
15Version: 2.8.12.2
16Release: 1
efafbc62 17License: BSD
72a696fa 18Group: Development/Building
28f0bd6c 19Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
aae1b476 20# Source0-md5: 17c6513483d23590cbce6957ec6d1e66
6342daf8 21Patch0: %{name}-lib64.patch
9ec4f08d 22Patch1: %{name}-helpers.patch
de784c58
JB
23Patch2: %{name}-findruby.patch
24Patch3: %{name}-tests.patch
0ea0e364 25Patch4: %{name}-freetype2.patch
a048aac3 26Patch5: %{name}-findruby2.patch
a315a797 27URL: http://www.cmake.org/
33042d59 28%{?with_gui:BuildRequires: QtGui-devel}
fef12180 29BuildRequires: libarchive-devel
ece9e155 30BuildRequires: libstdc++-devel
59917d1a 31BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
32%{?with_gui:BuildRequires: qt4-build}
33%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 34BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 35%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 36Requires: filesystem >= 3.0-52
efafbc62 37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
38
39%description
efafbc62
AG
40CMake is used to control the software compilation process using simple
41platform and compiler independent configuration files. CMake generates
42native makefiles and workspaces that can be used in the compiler
43environment of your choice. CMake is quite sophisticated: it is
44possible to support complex environments requiring system
45configuration, pre-processor generation, code generation, and template
46instantiation.
3fcbc09a 47
520c9eb8
JR
48%description -l pl.UTF-8
49CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 50użyciu prostych plików konfiguracyjnych niezależnych od platformy i
51kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 52których można używać w wybranym środowisku kompilatora. CMake jest
59787775 53dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 54konfiguracji systemu, generowanie preprocesora, generowanie kodu i
55dziedziczenie szablonów.
33042d59
KK
56
57%package gui
b563f9dc
JB
58Summary: Qt GUI for CMake
59Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
60Group: Development/Tools
61Requires: %{name} = %{version}-%{release}
62
b563f9dc
JB
63%description gui
64This package contains the Qt based GUI for CMake.
65
66%description gui -l pl.UTF-8
67Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
68CMake.
72a696fa 69
9ec4f08d 70%package emacs
69d19c08
JB
71Summary: Emacs mode for cmake files
72Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
73Group: Development/Tools
74
75%description emacs
69d19c08
JB
76Emacs mode for cmake files.
77
78%description emacs -l pl.UTF-8
79Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
80
81%package -n bash-completion-%{name}
82Summary: bash-completion for cmake
69d19c08 83Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 84Group: Applications/Shells
69d19c08 85Requires: %{name} = %{version}-%{release}
a9b1845f 86Requires: bash-completion >= 2.0
6465d90a
ER
87%if "%{_rpmversion}" >= "5"
88BuildArch: noarch
89%endif
9ec4f08d
KK
90
91%description -n bash-completion-%{name}
69d19c08
JB
92bash-completion for cmake.
93
94%description -n bash-completion-%{name} -l pl.UTF-8
95Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 96
3fcbc09a 97%prep
923851a2 98%setup -q
286b1479 99%if "%{_lib}" == "lib64"
6342daf8 100%patch0 -p1
286b1479 101%endif
9ec4f08d 102%patch1 -p1
fe667d6f 103%patch2 -p1
de784c58 104%patch3 -p1
0ea0e364 105%patch4 -p1
a048aac3 106%patch5 -p1
3fcbc09a 107
ece9e155 108cat > "init.cmake" <<EOF
286b1479 109SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
110SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
111SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
112EOF
113
3fcbc09a 114%build
ece9e155
KK
115export CC="%{__cc}"
116export CXX="%{__cxx}"
117export CFLAGS="%{rpmcflags}"
118export CXXFLAGS="%{rpmcxxflags}"
ccca321d 119export LDFLAGS="%{rpmldflags}"
923851a2
AG
120./bootstrap \
121 --prefix=%{_prefix} \
122 --mandir=/share/man \
123 --datadir=/share/cmake \
ece9e155 124 --init=init.cmake \
c342f103 125 %{!?with_bootstrap:--system-libs} \
33042d59 126 %{?with_gui:--qt-gui} \
08bb5e07 127 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
128 --verbose
129
28f0bd6c 130%{__make} VERBOSE=1
3fcbc09a 131
1fbe3ed6
AM
132%{?with_tests:%{__make} test}
133
3fcbc09a 134%install
efafbc62 135rm -rf $RPM_BUILD_ROOT
72a696fa
JB
136%{__make} install \
137 DESTDIR=$RPM_BUILD_ROOT
138
75cb386f 139%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%files
efafbc62 145%defattr(644,root,root,755)
51ed65c6 146%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
147%attr(755,root,root) %{_bindir}/ccmake
148%attr(755,root,root) %{_bindir}/cmake
08b6790a 149%attr(755,root,root) %{_bindir}/cpack
72a696fa 150%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
151%{_mandir}/man1/ccmake.1*
152%{_mandir}/man1/cmake.1*
153%{_mandir}/man1/cmakecommands.1*
154%{_mandir}/man1/cmakecompat.1*
155%{_mandir}/man1/cmakemodules.1*
156%{_mandir}/man1/cmakepolicies.1*
157%{_mandir}/man1/cmakeprops.1*
158%{_mandir}/man1/cmakevars.1*
159%{_mandir}/man1/cpack.1*
160%{_mandir}/man1/ctest.1*
b24a2e64
JB
161# top cmake/Modules dirs belong to filesystem
162%{_datadir}/cmake/Modules/.NoDartCoverage
163%{_datadir}/cmake/Modules/*
164%{_datadir}/cmake/Templates
f13d1e41 165%{_datadir}/cmake/editors
b24a2e64 166%{_datadir}/cmake/include
09f5d631 167%{_aclocaldir}/cmake.m4
33042d59 168
1a3a9dcd 169%if %{with gui}
33042d59
KK
170%files gui
171%defattr(644,root,root,755)
172%attr(755,root,root) %{_bindir}/cmake-gui
173%{_datadir}/mime/packages/cmakecache.xml
174%{_desktopdir}/CMake.desktop
ca760f29 175%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 176%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 177%endif
9ec4f08d
KK
178
179%files emacs
180%defattr(644,root,root,755)
181%{_datadir}/emacs/site-lisp/cmake-mode.el
182
183%files -n bash-completion-%{name}
184%defattr(644,root,root,755)
a9b1845f
JB
185%{_datadir}/bash-completion/completions/cmake
186%{_datadir}/bash-completion/completions/cpack
187%{_datadir}/bash-completion/completions/ctest
This page took 0.102423 seconds and 4 git commands to generate.