]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- fix libtool install dir
[packages/cmake.git] / cmake.spec
CommitLineData
efafbc62 1Summary: Cross-platform, open-source make system
ac3ea35a 2Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 3Name: cmake
512f5d39 4Version: 2.4.7
5Release: 1
efafbc62 6License: BSD
72a696fa 7Group: Development/Building
08b6790a 8Source0: http://www.cmake.org/files/v2.4/%{name}-%{version}.tar.gz
512f5d39 9# Source0-md5: 4476c423b8f74266136964e42ea88028
923851a2 10Patch0: %{name}-ncurses.patch
7503d318 11URL: http://www.cmake.org/HTML/Index.html
ece9e155
KK
12BuildRequires: libstdc++-devel
13BuildRequires: ncurses-devel
14BuildRequires: rpmbuild(macros) >= 1.167
efafbc62 15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
16
17%description
efafbc62
AG
18CMake is used to control the software compilation process using simple
19platform and compiler independent configuration files. CMake generates
20native makefiles and workspaces that can be used in the compiler
21environment of your choice. CMake is quite sophisticated: it is
22possible to support complex environments requiring system
23configuration, pre-processor generation, code generation, and template
24instantiation.
3fcbc09a 25
520c9eb8
JR
26%description -l pl.UTF-8
27CMake służy do sterowania procesem kompilacji oprogramowania przy
28użyciu prostych plików konfiguracyjnych niezależnych od platformy i
72a696fa 29kompilatora. CMake generuje natywne pliki makefile i workspace,
520c9eb8
JR
30których można używać w wybranym środowisku kompilatora. CMake jest
31dość przemyślany: może obsłużyć złożone środowiska wymagające
72a696fa 32konfiguracji systemu, generowanie preprocesora, generowanie kodu i
520c9eb8 33dziedziczenie szablonów.
72a696fa 34
3fcbc09a 35%prep
923851a2 36%setup -q
3fcbc09a
AG
37%patch0 -p1
38
ece9e155
KK
39cat > "init.cmake" <<EOF
40SET (CURSES_INCLUDE_PATH "%{_includedir}/ncurses" CACHE PATH " " FORCE)
41EOF
42
3fcbc09a 43%build
ece9e155
KK
44export CC="%{__cc}"
45export CXX="%{__cxx}"
46export CFLAGS="%{rpmcflags}"
47export CXXFLAGS="%{rpmcxxflags}"
923851a2
AG
48./bootstrap \
49 --prefix=%{_prefix} \
50 --mandir=/share/man \
51 --datadir=/share/cmake \
ece9e155 52 --init=init.cmake \
923851a2
AG
53 --verbose
54
923851a2 55%{__make}
3fcbc09a
AG
56
57%install
efafbc62 58rm -rf $RPM_BUILD_ROOT
72a696fa
JB
59
60%{__make} install \
61 DESTDIR=$RPM_BUILD_ROOT
62
c4bbee29 63rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
efafbc62 69%defattr(644,root,root,755)
51ed65c6 70%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
71%attr(755,root,root) %{_bindir}/ccmake
72%attr(755,root,root) %{_bindir}/cmake
08b6790a 73%attr(755,root,root) %{_bindir}/cpack
72a696fa
JB
74%attr(755,root,root) %{_bindir}/ctest
75%{_mandir}/man1/*.1*
923851a2 76%{_datadir}/cmake
This page took 0.047275 seconds and 4 git commands to generate.