]> git.pld-linux.org Git - packages/clusternfs.git/blob - clusternfs.spec
- raw version from Zbyniu <zbyniu@geocarbon.pl>
[packages/clusternfs.git] / clusternfs.spec
1 Summary:        ClusterNFS server
2 Summary(pl):    Serwer ClusterNFS
3 Name:           clusternfs
4 Version:        3.0.rc2
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 URL:            http://clusternfs.sourceforge.net
9 Source0:        http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
10 Source1:        clusternfs.init
11 Requires:       portmap >= 4.0
12 Provides:       nfscluster
13 Conflicts:      nfs-utils nfs-server
14 PreReq:         /sbin/chkconfig
15 PreReq:         rc-scripts
16 BuildRoot:      %{_tmppath}/%{name}-%{version}
17
18 %description
19 ClusterNFS allows diskless clients to share a single root filesystem
20 by matching "tagged" filenames of the form "filename$$TAG=value$$" 
21 with fallback to the original filename.
22
23 %description -l pl
24 ClusterNFS pozwala bezdyskowym klientom wspó³dzieliæ pojedynczy system 
25 plików wybieraj±c odpowiednio "oznakowane" nazwy plików postaci 
26 "plik$$TAG=warto¶æ$$" z podmian± do oryginalnej nazwy.
27
28 %prep
29 rm -fr %{buildroot}
30 %setup -q
31
32 %build
33 ./BUILD --batch \
34         --rquotad=no \
35         --ugidd=no --nis=yes \
36         --hosts-access=yes\
37         --libwrap-directory=%{_libdir} \
38         --exports-uid=0 --exports-gid=0 \
39         --log-mounts=yes --multi=yes \
40         --devtab=yes --trnames=yes \
41         --path_devtab=%{_localstatedir}/nfs/devtab
42
43 make
44
45 %install
46 rm -fr %{buildroot}
47
48 make DESTDIR=%{buildroot} install
49 install -d %{buildroot}/var/adm/fillup-templates %{buildroot}/etc/rc.d/init.d
50 install -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/clusternfs
51
52 %post
53
54 /sbin/chkconfig --add clusternfs
55 if [ -r /var/lock/subsys/clusternfs ]; then
56         /etc/rc.d/init.d/clusternfs restart >&2
57 else
58         echo "Run \"/etc/rc.d/init.d/clusternfs start\" to start nfs daemon."
59 fi
60 #sed -e 's/NFSDTYPE=.*/NFSDTYPE=K/' /etc/sysconfig/nfsd > /etc/sysconfig/nfsd.new
61 #mv -f /etc/sysconfig/nfsd.new /etc/sysconfig/nfsd
62
63 %preun
64 if [ "$1" = "0" ]; then
65         if [ -r /var/lock/subsys/clusternfs ]; then
66                 /etc/rc.d/init.d/clusternfs stop >&2
67         fi
68         /sbin/chkconfig --del clusternfs
69 fi
70                                         
71 %clean
72 rm -fr %{buildroot}
73
74 %files
75 %defattr(-,root,root)
76 %doc BUGS COPYING ChangeLog HALL_OF_FAME NEWS README README.HISTORIC TODO README.ClusterNFS EXAMPLE.ClusterNFS
77 %{_mandir}/man5/*
78 %{_mandir}/man8/[m-r]*
79 %{_localstatedir}/nfs
80 %{_sbindir}/rpc.*
81 %config(noreplace) %{_initrddir}/clusternfs
82
83 %changelog
This page took 0.054255 seconds and 3 git commands to generate.