]> git.pld-linux.org Git - packages/clusternfs.git/blob - clusternfs.spec
- cleaning
[packages/clusternfs.git] / clusternfs.spec
1 Summary:        ClusterNFS server
2 Summary(pl):    Serwer ClusterNFS
3 Name:           clusternfs
4 Version:        3.0
5 Release:        0.rc2.1
6 License:        GPL v2
7 Group:          Networking/Daemons
8 URL:            http://clusternfs.sourceforge.net
9 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}rc2.tar.bz2
10 Source1:        %{name}.init
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 PreReq:         rc-scripts
14 Requires(post,preun):   /sbin/chkconfig
15 Requires:       portmap >= 4.0
16 Provides:       nfscluster
17 Conflicts:      nfs-utils nfs-server
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 ClusterNFS allows diskless clients to share a single root filesystem
22 by matching "tagged" filenames of the form "filename$$TAG=value$$"
23 with fallback to the original filename.
24
25 %description -l pl
26 ClusterNFS pozwala bezdyskowym klientom wspó³dzieliæ pojedynczy system
27 plików wybieraj±c odpowiednio "oznakowane" nazwy plików postaci
28 "plik$$TAG=warto¶æ$$" z podmian± do oryginalnej nazwy.
29
30 %prep
31 %setup -q -n ClusterNFS
32
33 %build
34 mv -f aclocal.m4 acinclude.m4
35 %{__aclocal}
36 %{__autoconf}
37 ./BUILD --batch \
38         --rquotad=no \
39         --ugidd=no --nis=yes \
40         --hosts-access=yes \
41         --libwrap-directory=/usr/lib \
42         --exports-uid=0 --exports-gid=0 \
43         --log-mounts=yes --multi=yes \
44         --devtab=yes --trnames=yes \
45         --path_devtab=/var/lib/clusternfs/devtab
46
47 %configure
48
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/clusternfs
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 /sbin/chkconfig --add clusternfs
65 if [ -r /var/lock/subsys/clusternfs ]; then
66         /etc/rc.d/init.d/clusternfs restart >&2
67 else
68         echo "Run \"/etc/rc.d/init.d/clusternfs start\" to start nfs daemon."
69 fi
70
71 %preun
72 if [ "$1" = "0" ]; then
73         if [ -r /var/lock/subsys/clusternfs ]; then
74                 /etc/rc.d/init.d/clusternfs stop >&2
75         fi
76         /sbin/chkconfig --del clusternfs
77 fi
78
79 %files
80 %defattr(644,root,root,755)
81 %doc BUGS ChangeLog* EXAMPLE.ClusterNFS HALL_OF_FAME NEWS README* TODO*
82 %attr(754,root,root) /etc/rc.d/init.d/clusternfs
83 %attr(755,root,root) %{_sbindir}/rpc.*
84 %{_mandir}/man5/*
85 %{_mandir}/man8/[mn]*
86 /var/lib/clusternfs
This page took 0.114011 seconds and 3 git commands to generate.