]> git.pld-linux.org Git - packages/clusternfs.git/blob - clusternfs.spec
- types.patch, now builds with gcc3
[packages/clusternfs.git] / clusternfs.spec
1 Summary:        ClusterNFS server
2 Summary(pl):    Serwer ClusterNFS
3 Name:           clusternfs
4 Version:        3.0
5 Release:        0.rc2.1
6 License:        GPL v2
7 Group:          Networking/Daemons
8 URL:            http://clusternfs.sourceforge.net/
9 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}rc2.tar.bz2
10 # Source0-md5:  b25b578b2dd3222b554c4953a32efc8f
11 Source1:        %{name}.init
12 Patch0:         %{name}-types.patch
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libwrap-devel
16 PreReq:         rc-scripts
17 Requires(post,preun):   /sbin/chkconfig
18 Requires:       portmap >= 4.0
19 Provides:       nfscluster
20 Conflicts:      nfs-utils nfs-server
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 ClusterNFS allows diskless clients to share a single root filesystem
25 by matching "tagged" filenames of the form "filename$$TAG=value$$"
26 with fallback to the original filename.
27
28 %description -l pl
29 ClusterNFS pozwala bezdyskowym klientom wspó³dzieliæ pojedynczy system
30 plików wybieraj±c odpowiednio "oznakowane" nazwy plików postaci
31 "plik$$TAG=warto¶æ$$" z podmian± do oryginalnej nazwy.
32
33 %prep
34 %setup -q -n ClusterNFS
35 %patch0 -p1
36
37 %build
38 mv -f aclocal.m4 acinclude.m4
39 %{__aclocal}
40 %{__autoconf}
41 ./BUILD --batch \
42         --rquotad=no \
43         --ugidd=no --nis=yes \
44         --hosts-access=yes \
45         --libwrap-directory=/usr/lib \
46         --exports-uid=0 --exports-gid=0 \
47         --log-mounts=yes --multi=yes \
48         --devtab=yes --trnames=yes \
49         --path_devtab=/var/lib/clusternfs/devtab
50
51 %configure
52
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/clusternfs
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 /sbin/chkconfig --add clusternfs
69 if [ -r /var/lock/subsys/clusternfs ]; then
70         /etc/rc.d/init.d/clusternfs restart >&2
71 else
72         echo "Run \"/etc/rc.d/init.d/clusternfs start\" to start nfs daemon."
73 fi
74
75 %preun
76 if [ "$1" = "0" ]; then
77         if [ -r /var/lock/subsys/clusternfs ]; then
78                 /etc/rc.d/init.d/clusternfs stop >&2
79         fi
80         /sbin/chkconfig --del clusternfs
81 fi
82
83 %files
84 %defattr(644,root,root,755)
85 %doc BUGS ChangeLog* EXAMPLE.ClusterNFS HALL_OF_FAME NEWS README* TODO*
86 %attr(754,root,root) /etc/rc.d/init.d/clusternfs
87 %attr(755,root,root) %{_sbindir}/rpc.*
88 %{_mandir}/man5/*
89 %{_mandir}/man8/[mn]*
90 /var/lib/clusternfs
This page took 0.067716 seconds and 3 git commands to generate.