]> git.pld-linux.org Git - packages/closure-stylesheets.git/commitdiff
- up to 20111230 AC-branch auto/ac/closure-stylesheets-20111230-1 auto/th/closure-stylesheets-20111230-1
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 29 Feb 2012 05:45:28 +0000 (05:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    closure-stylesheets.spec -> 1.2
    get-source.sh -> 1.1

closure-stylesheets.spec
get-source.sh [new file with mode: 0644]

index 07d76e28da01fb7c3a9e4610ffe74d78549609e1..e8700b3c36a73ce7f7ce0a1305cf67dab9791a68 100644 (file)
@@ -3,13 +3,14 @@
 %include       /usr/lib/rpm/macros.java
 Summary:       Closure Stylesheets
 Name:          closure-stylesheets
-Version:       1
-Release:       0.1
+Version:       20111230
+Release:       1
 License:       Apache v2.0
 Group:         Applications/WWW
-Source0:       https://closure-stylesheets.googlecode.com/files/%{name}.jar
-# Source0-md5: 4c76e8116f73fe288011bc36c54da69b
+Source0:       https://closure-stylesheets.googlecode.com/files/%{name}-%{version}.jar
+# Source0-md5: eb82b5672843df21ad6fae6eb1547fa1
 Source1:       %{name}.sh
+Source2:       get-source.sh
 URL:           https://code.google.com/p/closure-stylesheets/
 BuildRequires: rpm-javaprov
 BuildRequires: rpmbuild(macros) >= 1.300
diff --git a/get-source.sh b/get-source.sh
new file mode 100644 (file)
index 0000000..e578bfe
--- /dev/null
@@ -0,0 +1,32 @@
+#!/bin/sh
+p=closure-stylesheets
+fn=$p
+svn=http://$p.googlecode.com/svn/trunk
+dl="https://code.google.com/p/$p/downloads/list?can=2&colspec=Filename"
+
+set -x
+set -e
+
+html() {
+       if [ -z "$html" ]; then
+               html=$(lynx -width 1200 -dump -nolist "$dl")
+       fi
+       echo "$html" | tee debug.log
+}
+
+date=$(html | perl -ne '/'$fn'-(\d+).+jar/and print $1 and exit')
+test -n "$date"
+
+echo "Release: $date"
+
+exit 1
+
+d=$p-$date
+if [ ! -d "$d" ]; then
+       svn export -q $svn@$rev $p-$date
+fi
+
+t=$d.tar.bz2
+if [ ! -f "$t" ]; then
+       tar -cjf $t --exclude-vcs $d
+fi
This page took 0.075046 seconds and 4 git commands to generate.