]> git.pld-linux.org Git - packages/closure-compiler.git/blob - closure-compiler.spec
up to 20131014 (October 14, 2013)
[packages/closure-compiler.git] / closure-compiler.spec
1 # NOTE:
2 # - check release notes from here https://code.google.com/p/closure-compiler/wiki/Releases
3 # TODO
4 # - build from source (get-source.sh fetches it)
5
6 %include        /usr/lib/rpm/macros.java
7 Summary:        Closure Compiler - JavaScript compressor
8 Name:           closure-compiler
9 Version:        20131014
10 Release:        1
11 License:        Apache v2.0
12 Group:          Applications/WWW
13 # Source0Download: https://code.google.com/p/closure-compiler/downloads/list
14 Source0:        http://closure-compiler.googlecode.com/files/compiler-%{version}.tar.gz
15 # Source0-md5:  37e8eb83d3fe271a002f41e7c2d1e2d7
16 Source1:        %{name}.sh
17 Source2:        get-source.sh
18 Source4:        Changes
19 URL:            http://closure-compiler.appspot.com/
20 BuildRequires:  rpm-javaprov
21 BuildRequires:  rpmbuild(macros) >= 1.300
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Closure Compiler is a tool for making JavaScript download and run
27 faster. It is a true compiler for JavaScript. Instead of compiling
28 from a source language to machine code, it compiles from JavaScript to
29 better JavaScript. It parses your JavaScript, analyzes it, removes
30 dead code and rewrites and minimizes what's left. It also checks
31 syntax, variable references, and types, and warns about common
32 JavaScript pitfalls.
33
34 %prep
35 %setup -qc
36 cp -p %{SOURCE4} .
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_bindir},%{_javadir}}
41 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}
42
43 # jars
44 cp -p compiler.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
45 ln -s %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc README Changes
53 %attr(755,root,root) %{_bindir}/%{name}
54 %{_javadir}/*.jar
This page took 0.052574 seconds and 3 git commands to generate.