]> git.pld-linux.org Git - packages/closure-compiler.git/blob - closure-compiler.spec
8c86765e1f2781f5d3ad021208dcd177ab6de0f7
[packages/closure-compiler.git] / closure-compiler.spec
1 # TODO
2 # - build from source (get-source.sh fetches it)
3
4 %include        /usr/lib/rpm/macros.java
5 Summary:        Closure Compiler - JavaScript compressor
6 Name:           closure-compiler
7 Version:        20130227
8 Release:        1
9 License:        Apache v2.0
10 Group:          Applications/WWW
11 # Source0Download: https://code.google.com/p/closure-compiler/downloads/list
12 Source0:        http://closure-compiler.googlecode.com/files/compiler-%{version}.tar.gz
13 # Source0-md5:  7b7b88cb8237f43e263b3583f8a7ea5d
14 Source1:        %{name}.sh
15 Source2:        get-source.sh
16 Source3:        gen-changes.sh
17 Source4:        Changes
18 URL:            http://closure-compiler.appspot.com/
19 BuildRequires:  rpm-javaprov
20 BuildRequires:  rpmbuild(macros) >= 1.300
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Closure Compiler is a tool for making JavaScript download and run
26 faster. It is a true compiler for JavaScript. Instead of compiling
27 from a source language to machine code, it compiles from JavaScript to
28 better JavaScript. It parses your JavaScript, analyzes it, removes
29 dead code and rewrites and minimizes what's left. It also checks
30 syntax, variable references, and types, and warns about common
31 JavaScript pitfalls.
32
33 %prep
34 %setup -qc
35 cp -p %{SOURCE4} .
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{%{_bindir},%{_javadir}}
40 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}
41
42 # jars
43 cp -p compiler.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
44 ln -s %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc README Changes
52 %attr(755,root,root) %{_bindir}/%{name}
53 %{_javadir}/*.jar
This page took 0.040659 seconds and 2 git commands to generate.