]> git.pld-linux.org Git - packages/closure-compiler.git/blame - closure-compiler.spec
- new
[packages/closure-compiler.git] / closure-compiler.spec
CommitLineData
65a15527
ER
1# TODO
2# - build from source
3# - NOTE: build-data.properties is included twice in .jar
4
5%include /usr/lib/rpm/macros.java
6Summary: Closure Compiler - JavaScript compressor
7Name: closure-compiler
8Version: 20100201
9Release: 0.1
10License: Apache v2.0
11Group: Applications/WWW
12Source0: http://closure-compiler.googlecode.com/files/compiler-%{version}.tar.gz
13# Source0-md5: 71bb4f8975ffc81fd0b9a82e18318a49
14URL: http://closure-compiler.appspot.com/
15BuildRequires: rpm-javaprov
16BuildRequires: rpmbuild(macros) >= 1.300
17BuildArch: noarch
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21Closure Compiler is a JavaScript optimizing compiler. It parses your
22JavaScript, analyzes it, removes dead code and rewrites and minimizes
23what's left. It also checks syntax, variable references, and types,
24and warns about common JavaScript pitfalls. It is used in many of
25Google's JavaScript apps, including Gmail, Google Web Search, Google
26Maps, and Google Docs.
27
28%prep
29%setup -qc
30
31cat <<'EOF' >> %{name}
32#!/bin/sh
33exec java -jar %{_javadir}/%{name}.jar "$@"
34EOF
35
36%install
37rm -rf $RPM_BUILD_ROOT
38install -d $RPM_BUILD_ROOT{%{_bindir},%{_javadir}}
39install -p %{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
40
41# jars
42cp -a compiler.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
43ln -s %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
44
45%clean
46rm -rf $RPM_BUILD_ROOT
47
48%files
49%defattr(644,root,root,755)
50%doc README
51%attr(755,root,root) %{_bindir}/%{name}
52%{_javadir}/*.jar
This page took 0.052237 seconds and 4 git commands to generate.