]> git.pld-linux.org Git - packages/cloog.git/blob - cloog.spec
adee501f1c9fb9ce4e3151edca7e347b76394689
[packages/cloog.git] / cloog.spec
1 %define         tarball_name %{name}-ppl
2 Summary:        The Chunky Loop Generator
3 Name:           cloog
4 Version:        0.15.9
5 Release:        0.1
6 License:        GPL v2+
7 Group:          Libraries
8 URL:            http://www.cloog.org/
9 Source0:        ftp://gcc.gnu.org/pub/gcc/infrastructure/%{tarball_name}-%{version}.tar.gz
10 # Source0-md5:  806e001d1b1a6b130069ff6274900af5
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  gmp-devel >= 4.1.3
14 BuildRequires:  libtool
15 BuildRequires:  libtool
16 BuildRequires:  ppl-devel >= 0.10
17 BuildRequires:  texinfo >= 4.12
18 Requires(post): /sbin/ldconfig
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 CLooG is a software which generates loops for scanning Z-polyhedra.
23 That is, CLooG finds the code or pseudo-code where each integral point
24 of one or more parametrized polyhedron or parametrized polyhedra union
25 is reached. CLooG is designed to avoid control overhead and to produce
26 a very efficient code.
27
28 %package ppl
29 Summary:        Parma Polyhedra Library backend (ppl) based version of the Cloog binaries
30 Group:          Development/Libraries
31
32 %description ppl
33 The dynamic shared libraries of the Chunky Loop Generator
34
35 %package ppl-devel
36 Summary:        Development tools for the ppl based version of Chunky Loop Generator
37 Group:          Development/Libraries
38 Requires:       %{name}-ppl = %{version}-%{release}
39 Requires:       gmp-devel >= 4.1.3
40 Requires:       ppl-devel >= 0.10
41
42 %description ppl-devel
43 The header files and dynamic shared libraries of the Chunky Loop
44 Generator.
45
46 %prep
47 %setup -q -n %{tarball_name}-%{version}
48
49 sed -i -e s/ppl_minor_version=10/ppl_minor_version=11/  configure*
50
51 %build
52 %{__libtoolize}
53 %{__aclocal}
54 %{__autoconf}
55 %{__autoheader}
56 %{__automake}
57 %configure \
58         --disable-static \
59         --with-ppl
60
61 # Remove the cloog.info in the tarball
62 # to force the re-generation of a new one
63 test -f doc/cloog.info && rm doc/cloog.info
64
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %{__make} install \
70         INSTALL="%{__install} -p" \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
74 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post ppl       -p /sbin/postshell
80 /sbin/ldconfig
81 -/usr/sbin/fix-info-dir -c %{_infodir}
82
83 %preun ppl
84 if [ "$1" = 0 ]; then
85         [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
86 fi
87
88 %postun ppl -p /sbin/ldconfig
89
90 %files ppl
91 %defattr(644,root,root,755)
92 %doc README LICENSE
93 %attr(755,root,root) %{_bindir}/cloog
94 %{_libdir}/libcloog.so.*
95 %{_infodir}/cloog.info*
96
97 %files ppl-devel
98 %defattr(644,root,root,755)
99 %{_includedir}/cloog
100 %{_libdir}/libcloog.so
This page took 0.054062 seconds and 2 git commands to generate.