]> git.pld-linux.org Git - packages/cloog.git/blob - cloog.spec
4e69168a36aaebce662c94c24d6a379765e22104
[packages/cloog.git] / cloog.spec
1 %define         tarball_name %{name}-ppl
2 Summary:        The Chunky Loop Generator
3 Summary(pl.UTF-8):      Chunky Loop Generator - generator pętli cząstkowych
4 Name:           cloog
5 Version:        0.15.11
6 Release:        1
7 License:        GPL v2+
8 Group:          Libraries
9 Source0:        ftp://gcc.gnu.org/pub/gcc/infrastructure/%{tarball_name}-%{version}.tar.gz
10 # Source0-md5:  060ae4df6fb8176e021b4d033a6c0b9e
11 URL:            http://www.cloog.org/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  gmp-devel >= 4.1.3
15 BuildRequires:  gmp-c++-devel >= 4.1.3
16 BuildRequires:  libtool
17 BuildRequires:  ppl-devel >= 0.10
18 BuildRequires:  sed >= 4.0
19 BuildRequires:  texinfo >= 4.12
20 Requires(post): /sbin/ldconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 CLooG is a software which generates loops for scanning Z-polyhedra.
25 That is, CLooG finds the code or pseudo-code where each integral point
26 of one or more parametrized polyhedron or parametrized polyhedra union
27 is reached. CLooG is designed to avoid control overhead and to produce
28 a very efficient code.
29
30 %description -l pl.UTF-8
31 CLooG to oprogramowanie generujące pętle do przeszukiwania
32 Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
33 pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
34 sparametryzowanych wielościanów lub sum sparametryzowanych
35 wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
36 narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
37
38 %package ppl
39 Summary:        Parma Polyhedra Library backend (ppl) based version of the Cloog binaries
40 Summary(pl.UTF-8):      Binaria CLooG w wersji opartej na bibliotece PPL (Parma Polyhedra Library)
41 Group:          Development/Tools
42
43 %description ppl
44 The dynamic shared library and utility of the Chunky Loop Generator.
45
46 %description ppl -l pl.UTF-8
47 Biblioteka współdzielona i narzędzie Chunky Loop Generatora.
48
49 %package ppl-devel
50 Summary:        Header files for the ppl based version of Chunky Loop Generator
51 Summary(pl.UTF-8):      Pliki nagłówkowe opartej na ppl wersji Chunky Loop Generatora
52 Group:          Development/Libraries
53 Requires:       %{name}-ppl = %{version}-%{release}
54 Requires:       gmp-devel >= 4.1.3
55 Requires:       gmp-c++-devel >= 4.1.3
56 Requires:       ppl-devel >= 0.10
57
58 %description ppl-devel
59 The header files for Chunky Loop Generator library.
60
61 %description ppl-devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki Chunky Loop Generatora.
63
64 %package ppl-static
65 Summary:        Static library of ppl based version of Chunky Loop Generator
66 Summary(pl.UTF-8):      Statyczna biblioteka opartej na ppl wersji Chunky Loop Generatora
67 Group:          Development/Libraries
68 Requires:       %{name}-ppl-devel = %{version}-%{release}
69
70 %description ppl-static
71 Static library of ppl based version of Chunky Loop Generator.
72
73 %description ppl-static -l pl.UTF-8
74 Statyczna biblioteka opartej na ppl wersji Chunky Loop Generatora.
75
76 %prep
77 %setup -q -n %{tarball_name}-%{version}
78
79 sed -i -e s/ppl_minor_version=10/ppl_minor_version=11/  configure*
80
81 %build
82 %{__libtoolize}
83 %{__aclocal}
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         --with-ppl
89
90 # Remove the cloog.info in the tarball
91 # to force the re-generation of a new one
92 test -f doc/cloog.info && %{__rm} doc/cloog.info
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         INSTALL="%{__install} -p" \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   ppl -p /sbin/postshell
109 /sbin/ldconfig
110 -/usr/sbin/fix-info-dir -c %{_infodir}
111
112 %preun  ppl
113 if [ "$1" = 0 ]; then
114         [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
115 fi
116
117 %postun ppl -p /sbin/ldconfig
118
119 %files ppl
120 %defattr(644,root,root,755)
121 %doc LICENSE README
122 %attr(755,root,root) %{_bindir}/cloog
123 %attr(755,root,root) %{_libdir}/libcloog.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libcloog.so.0
125 %{_infodir}/cloog.info*
126
127 %files ppl-devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libcloog.so
130 %{_libdir}/libcloog.la
131 %{_includedir}/cloog
132
133 %files ppl-static
134 %defattr(644,root,root,755)
135 %{_libdir}/libcloog.a
This page took 0.079194 seconds and 2 git commands to generate.