]> git.pld-linux.org Git - packages/cloog.git/blame_incremental - cloog.spec
- added info patch (unify direntry)
[packages/cloog.git] / cloog.spec
... / ...
CommitLineData
1%define tarball_name %{name}-ppl
2Summary: The Chunky Loop Generator
3Summary(pl.UTF-8): Chunky Loop Generator - generator pętli cząstkowych
4Name: cloog
5Version: 0.15.11
6Release: 1
7License: GPL v2+
8Group: Libraries
9Source0: ftp://gcc.gnu.org/pub/gcc/infrastructure/%{tarball_name}-%{version}.tar.gz
10# Source0-md5: 060ae4df6fb8176e021b4d033a6c0b9e
11Patch0: %{name}-info.patch
12URL: http://www.cloog.org/
13BuildRequires: autoconf >= 2.13
14BuildRequires: automake
15BuildRequires: gmp-devel >= 4.1.3
16BuildRequires: gmp-c++-devel >= 4.1.3
17BuildRequires: libtool
18BuildRequires: ppl-devel >= 0.10
19BuildRequires: texinfo >= 4.12
20Requires(post): /sbin/ldconfig
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24CLooG is a software which generates loops for scanning Z-polyhedra.
25That is, CLooG finds the code or pseudo-code where each integral point
26of one or more parametrized polyhedron or parametrized polyhedra union
27is reached. CLooG is designed to avoid control overhead and to produce
28a very efficient code.
29
30%description -l pl.UTF-8
31CLooG to oprogramowanie generujące pętle do przeszukiwania
32Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
33pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
34sparametryzowanych wielościanów lub sum sparametryzowanych
35wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
36narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
37
38%package ppl
39Summary: Parma Polyhedra Library backend (ppl) based version of the Cloog binaries
40Summary(pl.UTF-8): Binaria CLooG w wersji opartej na bibliotece PPL (Parma Polyhedra Library)
41Group: Development/Tools
42
43%description ppl
44The dynamic shared library and utility of the Chunky Loop Generator.
45
46%description ppl -l pl.UTF-8
47Biblioteka współdzielona i narzędzie Chunky Loop Generatora.
48
49%package ppl-devel
50Summary: Header files for the ppl based version of Chunky Loop Generator
51Summary(pl.UTF-8): Pliki nagłówkowe opartej na ppl wersji Chunky Loop Generatora
52Group: Development/Libraries
53Requires: %{name}-ppl = %{version}-%{release}
54Requires: gmp-devel >= 4.1.3
55Requires: gmp-c++-devel >= 4.1.3
56Requires: ppl-devel >= 0.10
57
58%description ppl-devel
59The header files for Chunky Loop Generator library.
60
61%description ppl-devel -l pl.UTF-8
62Pliki nagłówkowe biblioteki Chunky Loop Generatora.
63
64%package ppl-static
65Summary: Static library of ppl based version of Chunky Loop Generator
66Summary(pl.UTF-8): Statyczna biblioteka opartej na ppl wersji Chunky Loop Generatora
67Group: Development/Libraries
68Requires: %{name}-ppl-devel = %{version}-%{release}
69
70%description ppl-static
71Static library of ppl based version of Chunky Loop Generator.
72
73%description ppl-static -l pl.UTF-8
74Statyczna biblioteka opartej na ppl wersji Chunky Loop Generatora.
75
76%prep
77%setup -q -n %{tarball_name}-%{version}
78%patch0 -p1
79
80%build
81%{__libtoolize}
82%{__aclocal}
83%{__autoconf}
84%{__autoheader}
85%{__automake}
86%configure \
87 --with-ppl
88
89# Remove the cloog.info in the tarball
90# to force the re-generation of a new one
91test -f doc/cloog.info && %{__rm} doc/cloog.info
92
93%{__make}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98%{__make} install \
99 INSTALL="%{__install} -p" \
100 DESTDIR=$RPM_BUILD_ROOT
101
102rm -f $RPM_BUILD_ROOT%{_infodir}/dir
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post ppl -p /sbin/postshell
108/sbin/ldconfig
109-/usr/sbin/fix-info-dir -c %{_infodir}
110
111%preun ppl
112if [ "$1" = 0 ]; then
113 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
114fi
115
116%postun ppl -p /sbin/ldconfig
117
118%files ppl
119%defattr(644,root,root,755)
120%doc LICENSE README
121%attr(755,root,root) %{_bindir}/cloog
122%attr(755,root,root) %{_libdir}/libcloog.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libcloog.so.0
124%{_infodir}/cloog.info*
125
126%files ppl-devel
127%defattr(644,root,root,755)
128%attr(755,root,root) %{_libdir}/libcloog.so
129%{_libdir}/libcloog.la
130%{_includedir}/cloog
131
132%files ppl-static
133%defattr(644,root,root,755)
134%{_libdir}/libcloog.a
This page took 0.11966 seconds and 4 git commands to generate.