]> git.pld-linux.org Git - packages/cloog.git/blame_incremental - cloog.spec
- rel 1
[packages/cloog.git] / cloog.spec
... / ...
CommitLineData
1%define tarball_name %{name}-ppl
2Summary: The Chunky Loop Generator
3Name: cloog
4Version: 0.15.9
5Release: 1
6License: GPL v2+
7Group: Libraries
8URL: http://www.cloog.org/
9Source0: ftp://gcc.gnu.org/pub/gcc/infrastructure/%{tarball_name}-%{version}.tar.gz
10# Source0-md5: 806e001d1b1a6b130069ff6274900af5
11BuildRequires: autoconf
12BuildRequires: automake
13BuildRequires: gmp-devel >= 4.1.3
14BuildRequires: libtool
15BuildRequires: libtool
16BuildRequires: ppl-devel >= 0.10
17BuildRequires: texinfo >= 4.12
18Requires(post): /sbin/ldconfig
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22CLooG is a software which generates loops for scanning Z-polyhedra.
23That is, CLooG finds the code or pseudo-code where each integral point
24of one or more parametrized polyhedron or parametrized polyhedra union
25is reached. CLooG is designed to avoid control overhead and to produce
26a very efficient code.
27
28%package ppl
29Summary: Parma Polyhedra Library backend (ppl) based version of the Cloog binaries
30Group: Development/Libraries
31
32%description ppl
33The dynamic shared libraries of the Chunky Loop Generator
34
35%package ppl-devel
36Summary: Development tools for the ppl based version of Chunky Loop Generator
37Group: Development/Libraries
38Requires: %{name}-ppl = %{version}-%{release}
39Requires: gmp-devel >= 4.1.3
40Requires: ppl-devel >= 0.10
41
42%description ppl-devel
43The header files and dynamic shared libraries of the Chunky Loop
44Generator.
45
46%prep
47%setup -q -n %{tarball_name}-%{version}
48
49sed -i -e s/ppl_minor_version=10/ppl_minor_version=11/ configure*
50
51%build
52%{__libtoolize}
53%{__aclocal}
54%{__autoconf}
55%{__autoheader}
56%{__automake}
57%configure \
58 --disable-static \
59 --with-ppl
60
61# Remove the cloog.info in the tarball
62# to force the re-generation of a new one
63test -f doc/cloog.info && rm doc/cloog.info
64
65%{__make}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69%{__make} install \
70 INSTALL="%{__install} -p" \
71 DESTDIR=$RPM_BUILD_ROOT
72
73%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
74rm -f $RPM_BUILD_ROOT%{_infodir}/dir
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post ppl -p /sbin/postshell
80/sbin/ldconfig
81-/usr/sbin/fix-info-dir -c %{_infodir}
82
83%preun ppl
84if [ "$1" = 0 ]; then
85 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
86fi
87
88%postun ppl -p /sbin/ldconfig
89
90%files ppl
91%defattr(644,root,root,755)
92%doc README LICENSE
93%attr(755,root,root) %{_bindir}/cloog
94%{_libdir}/libcloog.so.*
95%{_infodir}/cloog.info*
96
97%files ppl-devel
98%defattr(644,root,root,755)
99%{_includedir}/cloog
100%{_libdir}/libcloog.so
This page took 0.069331 seconds and 4 git commands to generate.