]> git.pld-linux.org Git - packages/cloog.git/blame - cloog.spec
- up to 0.15.11
[packages/cloog.git] / cloog.spec
CommitLineData
484e740b
ER
1%define tarball_name %{name}-ppl
2Summary: The Chunky Loop Generator
3Name: cloog
a0c01b57 4Version: 0.15.11
d84b836a 5Release: 1
484e740b
ER
6License: GPL v2+
7Group: Libraries
8URL: http://www.cloog.org/
9Source0: ftp://gcc.gnu.org/pub/gcc/infrastructure/%{tarball_name}-%{version}.tar.gz
a0c01b57 10# Source0-md5: 060ae4df6fb8176e021b4d033a6c0b9e
484e740b
ER
11BuildRequires: autoconf
12BuildRequires: automake
13BuildRequires: gmp-devel >= 4.1.3
a0c01b57 14BuildRequires: gmp-c++-devel >= 4.1.3
484e740b
ER
15BuildRequires: libtool
16BuildRequires: libtool
17BuildRequires: ppl-devel >= 0.10
18BuildRequires: texinfo >= 4.12
19Requires(post): /sbin/ldconfig
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23CLooG is a software which generates loops for scanning Z-polyhedra.
24That is, CLooG finds the code or pseudo-code where each integral point
25of one or more parametrized polyhedron or parametrized polyhedra union
26is reached. CLooG is designed to avoid control overhead and to produce
27a very efficient code.
28
29%package ppl
30Summary: Parma Polyhedra Library backend (ppl) based version of the Cloog binaries
31Group: Development/Libraries
32
33%description ppl
34The dynamic shared libraries of the Chunky Loop Generator
35
36%package ppl-devel
37Summary: Development tools for the ppl based version of Chunky Loop Generator
38Group: Development/Libraries
39Requires: %{name}-ppl = %{version}-%{release}
40Requires: gmp-devel >= 4.1.3
41Requires: ppl-devel >= 0.10
42
43%description ppl-devel
44The header files and dynamic shared libraries of the Chunky Loop
45Generator.
46
47%prep
48%setup -q -n %{tarball_name}-%{version}
49
50sed -i -e s/ppl_minor_version=10/ppl_minor_version=11/ configure*
51
52%build
53%{__libtoolize}
54%{__aclocal}
55%{__autoconf}
56%{__autoheader}
57%{__automake}
58%configure \
59 --disable-static \
60 --with-ppl
61
62# Remove the cloog.info in the tarball
63# to force the re-generation of a new one
64test -f doc/cloog.info && rm doc/cloog.info
65
66%{__make}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70%{__make} install \
71 INSTALL="%{__install} -p" \
72 DESTDIR=$RPM_BUILD_ROOT
73
74%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
75rm -f $RPM_BUILD_ROOT%{_infodir}/dir
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post ppl -p /sbin/postshell
81/sbin/ldconfig
82-/usr/sbin/fix-info-dir -c %{_infodir}
83
84%preun ppl
85if [ "$1" = 0 ]; then
86 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
87fi
88
89%postun ppl -p /sbin/ldconfig
90
91%files ppl
92%defattr(644,root,root,755)
93%doc README LICENSE
94%attr(755,root,root) %{_bindir}/cloog
95%{_libdir}/libcloog.so.*
96%{_infodir}/cloog.info*
97
98%files ppl-devel
99%defattr(644,root,root,755)
100%{_includedir}/cloog
101%{_libdir}/libcloog.so
This page took 0.100699 seconds and 4 git commands to generate.