]> git.pld-linux.org Git - packages/cloog.git/blame - cloog.spec
- added info patch (unify direntry)
[packages/cloog.git] / cloog.spec
CommitLineData
484e740b
ER
1%define tarball_name %{name}-ppl
2Summary: The Chunky Loop Generator
3573eb98 3Summary(pl.UTF-8): Chunky Loop Generator - generator pętli cząstkowych
484e740b 4Name: cloog
a0c01b57 5Version: 0.15.11
d84b836a 6Release: 1
484e740b
ER
7License: GPL v2+
8Group: Libraries
484e740b 9Source0: ftp://gcc.gnu.org/pub/gcc/infrastructure/%{tarball_name}-%{version}.tar.gz
a0c01b57 10# Source0-md5: 060ae4df6fb8176e021b4d033a6c0b9e
ed7d4f7b 11Patch0: %{name}-info.patch
3573eb98 12URL: http://www.cloog.org/
ed7d4f7b 13BuildRequires: autoconf >= 2.13
484e740b
ER
14BuildRequires: automake
15BuildRequires: gmp-devel >= 4.1.3
a0c01b57 16BuildRequires: gmp-c++-devel >= 4.1.3
484e740b 17BuildRequires: libtool
484e740b
ER
18BuildRequires: ppl-devel >= 0.10
19BuildRequires: texinfo >= 4.12
20Requires(post): /sbin/ldconfig
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24CLooG is a software which generates loops for scanning Z-polyhedra.
25That is, CLooG finds the code or pseudo-code where each integral point
26of one or more parametrized polyhedron or parametrized polyhedra union
27is reached. CLooG is designed to avoid control overhead and to produce
28a very efficient code.
29
3573eb98
JB
30%description -l pl.UTF-8
31CLooG to oprogramowanie generujące pętle do przeszukiwania
32Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
33pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
34sparametryzowanych wielościanów lub sum sparametryzowanych
35wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
36narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
37
484e740b
ER
38%package ppl
39Summary: Parma Polyhedra Library backend (ppl) based version of the Cloog binaries
3573eb98
JB
40Summary(pl.UTF-8): Binaria CLooG w wersji opartej na bibliotece PPL (Parma Polyhedra Library)
41Group: Development/Tools
484e740b
ER
42
43%description ppl
3573eb98
JB
44The dynamic shared library and utility of the Chunky Loop Generator.
45
46%description ppl -l pl.UTF-8
47Biblioteka współdzielona i narzędzie Chunky Loop Generatora.
484e740b
ER
48
49%package ppl-devel
3573eb98
JB
50Summary: Header files for the ppl based version of Chunky Loop Generator
51Summary(pl.UTF-8): Pliki nagłówkowe opartej na ppl wersji Chunky Loop Generatora
484e740b
ER
52Group: Development/Libraries
53Requires: %{name}-ppl = %{version}-%{release}
54Requires: gmp-devel >= 4.1.3
3573eb98 55Requires: gmp-c++-devel >= 4.1.3
484e740b
ER
56Requires: ppl-devel >= 0.10
57
58%description ppl-devel
3573eb98
JB
59The header files for Chunky Loop Generator library.
60
61%description ppl-devel -l pl.UTF-8
62Pliki nagłówkowe biblioteki Chunky Loop Generatora.
63
64%package ppl-static
65Summary: Static library of ppl based version of Chunky Loop Generator
66Summary(pl.UTF-8): Statyczna biblioteka opartej na ppl wersji Chunky Loop Generatora
67Group: Development/Libraries
68Requires: %{name}-ppl-devel = %{version}-%{release}
69
70%description ppl-static
71Static library of ppl based version of Chunky Loop Generator.
72
73%description ppl-static -l pl.UTF-8
74Statyczna biblioteka opartej na ppl wersji Chunky Loop Generatora.
484e740b
ER
75
76%prep
77%setup -q -n %{tarball_name}-%{version}
ed7d4f7b 78%patch0 -p1
484e740b
ER
79
80%build
81%{__libtoolize}
82%{__aclocal}
83%{__autoconf}
84%{__autoheader}
85%{__automake}
86%configure \
484e740b
ER
87 --with-ppl
88
89# Remove the cloog.info in the tarball
90# to force the re-generation of a new one
3573eb98 91test -f doc/cloog.info && %{__rm} doc/cloog.info
484e740b
ER
92
93%{__make}
94
95%install
96rm -rf $RPM_BUILD_ROOT
3573eb98 97
484e740b
ER
98%{__make} install \
99 INSTALL="%{__install} -p" \
100 DESTDIR=$RPM_BUILD_ROOT
101
484e740b
ER
102rm -f $RPM_BUILD_ROOT%{_infodir}/dir
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
3573eb98 107%post ppl -p /sbin/postshell
484e740b
ER
108/sbin/ldconfig
109-/usr/sbin/fix-info-dir -c %{_infodir}
110
3573eb98 111%preun ppl
484e740b
ER
112if [ "$1" = 0 ]; then
113 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
114fi
115
3573eb98 116%postun ppl -p /sbin/ldconfig
484e740b
ER
117
118%files ppl
119%defattr(644,root,root,755)
3573eb98 120%doc LICENSE README
484e740b 121%attr(755,root,root) %{_bindir}/cloog
3573eb98
JB
122%attr(755,root,root) %{_libdir}/libcloog.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libcloog.so.0
484e740b
ER
124%{_infodir}/cloog.info*
125
126%files ppl-devel
127%defattr(644,root,root,755)
3573eb98
JB
128%attr(755,root,root) %{_libdir}/libcloog.so
129%{_libdir}/libcloog.la
484e740b 130%{_includedir}/cloog
3573eb98
JB
131
132%files ppl-static
133%defattr(644,root,root,755)
134%{_libdir}/libcloog.a
This page took 0.079003 seconds and 4 git commands to generate.