]> git.pld-linux.org Git - packages/cloog-isl.git/blob - cloog-isl.spec
- updated to 0.21.1; isl 0.26, osl 0.9.7
[packages/cloog-isl.git] / cloog-isl.spec
1 #
2 # Conditional build:
3 %bcond_without  osl     # OpenScop support
4 #
5 %define isl_ver 0.15
6 Summary:        The Chunky Loop Generator
7 Summary(pl.UTF-8):      Chunky Loop Generator - generator pętli cząstkowych
8 Name:           cloog-isl
9 Version:        0.18.4
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Development/Tools
13 # git clone git://repo.or.cz/cloog.git -b cloog-0.18.4 cloog-0.18.4
14 #Source0:       http://pkgs.fedoraproject.org/repo/pkgs/cloog/cloog-%{version}.tar.gz/a65195e2f1fe1b91826b18a185d82859/cloog-%{version}.tar.gz
15 Source0:        http://www.bastoul.net/cloog/pages/download/cloog-%{version}.tar.gz
16 # Source0-md5:  e531f725244856c92c9bba009ff44faf
17 URL:            http://www.cloog.org/
18 BuildRequires:  autoconf >= 2.53
19 BuildRequires:  automake
20 BuildRequires:  gmp-devel >= 5.0.2
21 BuildRequires:  gmp-c++-devel >= 5.0.2
22 BuildRequires:  isl-devel >= %{isl_ver}
23 BuildRequires:  libtool
24 %{?with_osl:BuildRequires:      osl-devel}
25 BuildRequires:  texinfo-texi2dvi
26 Requires:       %{name}-libs = %{version}-%{release}
27 Provides:       cloog = %{version}
28 Obsoletes:      cloog
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 CLooG is a software which generates loops for scanning Z-polyhedra.
33 That is, CLooG finds the code or pseudo-code where each integral point
34 of one or more parametrized polyhedron or parametrized polyhedra union
35 is reached. CLooG is designed to avoid control overhead and to produce
36 a very efficient code.
37
38 This version is based on isl.
39
40 %description -l pl.UTF-8
41 CLooG to oprogramowanie generujące pętle do przeszukiwania
42 Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
43 pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
44 sparametryzowanych wielościanów lub sum sparametryzowanych
45 wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
46 narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
47
48 Ta wersja jest oparta na bibliotece isl.
49
50 %package libs
51 Summary:        Chunky Loop Generator shared library - isl based version
52 Summary(pl.UTF-8):      Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na isl
53 Group:          Libraries
54 Requires:       isl >= %{isl_ver}
55
56 %description libs
57 Chunky Loop Generator shared library - isl based version.
58
59 %description libs -l pl.UTF-8
60 Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na
61 isl.
62
63 %package devel
64 Summary:        Header files for the isl based version of Chunky Loop Generator
65 Summary(pl.UTF-8):      Pliki nagłówkowe opartej na isl wersji Chunky Loop Generatora
66 Group:          Development/Libraries
67 Requires:       %{name}-libs = %{version}-%{release}
68 Requires:       gmp-devel >= 5.0.2
69 Requires:       gmp-c++-devel >= 5.0.2
70 Requires:       isl-devel >= %{isl_ver}
71 %{?with_osl:Requires:   osl-devel}
72 Provides:       cloog-devel = %{version}
73
74 %description devel
75 The header files for Chunky Loop Generator library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki Chunky Loop Generatora.
79
80 %package static
81 Summary:        Static library of isl based version of Chunky Loop Generator
82 Summary(pl.UTF-8):      Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static library of isl based version of Chunky Loop Generator.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora.
91
92 %prep
93 %setup -q -n cloog-%{version}
94
95 %build
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__automake}
100 # with_gmp_exec_prefix=yes avoids adding -L/lib to LDFLAGS
101 %configure \
102         --disable-silent-rules \
103         --with-gmp-exec-prefix \
104         --with-isl=system \
105         %{?with_osl:--with-osl=system}
106
107 %{__make}
108
109 %{__make} -C doc cloog.pdf
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   libs -p /sbin/ldconfig
121 %postun libs -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_bindir}/cloog
126
127 %files libs
128 %defattr(644,root,root,755)
129 %doc ChangeLog README
130 %attr(755,root,root) %{_libdir}/libcloog-isl.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libcloog-isl.so.4
132
133 %files devel
134 %defattr(644,root,root,755)
135 %doc doc/cloog.pdf
136 %attr(755,root,root) %{_libdir}/libcloog-isl.so
137 %{_libdir}/libcloog-isl.la
138 %dir %{_includedir}/cloog
139 %{_includedir}/cloog/*.h
140 %{_includedir}/cloog/isl
141 %{_includedir}/cloog/matrix
142 %dir %{_libdir}/cloog-isl
143 %{_libdir}/cloog-isl/cloog-isl-config.cmake
144 %dir %{_libdir}/isl
145 %{_libdir}/isl/isl-config.cmake
146 %{_pkgconfigdir}/cloog-isl.pc
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libcloog-isl.a
This page took 0.043115 seconds and 3 git commands to generate.