]> git.pld-linux.org Git - packages/cln.git/blame_incremental - cln.spec
- updated to 1.3.2
[packages/cln.git] / cln.spec
... / ...
CommitLineData
1Summary: C++ Class Library for Numbers
2Summary(pl.UTF-8): Biblioteka klas C++ dla liczb
3Name: cln
4Version: 1.3.2
5Release: 1
6License: GPL
7Group: Libraries
8Source0: ftp://ftpthep.physik.uni-mainz.de/pub/gnu/%{name}-%{version}.tar.bz2
9# Source0-md5: d897cce94d9c34d106575ed4ec865d71
10Patch0: %{name}-info.patch
11URL: http://www.ginac.de/CLN/
12BuildRequires: autoconf >= 2.59
13BuildRequires: automake >= 1:1.10
14BuildRequires: gmp-devel >= 3.0
15BuildRequires: libstdc++-devel
16BuildRequires: libtool >= 2:1.5
17BuildRequires: tetex-dvips
18BuildRequires: tetex-fonts-latex
19BuildRequires: tetex-format-plain
20BuildRequires: tetex-metafont
21BuildRequires: texconfig
22BuildRequires: texinfo
23BuildRequires: texinfo-texi2dvi
24Requires: gmp >= 3.0
25Obsoletes: libcln2
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28# won't work with -O0 because of static const initialization loops
29%define debugcflags -O1 -g
30
31%description
32A GPLed collection of C++ math classes and functions, that will bring
33efficiency, type safety, algebraic syntax to everyone in a memory and
34speed efficient library.
35
36%description -l pl.UTF-8
37Objęty licencją GPL zbiór klas i funkcji matematycznych C++ dający
38wydajność, bezpieczne typy i składnię algebraiczną.
39
40%package devel
41Summary: Development files for programs using the CLN library
42Summary(pl.UTF-8): Pliki do programowania z użyciem biblioteki CLN
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: gmp-devel >= 3.0
46Requires: libstdc++-devel
47Obsoletes: libcln2-devel
48
49%description devel
50This package is necessary if you wish to develop software based on the
51CLN library.
52
53%description devel -l pl.UTF-8
54Ten pakiet jest niezbędny do tworzenia oprogramowania opartego na
55bibliotece CLN.
56
57%package static
58Summary: Static CLN library
59Summary(pl.UTF-8): Statyczna biblioteka CLN
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64Static CLN library.
65
66%description static -l pl.UTF-8
67Statyczna biblioteka CLN.
68
69%prep
70%setup -q
71%patch0 -p1
72
73rm -f m4/libtool.m4
74
75%build
76%{__libtoolize}
77%{__aclocal} -I m4
78%{__autoconf}
79%configure
80%{__make}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85
86%{__make} install \
87 DESTDIR=$RPM_BUILD_ROOT
88
89install examples/{Makefile,*.cc} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%post devel -p /sbin/postshell
98-/usr/sbin/fix-info-dir -c %{_infodir}
99
100%postun devel -p /sbin/postshell
101-/usr/sbin/fix-info-dir -c %{_infodir}
102
103%files
104%defattr(644,root,root,755)
105%doc NEWS README TODO
106%attr(755,root,root) %{_bindir}/pi
107%attr(755,root,root) %{_libdir}/libcln.so.*.*.*
108%attr(755,root,root) %ghost %{_libdir}/libcln.so.6
109%{_mandir}/man1/pi.1*
110
111%files devel
112%defattr(644,root,root,755)
113%attr(755,root,root) %{_libdir}/libcln.so
114%{_libdir}/libcln.la
115%{_includedir}/cln
116%{_infodir}/cln.info*
117%{_pkgconfigdir}/cln.pc
118%{_examplesdir}/%{name}-%{version}
119
120%files static
121%defattr(644,root,root,755)
122%{_libdir}/libcln.a
This page took 0.065199 seconds and 4 git commands to generate.