]> git.pld-linux.org Git - packages/clive.git/commitdiff
- updated patches to 0.4.10
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 25 Apr 2008 21:01:43 +0000 (21:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    clive-delfi.patch -> 1.4
    clive-spz.patch -> 1.2
    clive.spec -> 1.20

clive-delfi.patch
clive-spz.patch
clive.spec

index d1560d39fcb9eabe0e6c344da99dc1427c80edad..8d358d717e96e44f4096788e4bd183115963470f 100644 (file)
@@ -1,18 +1,18 @@
---- clive-0.4.3/clive/parse.py~        2008-01-25 02:37:04.087918332 +0200
-+++ clive-0.4.3/clive/parse.py 2008-01-25 02:37:22.658094354 +0200
+--- clive-0.4.10/src/clive/parse.py~   2008-04-25 23:53:39.000000000 +0300
++++ clive-0.4.10/src/clive/parse.py    2008-04-25 23:55:53.000000000 +0300
 @@ -50,6 +50,7 @@
-                       ('guba.com', 'guba', self._parse_guba),
-                       ('stage6.', 'stage6', self._parse_stage6),
-                       ('metacafe.', 'metac', self._parse_metacafe),
+             ('dailymotion.', 'dmotion', self._parse_dmotion),
+             ('guba.com', 'guba', self._parse_guba),
+             ('metacafe.', 'metac', self._parse_metacafe),
 +                      ('delfi.', 'delfi', self._parse_delfi),
-               ]
+         ]
  
-       ## Parses a video page data (HTML).
-@@ -184,6 +185,16 @@
+     ## Parses a video page data (HTML)
+@@ -221,6 +222,16 @@
+         url = self._parse_from_to(data, 'mediaURL=', '&', skip_from=1)
+         return (url, vid, low_quality)
  
-               return (url, vid)
-+      def _parse_delfi(self, url, data):
++      def _parse_delfi(self, url, data, low_quality):
 +              text = self._parse_from_to(data, "flv_url:", ",")
 +              try:
 +                      url = urllib.unquote(text.replace("'", "").split('flv_url: ',2)[1])
@@ -20,8 +20,8 @@
 +                      pass
 +
 +              vid = md5.new(str(time.time())).hexdigest()[:8]
-+              return (url, vid)
++              return (url, vid, low_quality)
 +
-       def _parse_from_to(self, data, _from, to, skip_from=0):
-               start = data.find(_from)
-               end = data.find(to, start)
+     def _random_vid(self):
+         return md5.new(str(time.time())).hexdigest()[:8]
index 191c721621a94736b3773f2fb75cbcb1b3130f76..d115cf210a6647da7844133f8963eafd08ba8f62 100644 (file)
@@ -1,26 +1,18 @@
---- clive-0.4.1/clive/parse.py 2008-01-20 01:24:26.960335855 +0200
-+++ clive-0.4.1-spz/clive/parse.py     2008-01-20 01:23:07.943359159 +0200
-@@ -50,6 +50,7 @@
-                       ('guba.com', 'guba', self._parse_guba),
-                       ('stage6.', 'stage6', self._parse_stage6),
+--- clive-0.4.10/src/clive/parse.py~   2008-04-25 23:56:56.000000000 +0300
++++ clive-0.4.10/src/clive/parse.py    2008-04-25 23:59:51.000000000 +0300
+@@ -51,6 +51,7 @@
+             ('guba.com', 'guba', self._parse_guba),
+             ('metacafe.', 'metac', self._parse_metacafe),
                        ('delfi.', 'delfi', self._parse_delfi),
 +                      ('www.southparkzone.com', 'southparkzone', self._parse_southparkzone),
-               ]
+         ]
  
-       ## Parses a video page data (HTML).
-@@ -62,6 +63,7 @@
-       # \param say A callback function for printing out stdout messages
-       def parse(self, data, url, opts, callb_query_video_length, say):
-               self._say = say
-+              self._opts = opts
-               fmt = formatter.AbstractFormatter(formatter.NullWriter())
-               p = HTMLParser(fmt)
-@@ -195,6 +197,23 @@
+     ## Parses a video page data (HTML)
+@@ -232,6 +233,23 @@
                vid = md5.new(str(time.time())).hexdigest()[:8]
-               return (url, vid)
+               return (url, vid, low_quality)
  
-+      def _parse_southparkzone(self, url, data):
++      def _parse_southparkzone(self, url, data, low_quality):
 +              mirror_id = self._parse_from_to(data, "episodeinfo.php?mirror=", "'")
 +              from urlgrabber.grabber import URLGrabber
 +              from clive.progress import Progress
@@ -35,8 +27,8 @@
 +              url = self._parse_from_to(data, "<location><![CDATA[", "]]></location>", skip_from = 1)
 +
 +              vid = md5.new(str(time.time())).hexdigest()[:8]
-+              return (url, vid)
++              return (url, vid, low_quality)
 +
-       def _parse_from_to(self, data, _from, to, skip_from=0):
-               start = data.find(_from)
-               end = data.find(to, start)
+     def _random_vid(self):
+         return md5.new(str(time.time())).hexdigest()[:8]
index e96c9f07f4b4fec5ad110db8f4fed96d529b8a7a..5212d67034d6cf7165f6d1bf5611554179d32143 100644 (file)
@@ -2,15 +2,14 @@ Summary:      Video extraction utility for YouTube and Google Video
 Summary(pl.UTF-8):     Narzędzie do wydobywania filmów z YouTube i Google Video
 Name:          clive
 Version:       0.4.10
-Release:       0.14
+Release:       0.15
 License:       GPL v2+
 Group:         Applications/System
 Source0:       http://dl.sourceforge.net/clive/%{name}-%{version}.tar.bz2
 # Source0-md5: f6aec28af6b7794e2c4c833d80c8284a
 Source1:       %{name}-setup.py
-Patch0:                %{name}-setup.patch
-Patch1:                %{name}-delfi.patch
-Patch2:                %{name}-spz.patch
+Patch0:                %{name}-delfi.patch
+Patch1:                %{name}-spz.patch
 URL:           http://home.gna.org/clive/
 BuildRequires: python-devel >= 1:2.4
 BuildRequires: rpm-pythonprov
@@ -37,10 +36,8 @@ ffmpegiem) do przekodowywania wyciągniętych filmów do innych formatów
 
 %prep
 %setup -q
-#%patch0 -p1
-#%patch1 -p1
-#%patch2 -p1
-
+%patch0 -p1
+%patch1 -p1
 
 # switch back to python install. we don't need autofoo as we don't build newt
 cp %{SOURCE1} setup.py
This page took 0.09069 seconds and 4 git commands to generate.