]> git.pld-linux.org Git - packages/clive.git/blobdiff - clive-setup.py
- python module moved to src
[packages/clive.git] / clive-setup.py
index 452c4270fbed55fc9b31c18fef9eb24e3ba47540..cb123de22d9f3d9aa3282c77357dd99eb3d2b26f 100644 (file)
@@ -27,6 +27,8 @@ import gzip
 
 from distutils.core import setup
 
+sys.path.insert(0, 'src')
+
 import clive as _clive
 
 if sys.platform == 'win32':
@@ -70,16 +72,16 @@ setup_args = dict(
        maintainer_email = author_email,
        url = _clive.__url__,
        license = 'GPL',
-       scripts = ['scripts/clive'],
+       scripts = ['src/scripts/clive'],
        packages = ['clive'],
-       package_dir = {'clive':'clive'},
+       package_dir = {'clive':'src/clive'},
        data_files = data_files,
        classifiers = classifiers,
        platforms = ['Any']
 )
 
 if sys.platform == 'win32' and _py2exe_avail:
-       setup_args['console'] = ['scripts/clive']
+       setup_args['console'] = ['src/scripts/clive']
        setup_args['data_files'] = []
 
 # gzip clive.1; otherwise bdist_rpm will fail
This page took 0.094858 seconds and 4 git commands to generate.