]> git.pld-linux.org Git - packages/clisp.git/commitdiff
- rename glibc patch
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 3 Dec 2013 11:10:41 +0000 (12:10 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 3 Dec 2013 11:10:41 +0000 (12:10 +0100)
- add glibc fix from http://comments.gmane.org/gmane.comp.lib.glibc.alpha/25618
- updated error codes (hunk from fedora)

clisp-glibc.patch [new file with mode: 0644]
clisp-glibc2.16.patch [deleted file]
clisp.spec

diff --git a/clisp-glibc.patch b/clisp-glibc.patch
new file mode 100644 (file)
index 0000000..12b6238
--- /dev/null
@@ -0,0 +1,29 @@
+--- clisp-2.49/modules/bindings/glibc/linux.lisp~      2008-10-08 18:36:19.000000000 +0200
++++ clisp-2.49/modules/bindings/glibc/linux.lisp       2012-12-12 12:50:41.830606483 +0100
+@@ -67,7 +66,7 @@
+ (def-c-type __daddr_t)          ; int
+ (def-c-type __caddr_t)          ; c-pointer
+ (def-c-type __time_t)           ; long
+-(def-c-type __swblk_t)          ; long
++;;(def-c-type __swblk_t)          ; long
+ (def-c-type __fd_mask ulong)
+ (eval-when (load compile eval)
+@@ -86,7 +86,7 @@
+ (def-c-type __key_t)            ; int
+-(c-lines "#include <bits/ipctypes.h>~%")
++(c-lines "#include <sys/ipc.h>~%")
+ (def-c-type __ipc_pid_t)        ; ushort
+ ; --------------------------- <sys/types.h> -----------------------------------
+@@ -294,6 +294,8 @@
+ ;; for robust mutexes
+ (def-c-const EOWNERDEAD (:documentation "Owner died")) ; 130
+ (def-c-const ENOTRECOVERABLE (:documentation "State not recoverable")) ; 131
++(def-c-const ERFKILL (:documentation "Operation not possible due to RF-kill")) ; 132
++(def-c-const EHWPOISON (:documentation "Memory page has hardware error")) ; 133
+ ; -------------------------- <bits/errno.h> -----------------------------------
diff --git a/clisp-glibc2.16.patch b/clisp-glibc2.16.patch
deleted file mode 100644 (file)
index 7e788d1..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- clisp-2.49/modules/bindings/glibc/linux.lisp~      2008-10-08 18:36:19.000000000 +0200
-+++ clisp-2.49/modules/bindings/glibc/linux.lisp       2012-12-12 12:50:41.830606483 +0100
-@@ -86,7 +86,7 @@
- (def-c-type __key_t)            ; int
--(c-lines "#include <bits/ipctypes.h>~%")
-+(c-lines "#include <sys/ipc.h>~%")
- (def-c-type __ipc_pid_t)        ; ushort
- ; --------------------------- <sys/types.h> -----------------------------------
index 885eb088b79de1c20a8bf965f3bac5f459bb6bf9..c7d8bc1705e9134efc75e6f90ab8e9ea6651b0cb 100644 (file)
@@ -16,7 +16,7 @@ Source0:      http://download.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
 # Source0-md5: 1962b99d5e530390ec3829236d168649
 Patch0:                %{name}-shell.patch
 Patch1:                %{name}-alpha.patch
-Patch2:                %{name}-glibc2.16.patch
+Patch2:                %{name}-glibc.patch
 URL:           http://clisp.cons.org/
 BuildRequires: ffcall-devel
 BuildRequires: gettext-devel
This page took 0.06405 seconds and 4 git commands to generate.