]> git.pld-linux.org Git - packages/clisp.git/blame_incremental - clisp.spec
- updated to 2.49
[packages/clisp.git] / clisp.spec
... / ...
CommitLineData
1# TODO:
2# - review alpha patch
3#
4# Conditional build:
5%bcond_with tests # run test suite `make check' (uses network, won't pass on vserver)
6#
7Summary: Common Lisp (ANSI CL) implementation
8Summary(pl.UTF-8): Implementacja Common Lisp (ANSI CL)
9Summary(pt_BR.UTF-8): Implementação do Common Lisp (ANSI CL)
10Name: clisp
11Version: 2.49
12Release: 1
13License: GPL
14Group: Development/Languages
15Source0: http://download.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
16# Source0-md5: 1962b99d5e530390ec3829236d168649
17Patch0: %{name}-shell.patch
18Patch1: %{name}-alpha.patch
19Patch2: %{name}-glibc2.16.patch
20URL: http://clisp.cons.org/
21BuildRequires: ffcall-devel
22BuildRequires: gettext-devel
23BuildRequires: libsigsegv >= 2.4
24BuildRequires: ncurses-devel
25BuildRequires: readline-devel
26BuildRequires: xorg-lib-libX11-devel
27BuildRequires: xorg-lib-libXpm-devel
28BuildRequires: xorg-proto-xextproto-devel
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%define specflags_ppc -DNO_GENERATIONAL_GC
32%define specflags_ppc64 -DNO_GENERATIONAL_GC
33
34%description
35Common Lisp is a high-level, all-purpose programming language. CLISP
36is a Common Lisp implementation by Bruno Haible of Karlsruhe
37University and Michael Stoll of Munich University, both in Germany. It
38mostly supports Common Lisp as described in the ANSI CL standard. It
39runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
40500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
41Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
42needs only 2 MB of RAM.
43
44It is free software and may be distributed under the terms of GNU GPL,
45while it is possible to distribute commercial applications compiled
46with CLISP.
47
48The user interface comes in German, English, French and Spanish. CLISP
49includes an interpreter, a compiler, a large subset of CLOS, a foreign
50language interface and a socket interface. An X11 interface is
51available through CLX and Garnet.
52
53%description -l pl.UTF-8
54Common Lisp to wysokopoziomowy język programowania ogólnego
55przeznaczenia. CLISP to implementacja Common Lisp, której autorami są
56Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
57University (oba w Niemczech). W większości wspiera Common Lisp opisany
58w standardzie ANSI CL. Działa na mikrokomputerach (DOS, OS/2, Windows
59NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a także stacjach
60uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
61AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
62
63To jest oprogramowanie wolnodostępne, na licencji GNU GPL, możliwe
64jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
65
66Interfejs użytkownika dostępny jest po niemiecku, angielsku, francusku
67i hiszpańsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
68CLOS, interfejs do innych języków oraz interfejs do gniazdek.
69Interfejs X11 jest dostępny poprzez CLX i Garnet.
70
71%description -l pt_BR.UTF-8
72Common Lisp é uma linguagem de programação de propósito geral de alto
73nível. CLISP é uma implementação do Common Lisp feita por Bruno
74Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
75Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
76o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
77software livre, distribuído sob os termos da GNU GPL.
78
79%prep
80%setup -q
81%patch0 -p1
82#%patch1 -p1
83%patch2 -p1
84
85# changing default -O to optflags causes memory fault on amd64
86# - so something is broken... code or compiler
87# -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
88# random crashes on sparc (which occur with default CFLAGS)
89#%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
90
91%build
92
93%ifarch ppc ppc64
94ulimit -s unlimited
95%else
96ulimit -s 32768
97%endif
98
99CC="%{__cc}" \
100%ifarch sparc sparcv9 sparc64
101CFLAGS="%{rpmcflags} -DSAFETY=3" \
102%else
103CFLAGS="%{rpmcflags}" \
104%endif
105./configure \
106 --prefix=%{_prefix}
107
108cd src
109./makemake \
110 --prefix=%{_prefix} \
111 --with-readline \
112 --with-gettext \
113 --with-dynamic-ffi \
114 --fsstnd=redhat \
115 --with-module=wildcard \
116 --with-module=bindings/glibc \
117 --with-module=clx/new-clx \
118 >Makefile
119%{__make} -j1 config.lisp \
120 TOPDIR=clisp
121%{__make} -j1 \
122 libdir=%{_libdir} \
123 TOPDIR=clisp
124
125%{?with_tests:%{__make} -j1 check}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130%{__make} -j1 -C src install \
131 DESTDIR=$RPM_BUILD_ROOT \
132 libdir=%{_libdir} \
133 lispdocdir=%{_docdir}/%{name}-%{version} \
134 mandir=%{_mandir} \
135 TOPDIR=clisp
136
137install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
138install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
139
140%find_lang %{name} --all-name
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%files -f %{name}.lang
146%defattr(644,root,root,755)
147%attr(755,root,root) %{_bindir}/clisp
148%doc %{_docdir}/%{name}-%{version}
149%dir %{_libdir}/clisp
150%dir %{_libdir}/clisp/base
151%{_libdir}/clisp/base/*.[aho]
152%{_libdir}/clisp/base/lispinit.mem
153%attr(755,root,root) %{_libdir}/clisp/base/lisp.run
154%{_libdir}/clisp/base/makevars
155%{_libdir}/clisp/clisp-link
156%{_libdir}/clisp/data
157%dir %{_libdir}/clisp/full
158%attr(755,root,root) %{_libdir}/clisp/full/lisp.run
159%{_libdir}/clisp/full/*.[aho]
160%{_libdir}/clisp/full/lispinit.mem
161%{_libdir}/clisp/full/makevars
162%{_libdir}/clisp/linkkit
163%{_mandir}/man[13]/*
This page took 0.095824 seconds and 4 git commands to generate.