]> git.pld-linux.org Git - packages/clisp.git/blame - clisp.spec
- ulimit -s unlimited on ppc - stack size of about 8Mb is required to build
[packages/clisp.git] / clisp.spec
CommitLineData
3cd314f5
ŁK
1# TODO:
2# - review alpha patch
bfd7e11e 3#
79f0f74b 4# Conditional build:
cdd858ea 5%bcond_with tests # run test suite `make check' (uses network, won't pass on vserver)
bfd7e11e 6#
59f7b327 7Summary: Common Lisp (ANSI CL) implementation
2b164edd
ER
8Summary(pl.UTF-8): Implementacja Common Lisp (ANSI CL)
9Summary(pt_BR.UTF-8): Implementação do Common Lisp (ANSI CL)
59f7b327 10Name: clisp
38c3e49c 11Version: 2.47
6ba4ad61 12Release: 4
59f7b327 13License: GPL
14Group: Development/Languages
05dfe0ce 15Source0: http://dl.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
38c3e49c 16# Source0-md5: 8fa89bb13e865fc7c7150b82682f35af
59f7b327 17Patch0: %{name}-shell.patch
5a8ba3e7 18Patch1: %{name}-alpha.patch
59f7b327 19URL: http://clisp.cons.org/
3cd314f5 20BuildRequires: ffcall-devel
59f7b327 21BuildRequires: gettext-devel
afc85770 22BuildRequires: libsigsegv >= 2.4
10afc298 23BuildRequires: ncurses-devel
05dfe0ce 24BuildRequires: readline-devel
a84435bf
JB
25BuildRequires: xorg-lib-libX11-devel
26BuildRequires: xorg-lib-libXpm-devel
27BuildRequires: xorg-proto-xextproto-devel
59f7b327 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
df1563da 30%define specflags_ppc -DNO_GENERATIONAL_GC
31%define specflags_ppc64 -DNO_GENERATIONAL_GC
32
59f7b327 33%description
34Common Lisp is a high-level, all-purpose programming language. CLISP
35is a Common Lisp implementation by Bruno Haible of Karlsruhe
36University and Michael Stoll of Munich University, both in Germany. It
37mostly supports Common Lisp as described in the ANSI CL standard. It
38runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
39500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
40Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
41needs only 2 MB of RAM.
42
43It is free software and may be distributed under the terms of GNU GPL,
44while it is possible to distribute commercial applications compiled
45with CLISP.
46
47The user interface comes in German, English, French and Spanish. CLISP
48includes an interpreter, a compiler, a large subset of CLOS, a foreign
49language interface and a socket interface. An X11 interface is
50available through CLX and Garnet.
51
9a5b73ba
JR
52%description -l pl.UTF-8
53Common Lisp to wysokopoziomowy język programowania ogólnego
54przeznaczenia. CLISP to implementacja Common Lisp, której autorami są
66d98f1f 55Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
9a5b73ba
JR
56University (oba w Niemczech). W większości wspiera Common Lisp opisany
57w standardzie ANSI CL. Działa na mikrokomputerach (DOS, OS/2, Windows
58NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a także stacjach
66d98f1f
JB
59uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
60AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
61
9a5b73ba 62To jest oprogramowanie wolnodostępne, na licencji GNU GPL, możliwe
66d98f1f
JB
63jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
64
9a5b73ba
JR
65Interfejs użytkownika dostępny jest po niemiecku, angielsku, francusku
66i hiszpańsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
67CLOS, interfejs do innych języków oraz interfejs do gniazdek.
68Interfejs X11 jest dostępny poprzez CLX i Garnet.
66d98f1f 69
9a5b73ba
JR
70%description -l pt_BR.UTF-8
71Common Lisp é uma linguagem de programação de propósito geral de alto
72nível. CLISP é uma implementação do Common Lisp feita por Bruno
3b8ff915 73Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
9a5b73ba
JR
74Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
75o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
76software livre, distribuído sob os termos da GNU GPL.
3b8ff915 77
59f7b327 78%prep
79%setup -q
80%patch0 -p1
3cd314f5 81#%patch1 -p1
05dfe0ce
JB
82
83# changing default -O to optflags causes memory fault on amd64
84# - so something is broken... code or compiler
0c5f0ead
JB
85# -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
86# random crashes on sparc (which occur with default CFLAGS)
87#%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
59f7b327 88
89%build
fdf4594b 90
5ce91178 91%ifarch ppc ppc64
92ulimit -s unlimited
93%else
df1563da 94ulimit -s 32768
5ce91178 95%endif
fdf4594b 96
79f0f74b 97CC="%{__cc}" \
df1563da 98CFLAGS="%{rpmcflags}" \
79f0f74b 99./configure \
00fbe0f1 100 --prefix=%{_prefix}
f404e321 101
59f7b327 102cd src
103./makemake \
104 --prefix=%{_prefix} \
105 --with-readline \
106 --with-gettext \
107 --with-dynamic-ffi \
e4912e71 108 --fsstnd=redhat \
59f7b327 109 --with-module=wildcard \
5d55e2b8 110 --with-module=bindings/glibc \
e4912e71 111 --with-module=clx/new-clx \
59f7b327 112 >Makefile
a6fd4b7b 113%{__make} -j1 config.lisp \
3cd314f5 114 TOPDIR=clisp
a6fd4b7b 115%{__make} -j1 \
3cd314f5
ŁK
116 libdir=%{_libdir} \
117 TOPDIR=clisp
bfd7e11e 118
a6fd4b7b 119%{?with_tests:%{__make} -j1 check}
59f7b327 120
121%install
122rm -rf $RPM_BUILD_ROOT
05dfe0ce 123
a6fd4b7b 124%{__make} -j1 -C src install \
59f7b327 125 DESTDIR=$RPM_BUILD_ROOT \
05dfe0ce 126 libdir=%{_libdir} \
59f7b327 127 lispdocdir=%{_docdir}/%{name}-%{version} \
3cd314f5
ŁK
128 mandir=%{_mandir} \
129 TOPDIR=clisp
05dfe0ce
JB
130
131install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
66d98f1f 132install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
59f7b327 133
085d3d70 134%find_lang %{name} --all-name
135
59f7b327 136%clean
137rm -rf $RPM_BUILD_ROOT
138
085d3d70 139%files -f %{name}.lang
59f7b327 140%defattr(644,root,root,755)
141%attr(755,root,root) %{_bindir}/clisp
bb3deaa0 142%doc %{_docdir}/%{name}-%{version}
59f7b327 143%dir %{_libdir}/clisp
144%dir %{_libdir}/clisp/base
145%{_libdir}/clisp/base/*.[aho]
146%{_libdir}/clisp/base/lispinit.mem
147%attr(755,root,root) %{_libdir}/clisp/base/lisp.run
148%{_libdir}/clisp/base/makevars
149%{_libdir}/clisp/clisp-link
150%{_libdir}/clisp/data
05dfe0ce
JB
151%dir %{_libdir}/clisp/full
152%attr(755,root,root) %{_libdir}/clisp/full/lisp.run
59f7b327 153%{_libdir}/clisp/full/*.[aho]
154%{_libdir}/clisp/full/lispinit.mem
59f7b327 155%{_libdir}/clisp/full/makevars
156%{_libdir}/clisp/linkkit
59f7b327 157%{_mandir}/man[13]/*
This page took 0.14784 seconds and 4 git commands to generate.