]> git.pld-linux.org Git - packages/clisp.git/blame - clisp.spec
- paralled build isn't?
[packages/clisp.git] / clisp.spec
CommitLineData
3cd314f5
ŁK
1# TODO:
2# - review alpha patch
bfd7e11e 3#
79f0f74b 4# Conditional build:
cdd858ea 5%bcond_with tests # run test suite `make check' (uses network, won't pass on vserver)
bfd7e11e 6#
59f7b327 7Summary: Common Lisp (ANSI CL) implementation
2b164edd
ER
8Summary(pl.UTF-8): Implementacja Common Lisp (ANSI CL)
9Summary(pt_BR.UTF-8): Implementação do Common Lisp (ANSI CL)
59f7b327 10Name: clisp
38c3e49c 11Version: 2.47
56bd9e1e 12Release: 2
59f7b327 13License: GPL
14Group: Development/Languages
05dfe0ce 15Source0: http://dl.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
38c3e49c 16# Source0-md5: 8fa89bb13e865fc7c7150b82682f35af
59f7b327 17Patch0: %{name}-shell.patch
5a8ba3e7 18Patch1: %{name}-alpha.patch
59f7b327 19URL: http://clisp.cons.org/
3cd314f5 20BuildRequires: ffcall-devel
59f7b327 21BuildRequires: gettext-devel
afc85770 22BuildRequires: libsigsegv >= 2.4
10afc298 23BuildRequires: ncurses-devel
05dfe0ce 24BuildRequires: readline-devel
a84435bf
JB
25BuildRequires: xorg-lib-libX11-devel
26BuildRequires: xorg-lib-libXpm-devel
27BuildRequires: xorg-proto-xextproto-devel
59f7b327 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Common Lisp is a high-level, all-purpose programming language. CLISP
32is a Common Lisp implementation by Bruno Haible of Karlsruhe
33University and Michael Stoll of Munich University, both in Germany. It
34mostly supports Common Lisp as described in the ANSI CL standard. It
35runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
36500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
37Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
38needs only 2 MB of RAM.
39
40It is free software and may be distributed under the terms of GNU GPL,
41while it is possible to distribute commercial applications compiled
42with CLISP.
43
44The user interface comes in German, English, French and Spanish. CLISP
45includes an interpreter, a compiler, a large subset of CLOS, a foreign
46language interface and a socket interface. An X11 interface is
47available through CLX and Garnet.
48
9a5b73ba
JR
49%description -l pl.UTF-8
50Common Lisp to wysokopoziomowy język programowania ogólnego
51przeznaczenia. CLISP to implementacja Common Lisp, której autorami są
66d98f1f 52Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
9a5b73ba
JR
53University (oba w Niemczech). W większości wspiera Common Lisp opisany
54w standardzie ANSI CL. Działa na mikrokomputerach (DOS, OS/2, Windows
55NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a także stacjach
66d98f1f
JB
56uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
57AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
58
9a5b73ba 59To jest oprogramowanie wolnodostępne, na licencji GNU GPL, możliwe
66d98f1f
JB
60jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
61
9a5b73ba
JR
62Interfejs użytkownika dostępny jest po niemiecku, angielsku, francusku
63i hiszpańsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
64CLOS, interfejs do innych języków oraz interfejs do gniazdek.
65Interfejs X11 jest dostępny poprzez CLX i Garnet.
66d98f1f 66
9a5b73ba
JR
67%description -l pt_BR.UTF-8
68Common Lisp é uma linguagem de programação de propósito geral de alto
69nível. CLISP é uma implementação do Common Lisp feita por Bruno
3b8ff915 70Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
9a5b73ba
JR
71Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
72o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
73software livre, distribuído sob os termos da GNU GPL.
3b8ff915 74
59f7b327 75%prep
76%setup -q
77%patch0 -p1
3cd314f5 78#%patch1 -p1
05dfe0ce
JB
79
80# changing default -O to optflags causes memory fault on amd64
81# - so something is broken... code or compiler
0c5f0ead
JB
82# -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
83# random crashes on sparc (which occur with default CFLAGS)
84#%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
59f7b327 85
86%build
79f0f74b
JB
87CC="%{__cc}" \
88./configure \
00fbe0f1 89 --prefix=%{_prefix}
f404e321 90
59f7b327 91cd src
92./makemake \
93 --prefix=%{_prefix} \
94 --with-readline \
95 --with-gettext \
96 --with-dynamic-ffi \
e4912e71 97 --fsstnd=redhat \
59f7b327 98 --with-module=wildcard \
5d55e2b8 99 --with-module=bindings/glibc \
e4912e71 100 --with-module=clx/new-clx \
59f7b327 101 >Makefile
a6fd4b7b 102%{__make} -j1 config.lisp \
3cd314f5 103 TOPDIR=clisp
a6fd4b7b 104%{__make} -j1 \
3cd314f5
ŁK
105 libdir=%{_libdir} \
106 TOPDIR=clisp
bfd7e11e 107
a6fd4b7b 108%{?with_tests:%{__make} -j1 check}
59f7b327 109
110%install
111rm -rf $RPM_BUILD_ROOT
05dfe0ce 112
a6fd4b7b 113%{__make} -j1 -C src install \
59f7b327 114 DESTDIR=$RPM_BUILD_ROOT \
05dfe0ce 115 libdir=%{_libdir} \
59f7b327 116 lispdocdir=%{_docdir}/%{name}-%{version} \
3cd314f5
ŁK
117 mandir=%{_mandir} \
118 TOPDIR=clisp
05dfe0ce
JB
119
120install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
66d98f1f 121install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
59f7b327 122
085d3d70 123%find_lang %{name} --all-name
124
59f7b327 125%clean
126rm -rf $RPM_BUILD_ROOT
127
085d3d70 128%files -f %{name}.lang
59f7b327 129%defattr(644,root,root,755)
130%attr(755,root,root) %{_bindir}/clisp
bb3deaa0 131%doc %{_docdir}/%{name}-%{version}
59f7b327 132%dir %{_libdir}/clisp
133%dir %{_libdir}/clisp/base
134%{_libdir}/clisp/base/*.[aho]
135%{_libdir}/clisp/base/lispinit.mem
136%attr(755,root,root) %{_libdir}/clisp/base/lisp.run
137%{_libdir}/clisp/base/makevars
138%{_libdir}/clisp/clisp-link
139%{_libdir}/clisp/data
05dfe0ce
JB
140%dir %{_libdir}/clisp/full
141%attr(755,root,root) %{_libdir}/clisp/full/lisp.run
59f7b327 142%{_libdir}/clisp/full/*.[aho]
143%{_libdir}/clisp/full/lispinit.mem
59f7b327 144%{_libdir}/clisp/full/makevars
145%{_libdir}/clisp/linkkit
59f7b327 146%{_mandir}/man[13]/*
This page took 0.089141 seconds and 4 git commands to generate.