]> git.pld-linux.org Git - packages/click-packages.git/blob - click-packages.spec
- tabs in preamble
[packages/click-packages.git] / click-packages.spec
1 Summary:        Click Modular Router Packages
2 Summary(pl.UTF-8):      Pakiety do modularnego routera Click
3 Name:           click-packages
4 Version:        1.4
5 Release:        0.1
6 License:        MIT
7 Group:          Networking/Admin
8 #Source0Download: http://www.read.cs.ucla.edu/click/download
9 Source0:        http://www.read.cs.ucla.edu/click/%{name}-%{version}.tar.gz
10 # Source0-md5:  8e2779fedb806bffb13d565f59c3ba76
11 Patch0:         %{name}-DESTDIR.patch
12 URL:            http://www.read.cs.ucla.edu/click/
13 BuildRequires:  click-devel
14 BuildRequires:  libstdc++-devel
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Click is a modular software router developed by MIT LCS Parallel and
19 Distributed Operating Systems group, Mazu Networks, the ICSI Center
20 for Internet Research, and now UCLA. Click routers are flexible,
21 configurable, and easy to understand.
22
23 A Click router is an interconnected collection of modules called
24 elements; elements control every aspect of the routers behavior, from
25 communicating with devices to packet modification to queueing,
26 dropping policies and packet scheduling. Individual elements can have
27 surprisingly powerful behavior, and it's easy to write new ones in
28 C++. You write a router configuration by gluing elements together with
29 a simple language.
30
31 %description -l pl.UTF-8
32 Click to modularny router rozwijany przez grupę MIT LCS Parallel and
33 Distributed Operating Systems, Mazu Networks, ICSI Center for Internet
34 Research, a obecnie UCLA. Routery Click są elastyczne, konfigurowalne
35 i łatwe do zrozumienia.
36
37 Router Click to połączony zestaw modułów nazywanych elementami;
38 elementy kontrolują każdy aspekt zachowania routerów, od komunikacji z
39 urządzeniami do modyfikowania pakietów, kolejkowania, polityki
40 porzucania oraz schedulingu pakietów. Poszczególne elementy mogą mieć
41 zaskakująco potężne zachowanie i łatwo pisać nowe w C++. Konfiguracją
42 routera tworzy się przez sklejanie elementów w prostym języku.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47
48 %define subdirs ip6_natpt unibo_qos models
49
50 %build
51 for dir in %{subdirs}; do
52         cd $dir
53 %configure \
54         --with-click=%{_prefix}
55
56         %{__make}
57         cd -
58 done
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8,/bin}
63
64 for dir in %{subdirs}; do
65         %{__make} -C $dir install \
66                 DESTDIR=$RPM_BUILD_ROOT
67 done
68
69 #echo ".so tracepath.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tracepath6.8
70
71 rm $RPM_BUILD_ROOT%{_mandir}/mann/elements.n*
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %attr(755,root,root) %{_libdir}/*.uo
79 %{_datadir}/click/elementmap*.xml
80 %{_mandir}/man*/*
This page took 0.070089 seconds and 3 git commands to generate.