]> git.pld-linux.org Git - packages/clementine.git/commitdiff
- added protobuf patch (don't require static protobuf library)
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 31 Dec 2018 18:24:27 +0000 (19:24 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 31 Dec 2018 18:25:00 +0000 (19:25 +0100)
- added cryptopp patch (adjust for cryptopp 8)

clementine-cryptopp.patch [new file with mode: 0644]
clementine-protobuf.patch [new file with mode: 0644]
clementine.spec

diff --git a/clementine-cryptopp.patch b/clementine-cryptopp.patch
new file mode 100644 (file)
index 0000000..6ffe26e
--- /dev/null
@@ -0,0 +1,23 @@
+--- /home/comp/rpm/BUILD/clementine-1.3.1/src/internet/spotify/spotifyblobdownloader.cpp.orig  2016-01-28 15:51:24.000000000 +0100
++++ /home/comp/rpm/BUILD/clementine-1.3.1/src/internet/spotify/spotifyblobdownloader.cpp       2018-12-31 19:20:49.438080352 +0100
+@@ -189,7 +189,7 @@
+   try {
+     CryptoPP::ByteQueue bytes;
+-    bytes.Put(reinterpret_cast<const byte*>(public_key_data.constData()),
++    bytes.Put(reinterpret_cast<const CryptoPP::byte*>(public_key_data.constData()),
+               public_key_data.size());
+     bytes.MessageEnd();
+@@ -204,9 +204,9 @@
+       actual_filename.remove(kSignatureSuffix);
+       const bool result = verifier.VerifyMessage(
+-          reinterpret_cast<const byte*>(file_data[actual_filename].constData()),
++          reinterpret_cast<const CryptoPP::byte*>(file_data[actual_filename].constData()),
+           file_data[actual_filename].size(),
+-          reinterpret_cast<const byte*>(
++          reinterpret_cast<const CryptoPP::byte*>(
+               file_data[signature_filename].constData()),
+           file_data[signature_filename].size());
+       qLog(Debug) << "Verifying" << actual_filename << "against"
diff --git a/clementine-protobuf.patch b/clementine-protobuf.patch
new file mode 100644 (file)
index 0000000..f3c39b4
--- /dev/null
@@ -0,0 +1,22 @@
+--- clementine-1.3.1/ext/clementine-spotifyblob/CMakeLists.txt.orig    2015-12-15 13:13:23.000000000 +0100
++++ clementine-1.3.1/ext/clementine-spotifyblob/CMakeLists.txt 2018-12-31 19:09:51.088087870 +0100
+@@ -46,7 +46,7 @@
+   ${QT_QTNETWORK_LIBRARY}
+   ${GSTREAMER_BASE_LIBRARIES}
+   ${GSTREAMER_APP_LIBRARIES}
+-  ${PROTOBUF_STATIC_LIBRARY}
++  ${PROTOBUF_LIBRARY}
+   clementine-spotifyblob-messages
+   libclementine-common
+ )
+--- clementine-1.3.1/CMakeLists.txt.orig       2018-12-31 18:48:20.634769271 +0100
++++ clementine-1.3.1/CMakeLists.txt    2018-12-31 19:10:06.811421024 +0100
+@@ -55,8 +55,6 @@
+ find_package(Protobuf REQUIRED)
+ find_package(FFTW3)
+-find_library(PROTOBUF_STATIC_LIBRARY libprotobuf.a libprotobuf)
+-
+ pkg_check_modules(CDIO libcdio)
+ pkg_check_modules(CHROMAPRINT REQUIRED libchromaprint)
+ pkg_search_module(CRYPTOPP cryptopp libcrypto++)
index fc5df0e66def6f68e47adf099c57974774213552..31d505aaf3c5d7c67bfda61c80a52455c947939a 100644 (file)
@@ -30,6 +30,8 @@ Patch1:               unbundle-po.patch
 Patch2:                %{name}-udisks-headers.patch
 Patch3:                %{name}-mygpo.patch
 Patch4:                moc.patch
+Patch5:                %{name}-protobuf.patch
+Patch6:                %{name}-cryptopp.patch
 URL:           http://www.clementine-player.org/
 BuildRequires: OpenGL-devel
 BuildRequires: QtCore-devel >= %{qt_ver}
@@ -121,6 +123,8 @@ przepisanymi tak, aby wykorzystać Qt4.
 %patch2 -p1
 #%patch3 -p1
 %patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 # cleanup vendor. keep only needed libraries.
 %{__mv} 3rdparty 3rdparty.dist
This page took 0.055226 seconds and 4 git commands to generate.