]> git.pld-linux.org Git - packages/clementine.git/blobdiff - clementine.spec
- release 17 (rebuild with protobuf 3.9)
[packages/clementine.git] / clementine.spec
index fd2872be07b5fc3e0f099d43b1439008726bd4b4..a9eca5bdbeaec89e7819e59e7f68b411ee8425f1 100644 (file)
@@ -8,87 +8,92 @@
 #        /usr/share/kde4/services/clementine-zune.protocol
 #
 # Conditional build:
-%bcond_without static_sqlite   # with static sqlite3
 %bcond_with    static_projectm # with static projectM
 %bcond_with    libspotify      # build with system libspotify instead of downloading blob
-%bcond_without tests           # build without tests
+%bcond_with    tests           # build without tests
 
-%define                rel             0.1
-%define                subver  rc1
-%define                qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
+%define                qt_ver          4.5.0
+%define                qt_installed    %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
+%define                sqlite_ver      3.14.0-2
 Summary:       A music player and library organiser
 Summary(hu.UTF-8):     Egy zenelejátszó és gyűjtemény-kezelő
+Summary(pl.UTF-8):     Odtwarzacz muzyki i organizator biblioteczki
 Name:          clementine
-Version:       1.3.0
-Release:       0.%{subver}.%{rel}
+Version:       1.3.1
+Release:       17
 License:       GPL v3 and GPL v2+
-Group:         Applications/Multimedia
-Source0:       https://github.com/clementine-player/Clementine/releases/download/1.3rc1/%{name}-%{version}%{subver}.tar.xz
-# Source0-md5: c709615f6c5061e5ff1f43bbb1f9255a
+Group:         X11/Applications/Multimedia
+Source0:       https://github.com/clementine-player/Clementine/releases/download/%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: 18cc5f66aa5fbb2781198a65439bd38a
+Patch0:                %{name}-c++.patch
 Patch1:                unbundle-po.patch
-Patch4:                %{name}-mygpo.patch
-Patch6:                %{name}-udisks-headers.patch
+Patch2:                %{name}-udisks-headers.patch
+Patch3:                %{name}-mygpo.patch
+Patch4:                moc.patch
+Patch5:                %{name}-protobuf.patch
+Patch6:                %{name}-cryptopp.patch
 URL:           http://www.clementine-player.org/
-BuildRequires: QtCore-devel >= %{qtver}
-BuildRequires: QtDBus-devel >= %{qtver}
-BuildRequires: QtGui-devel >= %{qtver}
-BuildRequires: QtIOCompressor-devel
-BuildRequires: QtNetwork-devel >= %{qtver}
-BuildRequires: QtOpenGL-devel >= %{qtver}
+BuildRequires: OpenGL-devel
+BuildRequires: QtCore-devel >= %{qt_ver}
+BuildRequires: QtDBus-devel >= %{qt_ver}
+BuildRequires: QtGui-devel >= %{qt_ver}
+BuildRequires: QtIOCompressor-devel >= 2.3
+BuildRequires: QtNetwork-devel >= %{qt_ver}
+BuildRequires: QtOpenGL-devel >= %{qt_ver}
 BuildRequires: QtSingleApplication-devel >= 2.6-4
-BuildRequires: QtSql-devel >= %{qtver}
-%{?with_tests:BuildRequires:   QtTest-devel >= %{qtver}}
-BuildRequires: QtXml-devel >= %{qtver}
-BuildRequires: QtXmlPatterns-devel >= %{qtver}
+BuildRequires: QtSql-devel >= %{qt_ver}
+%{?with_tests:BuildRequires:   QtTest-devel >= %{qt_ver}}
+BuildRequires: QtXml-devel >= %{qt_ver}
 BuildRequires: boost-devel
 BuildRequires: cmake >= 2.6
 BuildRequires: cryptopp-devel >= 5.6.1-4
 BuildRequires: desktop-file-utils
+BuildRequires: fftw3-devel
 BuildRequires: gettext-tools
 %{?with_static_projectm:BuildRequires: glew-devel}
-BuildRequires: glib2-devel
-BuildRequires: gstreamer0.10-devel
-BuildRequires: gstreamer0.10-plugins-base-devel
+BuildRequires: glib2-devel >= 2.0
+BuildRequires: gstreamer-devel >= 1.0
+BuildRequires: gstreamer-plugins-base-devel >= 1.0
 BuildRequires: gtest-devel
 BuildRequires: libcdio-devel
 BuildRequires: libchromaprint-devel
 BuildRequires: libechonest-devel
 BuildRequires: libgpod-devel >= 0.7.92
 BuildRequires: libimobiledevice-devel >= 1.1.5
-BuildRequires: libindicate-qt-devel
 BuildRequires: liblastfm-devel >= 0.3.3
-BuildRequires: libmtp-devel
-BuildRequires: libmygpo-qt-devel >= 1.0.7
+BuildRequires: libmtp-devel >= 1.0
+#BuildRequires:        libmygpo-qt-devel >= 1.0.9
 BuildRequires: libplist-devel
 %{!?with_static_projectm:BuildRequires:        libprojectM-devel >= 1:2.0.1-4}
 BuildRequires: libqxt-devel
 %{?with_libspotify:BuildRequires:      libspotify-devel >= 12.1.45}
 BuildRequires: libusbmuxd-devel
-BuildRequires: libxml2-devel
-BuildRequires: pkgconfig
+BuildRequires: libxml2-devel >= 2.0
 BuildRequires: pkgconfig
 BuildRequires: protobuf-devel
-BuildRequires: qca-devel
+BuildRequires: pulseaudio-devel
 BuildRequires: qjson-devel
-BuildRequires: qt4-build >= %{qtver}
+BuildRequires: qt4-build >= %{qt_ver}
 BuildRequires: qt4-linguist
 BuildRequires: qt4-qmake
 BuildRequires: rpmbuild(find_lang) >= 1.38
 BuildRequires: rpmbuild(macros) >= 1.596
 BuildRequires: sed >= 4.0
 BuildRequires: sparsehash-devel
-%{!?with_static_sqlite:BuildRequires:  sqlite3-devel}
-BuildRequires: taglib-devel >= 1.6
+BuildRequires: sqlite3-devel >= %{sqlite_ver}
+BuildRequires: taglib-devel >= 1.8
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 Requires(post,postun): desktop-file-utils
 Requires(post,postun): gtk-update-icon-cache
 Requires(post,postun): hicolor-icon-theme
+BuildRequires: sqlite3 >= %{sqlite_ver}
 Requires:      QtSingleApplication >= 2.6-4
-%{!?with_static_sqlite:Requires:       QtSql-sqlite3 >= %{qtver}}
-Requires:      gstreamer0.10-audio-effects-base
-Requires:      gstreamer0.10-mad
-Suggests:      gstreamer0.10-flac
+Requires:      QtSql-sqlite3 >= %{qt_installed}
+Requires:      gstreamer-audio-effects-base
+Suggests:      gstreamer-flac
+Suggests:      gstreamer-libav
+Suggests:      gstreamer-mpg123
 # if we do not link, we use datafiles
 %{!?with_static_projectm:Requires:     libprojectM}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -106,14 +111,23 @@ Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
 a Qt4 előnyeit.
 
+%description -l pl.UTF-8
+Clementine to nowoczesny odtwarzacz muzyki i organizator biblioteczki.
+Jest w dużej części portem Amaroka 1.4 z niektórymi funkcjami
+przepisanymi tak, aby wykorzystać Qt4.
+
 %prep
-%setup -q -n %{name}-%{version}%{subver}
+%setup -q
+%patch0 -p1
 %patch1 -p1
-#%patch4 -p1
-#%patch6 -p1
+%patch2 -p1
+#%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 # cleanup vendor. keep only needed libraries.
-mv 3rdparty 3rdparty.dist
+%{__mv} 3rdparty 3rdparty.dist
 vendor() {
        local path dir
        for path; do
@@ -123,52 +137,54 @@ vendor() {
        done
 }
 vendor sha2 qocoa
-%{?with_static_sqlite:vendor qsqlite}
+vendor qsqlite
 %{?with_static_projectm:vendor libprojectm}
 # missing in pld
 vendor vreen
-# temporary for 1.3.0
+# requires 1.0.9, but only 1.0.8 is released
 vendor libmygpo-qt
 
 # Don't build tests. They require gmock
-sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
+%{__sed} -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
 # remove -Wall
-sed -i -e 's/-Wall//' src/CMakeLists.txt
+%{__sed} -i -e 's/-Wall//' src/CMakeLists.txt
 
 %build
-install -d build
 install -d build/src/translations
 cd build
-# as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
-CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
+# as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~135
+CXXFLAGS="%{rpmcxxflags} -fpermissive -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
 %cmake \
        -DBUILD_WERROR:BOOL=OFF \
+       -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
        -DCMAKE_INCLUDE_PATH=%{_includedir}/qt4 \
        -DBUNDLE_PROJECTM_PRESETS=OFF \
        -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
        -DUSE_SYSTEM_QXT=ON \
        -DUSE_SYSTEM_PROJECTM=ON \
-       -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
        -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions \
        ..
 %{__make}
 
-%if %{with tests}
 desktop-file-validate ../dist/%{name}.desktop
+
+%if %{with tests}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/kde4/services
 
-# not in our glibc?
-rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
-rm -r $RPM_BUILD_ROOT%{_localedir}/he_IL
-rm -r $RPM_BUILD_ROOT%{_localedir}/mk_MK
-rm -r $RPM_BUILD_ROOT%{_localedir}/si_LK
+# unify locale codes
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{mk_MK,mk}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{si_LK,si}
+# empty copies of il,tr
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/he_IL
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
 
 %find_lang %{name} --with-qm
 
This page took 0.056233 seconds and 4 git commands to generate.