]> git.pld-linux.org Git - packages/clementine.git/blobdiff - clementine.spec
- up to 1.0.1
[packages/clementine.git] / clementine.spec
index d793b139e76cc96786982c9578a5dd44f7872cd8..6010dc80d4327e57c3d384d2373d2db52e2c7ac0 100644 (file)
@@ -1,83 +1,70 @@
 # TODO:
-# - add missing BRs
 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
-# -- Building engines: gst
-# -- Skipping engines: vlc xine qt-phonon
-#    The following engines are NOT supported by clementine developers:
-#     vlc xine qt-phonon
 # - apply patches to libprojectM.spec and use
-# - make engines pluggable not statically linked, then could enable the bconds
-#11:04:19  bs> glen, let me take a look at it [IN]
-#11:09:13  bs> glen, look at src/CMakeList.txt, remove lines 634-643  [IN]
-#11:19:32  bs> glen, aaaa, no no, it will them ignore them while building... so you've got another problem then i thought... [IN]
-#11:20:29  bs> glen, try too look in src/translations in CMakeList.txt and find out where the translations are installed per defualt, and then change the destination [IN]
 #
 # Conditional build:
-%bcond_with            engine_xine             # without xine engine
-%bcond_with            engine_vlc              # without vlc engine
-%bcond_with            engine_qt_phonon        # without qt-phonon engine
-%bcond_without engine_gstreamer        # without gstreamer engine
 %bcond_without static_sqlite   # with static sqlite3
-%bcond_with            static_projectm # with static projectM
+%bcond_with    static_projectm # with static projectM
 
+%define        qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
 Summary:       A music player and library organiser
 Summary(hu.UTF-8):     Egy zenelejátszó és gyűjtemény-kezelő
 Name:          clementine
-Version:       0.5.3
-Release:       2
+Version:       1.0.1
+Release:       1
 License:       GPL v3 and GPL v2+
 Group:         Applications/Multimedia
 URL:           http://www.clementine-player.org/
 Source0:       http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
-# Source0-md5: 3411a0e31bdab7a6693048e934996f40
+# Source0-md5: 54dc47eb2de5960cd1654e1249a59bc6
 Patch0:                desktop-install.patch
-BuildRequires: QtCore-devel
-BuildRequires: QtDBus-devel
-BuildRequires: QtGui-devel
+Patch1:                unbundle-po.patch
+BuildRequires: QtCore-devel >= %{qtver}
+BuildRequires: QtDBus-devel >= %{qtver}
+BuildRequires: QtGui-devel >= %{qtver}
 BuildRequires: QtIOCompressor-devel
-BuildRequires: QtNetwork-devel
-BuildRequires: QtOpenGL-devel
+BuildRequires: QtNetwork-devel >= %{qtver}
+BuildRequires: QtOpenGL-devel >= %{qtver}
 BuildRequires: QtSingleApplication-devel >= 2.6-4
-BuildRequires: QtSql-devel
-%{?with_tests:BuildRequires:   QtTest-devel}
-BuildRequires: QtXml-devel
+BuildRequires: QtSql-devel >= %{qtver}
+%{?with_tests:BuildRequires:   QtTest-devel >= %{qtver}}
+BuildRequires: QtXml-devel >= %{qtver}
 BuildRequires: boost-devel
 BuildRequires: cmake >= 2.6
-#BuildRequires:        desktop-file-utils
 #%{?with_static_projectm:BuildRequires:        ftgl-devel >= 2.1.3}
 BuildRequires: gettext-devel
 %{?with_static_projectm:BuildRequires: glew-devel}
 BuildRequires: glib2-devel
-%{?with_engine_gstreamer:BuildRequires:        gstreamer-devel >= 0.10}
-%{?with_engine_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 0.10}
+BuildRequires: gstreamer-devel >= 0.10
 BuildRequires: gtest-devel
 BuildRequires: libgpod-devel >= 0.7.92
 BuildRequires: libimobiledevice-devel
-BuildRequires: liblastfm-devel
+BuildRequires: libindicate-qt-devel
+BuildRequires: liblastfm-devel >= 0.3.3
 BuildRequires: libmtp-devel
-BuildRequires: libnotify-devel
 BuildRequires: libplist-devel
 %{!?with_static_projectm:BuildRequires:        libprojectM-devel >= 1:2.0.1-4}
 BuildRequires: libqxt-devel
-#BuildRequires:        libqxt-devel >= 0.6.0-0.2
 BuildRequires: libxml2-devel
-BuildRequires: notification-daemon
-BuildRequires: phonon
-%{?with_engine_phonon:BuildRequires:   phonon-devel}
 BuildRequires: pkgconfig
-BuildRequires: qt4-build
+BuildRequires: pkgconfig
+BuildRequires: protobuf-devel
+BuildRequires: qjson-devel
+BuildRequires: qt4-build >= %{qtver}
 BuildRequires: qt4-linguist
 BuildRequires: qt4-qmake
-BuildRequires: rpmbuild(macros) >= 1.577
+BuildRequires: rpmbuild(find_lang) >= 1.33
+BuildRequires: rpmbuild(macros) >= 1.596
 BuildRequires: sed >= 4.0
 %{!?with_static_sqlite:BuildRequires:  sqlite3-devel}
 BuildRequires: taglib-devel >= 1.6
 BuildRequires: usbmuxd-devel
-%{?with_engine_vlc:BuildRequires:      vlc-devel}
-%{?with_engine_xine:BuildRequires:     xine-lib-devel}
 Requires(post,postun): desktop-file-utils
+Requires(post,postun): gtk-update-icon-cache
+Requires(post,postun): hicolor-icon-theme
 Requires:      QtSingleApplication >= 2.6-4
-%{!?with_static_sqlite:Requires:       QtSql-sqlite3}
+%{!?with_static_sqlite:Requires:       QtSql-sqlite3 >= %{qtver}}
+Requires:      gstreamer-audio-effects-base
 # while we do not link (yet), we use datafiles
 Requires:      libprojectM
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -96,8 +83,9 @@ az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
 a Qt4 előnyeit.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}
 %patch0 -p1
+%patch1 -p1
 
 # We already don't use these but just to make sure
 rm -rf 3rdparty/gmock
@@ -109,19 +97,19 @@ rm -rf 3rdparty/qtiocompressor
 
 # Don't build tests. They require gmock
 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
+# remove -Wall
+sed -i -e 's/-Wall//' src/CMakeLists.txt
 
 %build
 install -d build
+install -d build/src/translations
 cd build
 %cmake \
        -DBUNDLE_PROJECTM_PRESETS=OFF \
        -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
+        -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
        -DUSE_SYSTEM_QXT=ON \
        -DUSE_SYSTEM_PROJECTM=ON \
-       -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
-       -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
-       -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
-       -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
        -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
        ..
 %{__make}
@@ -133,18 +121,28 @@ rm -rf $RPM_BUILD_ROOT
 
 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
 
+%find_lang %{name} --with-qm
+
+install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
+cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
+cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 %update_desktop_database_post
+%update_icon_cache hicolor
 
 %postun
 %update_desktop_database_postun
+%update_icon_cache hicolor
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc Changelog TODO
+%doc Changelog
 %attr(755,root,root) %{_bindir}/clementine
 %{_desktopdir}/clementine.desktop
 %{_pixmapsdir}/clementine.png
+%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
+%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.092306 seconds and 4 git commands to generate.