]> git.pld-linux.org Git - packages/clementine.git/blobdiff - clementine.spec
- up to 1.0.1
[packages/clementine.git] / clementine.spec
index 988eaea30cb731b95db6a07aea79fef6fa3c2d7e..6010dc80d4327e57c3d384d2373d2db52e2c7ac0 100644 (file)
@@ -1,31 +1,22 @@
 # TODO:
 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
-# -- Building engines: gst
-# -- Skipping engines: vlc xine qt-phonon
-#    The following engines are NOT supported by clementine developers:
-#     vlc xine qt-phonon
 # - apply patches to libprojectM.spec and use
-# - make engines pluggable not statically linked, then could enable the bconds
 #
 # Conditional build:
-%bcond_with            engine_xine             # without xine engine
-%bcond_with            engine_vlc              # without vlc engine
-%bcond_with            engine_qt_phonon        # without qt-phonon engine
-%bcond_without engine_gstreamer        # without gstreamer engine
 %bcond_without static_sqlite   # with static sqlite3
-%bcond_with            static_projectm # with static projectM
+%bcond_with    static_projectm # with static projectM
 
-%define     qtver      %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
+%define        qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
 Summary:       A music player and library organiser
 Summary(hu.UTF-8):     Egy zenelejátszó és gyűjtemény-kezelő
 Name:          clementine
-Version:       0.7
-Release:       0.rc1.1
+Version:       1.0.1
+Release:       1
 License:       GPL v3 and GPL v2+
 Group:         Applications/Multimedia
 URL:           http://www.clementine-player.org/
-Source0:       http://clementine-player.googlecode.com/files/%{name}-%{version}rc1.tar.gz
-# Source0-md5: a13a226975e12b425606db99a74d8424
+Source0:       http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
+# Source0-md5: 54dc47eb2de5960cd1654e1249a59bc6
 Patch0:                desktop-install.patch
 Patch1:                unbundle-po.patch
 BuildRequires: QtCore-devel >= %{qtver}
@@ -44,20 +35,21 @@ BuildRequires:      cmake >= 2.6
 BuildRequires: gettext-devel
 %{?with_static_projectm:BuildRequires: glew-devel}
 BuildRequires: glib2-devel
-%{?with_engine_gstreamer:BuildRequires:        gstreamer-devel >= 0.10}
+BuildRequires: gstreamer-devel >= 0.10
 BuildRequires: gtest-devel
 BuildRequires: libgpod-devel >= 0.7.92
 BuildRequires: libimobiledevice-devel
 BuildRequires: libindicate-qt-devel
-BuildRequires: liblastfm-devel
+BuildRequires: liblastfm-devel >= 0.3.3
 BuildRequires: libmtp-devel
 BuildRequires: libplist-devel
 %{!?with_static_projectm:BuildRequires:        libprojectM-devel >= 1:2.0.1-4}
 BuildRequires: libqxt-devel
 BuildRequires: libxml2-devel
-%{?with_engine_phonon:BuildRequires:   phonon-devel}
 BuildRequires: pkgconfig
 BuildRequires: pkgconfig
+BuildRequires: protobuf-devel
+BuildRequires: qjson-devel
 BuildRequires: qt4-build >= %{qtver}
 BuildRequires: qt4-linguist
 BuildRequires: qt4-qmake
@@ -67,8 +59,6 @@ BuildRequires:        sed >= 4.0
 %{!?with_static_sqlite:BuildRequires:  sqlite3-devel}
 BuildRequires: taglib-devel >= 1.6
 BuildRequires: usbmuxd-devel
-%{?with_engine_vlc:BuildRequires:      vlc-devel}
-%{?with_engine_xine:BuildRequires:     xine-lib-devel}
 Requires(post,postun): desktop-file-utils
 Requires(post,postun): gtk-update-icon-cache
 Requires(post,postun): hicolor-icon-theme
@@ -93,7 +83,7 @@ az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
 a Qt4 előnyeit.
 
 %prep
-%setup -q -n %{name}-%{version}rc1
+%setup -q -n %{name}-%{version}
 %patch0 -p1
 %patch1 -p1
 
@@ -107,6 +97,8 @@ rm -rf 3rdparty/qtiocompressor
 
 # Don't build tests. They require gmock
 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
+# remove -Wall
+sed -i -e 's/-Wall//' src/CMakeLists.txt
 
 %build
 install -d build
@@ -115,12 +107,9 @@ cd build
 %cmake \
        -DBUNDLE_PROJECTM_PRESETS=OFF \
        -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
+        -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
        -DUSE_SYSTEM_QXT=ON \
        -DUSE_SYSTEM_PROJECTM=ON \
-       -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
-       -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
-       -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
-       -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
        -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
        ..
 %{__make}
@@ -151,7 +140,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc Changelog TODO
+%doc Changelog
 %attr(755,root,root) %{_bindir}/clementine
 %{_desktopdir}/clementine.desktop
 %{_pixmapsdir}/clementine.png
This page took 0.066442 seconds and 4 git commands to generate.