]> git.pld-linux.org Git - packages/clementine.git/blobdiff - clementine.spec
- libechonest-2.3.1-1 rebuild
[packages/clementine.git] / clementine.spec
index 57aba76f5feec7f80866f34a5b94536b6fd32c0b..5c700b81fb2758b0b6170108f63a81a353dfcd13 100644 (file)
@@ -8,38 +8,35 @@
 #        /usr/share/kde4/services/clementine-zune.protocol
 #
 # Conditional build:
-%bcond_without static_sqlite   # with static sqlite3
 %bcond_with    static_projectm # with static projectM
 %bcond_with    libspotify      # build with system libspotify instead of downloading blob
-%bcond_without tests           # build without tests
+%bcond_with    tests           # build without tests
 
-%define                rel             0.1
-%define                subver  rc1
 %define                qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
+%define                sqlitever       3.14.0-2
 Summary:       A music player and library organiser
 Summary(hu.UTF-8):     Egy zenelejátszó és gyűjtemény-kezelő
 Name:          clementine
-Version:       1.3.0
-Release:       0.%{subver}.%{rel}
+Version:       1.3.1
+Release:       4
 License:       GPL v3 and GPL v2+
-Group:         Applications/Multimedia
-Source0:       https://github.com/clementine-player/Clementine/releases/download/1.3rc1/%{name}-%{version}%{subver}.tar.xz
-# Source0-md5: c709615f6c5061e5ff1f43bbb1f9255a
+Group:         X11/Applications/Multimedia
+Source0:       https://github.com/clementine-player/Clementine/releases/download/%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: 18cc5f66aa5fbb2781198a65439bd38a
 Patch1:                unbundle-po.patch
-Patch4:                %{name}-mygpo.patch
-Patch6:                %{name}-udisks-headers.patch
+Patch2:                %{name}-udisks-headers.patch
+Patch3:                %{name}-mygpo.patch
 URL:           http://www.clementine-player.org/
 BuildRequires: QtCore-devel >= %{qtver}
 BuildRequires: QtDBus-devel >= %{qtver}
 BuildRequires: QtGui-devel >= %{qtver}
-BuildRequires: QtIOCompressor-devel
+BuildRequires: QtIOCompressor-devel >= 2.3
 BuildRequires: QtNetwork-devel >= %{qtver}
 BuildRequires: QtOpenGL-devel >= %{qtver}
 BuildRequires: QtSingleApplication-devel >= 2.6-4
 BuildRequires: QtSql-devel >= %{qtver}
 %{?with_tests:BuildRequires:   QtTest-devel >= %{qtver}}
 BuildRequires: QtXml-devel >= %{qtver}
-BuildRequires: QtXmlPatterns-devel >= %{qtver}
 BuildRequires: boost-devel
 BuildRequires: cmake >= 2.6
 BuildRequires: cryptopp-devel >= 5.6.1-4
@@ -47,15 +44,14 @@ BuildRequires:      desktop-file-utils
 BuildRequires: gettext-tools
 %{?with_static_projectm:BuildRequires: glew-devel}
 BuildRequires: glib2-devel
-BuildRequires: gstreamer0.10-devel
-BuildRequires: gstreamer0.10-plugins-base-devel
+BuildRequires: gstreamer-devel
+BuildRequires: gstreamer-plugins-base-devel
 BuildRequires: gtest-devel
 BuildRequires: libcdio-devel
 BuildRequires: libchromaprint-devel
 BuildRequires: libechonest-devel
 BuildRequires: libgpod-devel >= 0.7.92
 BuildRequires: libimobiledevice-devel >= 1.1.5
-BuildRequires: libindicate-qt-devel
 BuildRequires: liblastfm-devel >= 0.3.3
 BuildRequires: libmtp-devel >= 1.0
 BuildRequires: libmygpo-qt-devel >= 1.0.7
@@ -68,7 +64,6 @@ BuildRequires:        libxml2-devel
 BuildRequires: pkgconfig
 BuildRequires: pkgconfig
 BuildRequires: protobuf-devel
-BuildRequires: qca-devel
 BuildRequires: qjson-devel
 BuildRequires: qt4-build >= %{qtver}
 BuildRequires: qt4-linguist
@@ -77,18 +72,19 @@ BuildRequires:      rpmbuild(find_lang) >= 1.38
 BuildRequires: rpmbuild(macros) >= 1.596
 BuildRequires: sed >= 4.0
 BuildRequires: sparsehash-devel
-%{!?with_static_sqlite:BuildRequires:  sqlite3-devel}
+BuildRequires: sqlite3-devel >= %{sqlitever}
 BuildRequires: taglib-devel >= 1.8
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 Requires(post,postun): desktop-file-utils
 Requires(post,postun): gtk-update-icon-cache
 Requires(post,postun): hicolor-icon-theme
+BuildRequires: sqlite3 >= %{sqlitever}
 Requires:      QtSingleApplication >= 2.6-4
-%{!?with_static_sqlite:Requires:       QtSql-sqlite3 >= %{qtver}}
-Requires:      gstreamer0.10-audio-effects-base
-Requires:      gstreamer0.10-mad
-Suggests:      gstreamer0.10-flac
+Requires:      QtSql-sqlite3 >= %{qtver}
+Requires:      gstreamer-audio-effects-base
+Requires:      gstreamer-mad
+Suggests:      gstreamer-flac
 # if we do not link, we use datafiles
 %{!?with_static_projectm:Requires:     libprojectM}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -107,10 +103,10 @@ az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
 a Qt4 előnyeit.
 
 %prep
-%setup -q -n %{name}-%{version}%{subver}
+%setup -q
 %patch1 -p1
-#%patch4 -p1
-%patch6 -p1
+%patch2 -p1
+#%patch3 -p1
 
 # cleanup vendor. keep only needed libraries.
 mv 3rdparty 3rdparty.dist
@@ -123,7 +119,7 @@ vendor() {
        done
 }
 vendor sha2 qocoa
-%{?with_static_sqlite:vendor qsqlite}
+vendor qsqlite
 %{?with_static_projectm:vendor libprojectm}
 # missing in pld
 vendor vreen
@@ -143,18 +139,19 @@ cd build
 CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
 %cmake \
        -DBUILD_WERROR:BOOL=OFF \
+       -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
        -DCMAKE_INCLUDE_PATH=%{_includedir}/qt4 \
        -DBUNDLE_PROJECTM_PRESETS=OFF \
        -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
        -DUSE_SYSTEM_QXT=ON \
        -DUSE_SYSTEM_PROJECTM=ON \
-       -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
        -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions \
        ..
 %{__make}
 
-%if %{with tests}
 desktop-file-validate ../dist/%{name}.desktop
+
+%if %{with tests}
 %endif
 
 %install
This page took 0.907701 seconds and 4 git commands to generate.