]> git.pld-linux.org Git - packages/clearsilver.git/commitdiff
- fix use of variadic macros without variable args auto/th/clearsilver-0.10.5-14
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 27 Dec 2015 12:51:47 +0000 (13:51 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 27 Dec 2015 12:51:47 +0000 (13:51 +0100)
- rel 14

clearsilver.spec
variadic-macros.patch [new file with mode: 0644]

index 0d179b9b5d315235e547c91c9bf36b782023ae47..92ff640103308a7c4d067980d080e39a6b7be12a 100644 (file)
@@ -2,13 +2,14 @@ Summary:      ClearSilver HTML template system
 Summary(pl.UTF-8):     ClearSilver - system szablonów HTML
 Name:          clearsilver
 Version:       0.10.5
-Release:       13
+Release:       14
 License:       Apache License style
 Group:         Development/Libraries
 Source0:       http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
 # Source0-md5: b8c0c7fbe0ef5e06e0c935f134304d44
 Patch0:                %{name}-pic.patch
 Patch1:                format-security.patch
+Patch2:                variadic-macros.patch
 URL:           http://www.clearsilver.net/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -90,6 +91,7 @@ ClearSilver.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 find . -type f -print0 | xargs -0 perl -pi -e "s!/usr/local/bin!/usr/bin!g" 
 
diff --git a/variadic-macros.patch b/variadic-macros.patch
new file mode 100644 (file)
index 0000000..433622b
--- /dev/null
@@ -0,0 +1,22 @@
+--- clearsilver-0.10.5/util/neo_err.h~ 2015-12-27 13:45:24.000000000 +0100
++++ clearsilver-0.10.5/util/neo_err.h  2015-12-27 13:49:48.870962697 +0100
+@@ -85,7 +85,7 @@
+  */
+ #if defined(USE_C99_VARARG_MACROS)
+ #define nerr_raise(e,f,...) \
+-   nerr_raisef(__PRETTY_FUNCTION__,__FILE__,__LINE__,e,f,__VA_ARGS__)
++   nerr_raisef(__PRETTY_FUNCTION__,__FILE__,__LINE__,e,f,##__VA_ARGS__)
+ #elif defined(USE_GNUC_VARARG_MACROS)
+ #define nerr_raise(e,f,a...) \
+    nerr_raisef(__PRETTY_FUNCTION__,__FILE__,__LINE__,e,f,##a)
+--- clearsilver-0.10.5/util/neo_err.h~ 2015-12-27 13:49:48.000000000 +0100
++++ clearsilver-0.10.5/util/neo_err.h  2015-12-27 13:50:21.991521142 +0100
+@@ -99,7 +99,7 @@
+ #if defined(USE_C99_VARARG_MACROS)
+ #define nerr_raise_errno(e,f,...) \
+-   nerr_raise_errnof(__PRETTY_FUNCTION__,__FILE__,__LINE__,e,f,__VA_ARGS__)
++   nerr_raise_errnof(__PRETTY_FUNCTION__,__FILE__,__LINE__,e,f,##__VA_ARGS__)
+ #elif defined(USE_GNUC_VARARG_MACROS)
+ #define nerr_raise_errno(e,f,a...) \
+    nerr_raise_errnof(__PRETTY_FUNCTION__,__FILE__,__LINE__,e,f,##a)
This page took 0.088523 seconds and 4 git commands to generate.