]> git.pld-linux.org Git - packages/classpath.git/commitdiff
- separated apidocs (over 200MB).
authorPaweł Sikora <pluto@pld-linux.org>
Wed, 4 May 2005 09:11:36 +0000 (09:11 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    classpath.spec -> 1.23

classpath.spec

index e9701c18d1fa205f2aa0b0f815fb3e25bec5f404..6f064f17b950d9eeafee43e3f70ce872ca862355 100644 (file)
@@ -1,12 +1,16 @@
 #
 # Conditional build:
 %bcond_without gcj     # use jikes instead of gcj
+%bcond_with    apidocs # prepare API documentation (over 200MB)
+#
+# TODO:
+#              - fix broken build with gcj on powerpc and reverse bcond.
 #
 Summary:       GNU Classpath (Essential Libraries for Java)
 Summary(pl):   GNU Classpath (Najwa¿niejsze biblioteki dla Javy)
 Name:          classpath
 Version:       0.15
-Release:       2
+Release:       2.1
 License:       GPL v2
 Group:         Libraries
 Source0:       ftp://ftp.gnu.org/gnu/classpath/%{name}-%{version}.tar.gz
@@ -18,7 +22,7 @@ BuildRequires:        automake >= 1:1.7
 BuildRequires: gcc-c++
 %{?with_gcj:BuildRequires:     gcc-java}
 BuildRequires: gdk-pixbuf-devel
-BuildRequires: gjdoc
+%{?with_apidocs:BuildRequires: gjdoc}
 BuildRequires: gtk+2-devel >= 2:2.4
 %{!?with_gcj:BuildRequires:    jikes >= 1.18}
 BuildRequires: libart_lgpl-devel >= 2.1.0
@@ -41,6 +45,24 @@ wolnego j
 i kompilatorami dla jêzyka Java. Zawiera wszystkie natywne metody i
 g³ówne klasy niezbêdne dla kompletnej funkcjonalno¶ci ¶rodowiska Javy.
 
+%package apidocs
+Summary:       API documentation
+Summary(pl):   Dokumentacja API
+Group:         Documentation
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description apidocs
+Annotated reference of GNU Classpath libraries programming interface including:
+- class lists
+- class members
+- namespaces
+
+%description apidocs -l pl
+Dokumentacja interfejsu programowania bibliotek GNU Classpath z przypisami.
+Zawiera:
+- listy klas i ich sk³adników
+- listê przestrzeni nazw (namespace)
+
 %package devel
 Summary:       Development files for GNU Classpath
 Summary(pl):   Pliki dla programistów u¿ywaj±cych GNU Classpath
@@ -88,7 +110,7 @@ statyczne.
        --without-gcj \
        --with-jikes \
 %endif
-       --with-gjdoc \
+       --with%{!?with_apidocs:out}-gjdoc \
        --disable-examples
 
 %{__make} \
@@ -97,13 +119,17 @@ statyczne.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_javadir}
+install -d $RPM_BUILD_ROOT{%{_javadir},%{_javadocdir}/%{name}-%{version}-apidocs}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        pkglibdir=%{_libdir} \
        pkgdatadir=%{_javadir}
 
+%if %{with apidocs}
+cp -afr doc/api/html/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}-apidocs
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -123,6 +149,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_javadir}/glibj.zip
 %{_infodir}/*.info*
 
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%{_javadocdir}/%{name}-%{version}-apidocs
+%endif
+
 %files devel
 %defattr(644,root,root,755)
 %{_libdir}/libgtkpeer.la
This page took 0.042898 seconds and 4 git commands to generate.