]> git.pld-linux.org Git - packages/clapack.git/blob - clapack.spec
- rebuild with lapack 3.7
[packages/clapack.git] / clapack.spec
1 Summary:        The CLAPACK libraries for numerical linear algebra
2 Summary(pl.UTF-8):      Biblioteki numeryczne CLAPACK do algebry liniowej
3 Name:           clapack
4 Version:        3.2.1
5 Release:        4
6 License:        freely distributable
7 Group:          Development/Libraries
8 Source0:        http://www.netlib.org/clapack/%{name}-%{version}-CMAKE.tgz
9 # Source0-md5:  4fd18eb33f3ff8c5d65a7d43913d661b
10 Patch0:         %{name}-%{version}-fix_include_file.patch
11 Patch1:         %{name}-%{version}-noblasf2c.patch
12 Patch2:         %{name}-%{version}-hang.patch
13 Patch3:         %{name}-%{version}-findblas-r6.patch
14 URL:            http://www.netlib.org/clapack/
15 BuildRequires:  cmake
16 BuildRequires:  gcc-fortran
17 BuildRequires:  libf2c-devel
18 BuildRequires:  libtool >= 1:1.4.2-9
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 CLAPACK (Linear Algebra PACKage) is a standard library for numerical
23 linear algebra. CLAPACK provides routines for solving systems of
24 simultaneous linear equations, least-squares solutions of linear
25 systems of equations, eigenvalue problems, and singular value
26 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
27 Schur, and generalized Schur) and related computations (i.e.,
28 reordering of Schur factorizations and estimating condition numbers)
29 are also included. CLAPACK can handle dense and banded matrices, but
30 not general sparse matrices. Similar functionality is provided for
31 real and complex matrices in both single and double precision. CLAPACK
32 is coded in Fortran77 and translated to C using f2c.
33
34 %description -l pl.UTF-8
35 CLAPACK (Linear Algebra PACKage) jest standardową biblioteką
36 numeryczną do algebry liniowej. Dostarcza funkcje rozwiązywania:
37 układów równań liniowych, układów równań metodą najmniejszych
38 kwadratów, problemów własnych. Zawiera algorytmy faktoryzacji macierzy
39 (LU, Cholesky'ego, QR, SVD, Schura, uogólnioną Schura) i związanych z
40 tym obliczeń (np. przenumerowanie w faktoryzacji Schura i estymację
41 uwarunkowania). CLAPACK może obsługiwać macierze blokowe i pasmowe,
42 ale nie rzadkie w ogólnym przypadku. Zapewnia funkcjonalność dla
43 macierzy rzeczywistych i zespolonych, dla liczb pojedynczej i
44 podwójnej precyzji. CLAPACK jest napisany w Fortranie 77 i
45 przetłumaczony na C przy użyciu f2c.
46
47 %package devel
48 Summary:        CLAPACK header files
49 Summary(pl.UTF-8):      Pliki nagłówkowe CLAPACK
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 CLAPACK header files.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe CLAPACK.
58
59 %package static
60 Summary:        Static CLAPACK libraries
61 Summary(pl.UTF-8):      Biblioteki statyczne CLAPACK
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static CLAPACK libraries.
67
68 %description static -l pl.UTF-8
69 Biblioteki statyczne CLAPACK.
70
71 %prep
72 %setup -q -n %{name}-%{version}-CMAKE
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77
78 %build
79 install -d build
80 cd build
81 %cmake \
82         ..
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} -C build install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README*
101 %attr(755,root,root) %{_libdir}/libclapack.so.*.*.*
102
103 %files devel
104 %defattr(644,root,root,755)
105 %{_libdir}/libclapack.so
106 %{_includedir}/clapack
107 %{_datadir}/cmake/Modules/clapack*.cmake
This page took 0.112626 seconds and 3 git commands to generate.