]> git.pld-linux.org Git - packages/clan.git/commitdiff
- new auto/th/clan-0.8.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 5 Oct 2014 13:09:37 +0000 (15:09 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 5 Oct 2014 13:09:37 +0000 (15:09 +0200)
clan-info.patch [new file with mode: 0644]
clan-osl.patch [new file with mode: 0644]
clan.spec [new file with mode: 0644]

diff --git a/clan-info.patch b/clan-info.patch
new file mode 100644 (file)
index 0000000..8e73333
--- /dev/null
@@ -0,0 +1,30 @@
+--- clan-0.8.0/doc/Makefile.am.orig    2014-10-05 15:00:13.715909221 +0200
++++ clan-0.8.0/doc/Makefile.am 2014-10-05 15:00:20.782575591 +0200
+@@ -65,10 +65,11 @@
+       clan.texi                               \
+       clan.pdf
++info_TEXINFOS =
++AM_MAKEINFOHTMLFLAGS    = --no-headers --no-split
+ if GENERATE_DOC
+ # Unfortunately the following is not supported conditionaly
+-#info_TEXINFOS                = clan.texi
+-#AM_MAKEINFOHTMLFLAGS    = --no-headers --no-split
++info_TEXINFOS         += clan.texi
+ clan.pdf: clan.texi
+       $(TEXI2PDF) clan.texi
+--- clan-0.8.0/doc/clan.texi.orig      2014-06-03 17:55:58.000000000 +0200
++++ clan-0.8.0/doc/clan.texi   2014-10-05 14:52:41.125928208 +0200
+@@ -33,6 +33,11 @@
+      @afourpaper
+ @end iftex
++@dircategory Programming tools:
++@direntry
++* Clan: (clan).                               A Polyhedral Representation Extraction Tool for C-Based High Level Langauges
++@end direntry
++
+ @c %**end of header
+ @c % /*************************************************************************
diff --git a/clan-osl.patch b/clan-osl.patch
new file mode 100644 (file)
index 0000000..e33aa67
--- /dev/null
@@ -0,0 +1,11 @@
+--- clan-0.8.0/configure.ac.orig       2014-06-03 17:55:27.000000000 +0200
++++ clan-0.8.0/configure.ac    2014-10-05 15:06:02.102561268 +0200
+@@ -204,7 +204,7 @@
+       if test "x$with_osl_exec_prefix" != "x"; then
+               OSL_LDFLAGS="-L$with_osl_exec_prefix/lib"
+       fi
+-      OSL_LIBS="$with_osl_exec_prefix/lib/libosl.la -losl"
++      OSL_LIBS="-losl"
+ esac
+ AM_CONDITIONAL(BUNDLED_OSL, test $with_osl = bundled)
diff --git a/clan.spec b/clan.spec
new file mode 100644 (file)
index 0000000..d74e642
--- /dev/null
+++ b/clan.spec
@@ -0,0 +1,116 @@
+Summary:       Clan - a Polyhedral Representation Extraction Tool for C-Based High Level Languages
+Summary(pl.UTF-8):     Clan - narzędzie do tworzenia reprezentacji wielościennej dla języków opartych na C
+Name:          clan
+Version:       0.8.0
+Release:       1
+License:       LGPL v3+
+Group:         Libraries
+#Source0Download: http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/
+Source0:       http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/docs/%{name}-%{version}.tar.gz
+# Source0-md5: 0dcba7f4bdf32159405f27ebce439d63
+Patch0:                %{name}-info.patch
+Patch1:                %{name}-osl.patch
+URL:           http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/
+BuildRequires: autoconf >= 2.53
+BuildRequires: automake
+BuildRequires: bison >= 2.4
+BuildRequires: doxygen
+BuildRequires: flex >= 2.5.35
+BuildRequires: libtool
+BuildRequires: osl-devel >= 0.9.0
+BuildRequires: texinfo
+BuildRequires: texinfo-texi2dvi
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Clan is a free software and library which translates some particular
+parts of high level programs written in C, C++, C# or Java into a
+polyhedral representation called OpenScop. This representation may be
+manipulated by other tools to, e.g., achieve complex analyses or
+program restructurations (for optimization, parallelization or any
+other kind of manipulation). It has been created to avoid tedious and
+error-prone input file writing for polyhedral tools (such as CLooG,
+LeTSeE, Clan etc.). Using Clan, the user has to deal with source
+codes based on C grammar only (as C, C++, C# or Java).
+
+%description -l pl.UTF-8
+Clan (Chunky ANalyzer for Dependences in Loops - blokowy analizator
+zależności w pętlach) to wolnodostępne oprogramowanie i biblioteka
+służące do obliczeń zależności danych.
+
+%package devel
+Summary:       Header files for Clan library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Clan
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      osl-devel >= 0.9.0
+
+%description devel
+Header files for Clan library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki Clan.
+
+%package static
+Summary:       Static Clan library
+Summary(pl.UTF-8):     Statyczna biblioteka Clan
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static Clan library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka Clan.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__automake}
+%configure \
+       --disable-silent-rules \
+       --with-osl=system
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%post  devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%postun        devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS ChangeLog README THANKS
+%attr(755,root,root) %{_bindir}/clan
+%attr(755,root,root) %{_libdir}/libclan.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libclan.so.0
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libclan.so
+%{_libdir}/libclan.la
+%{_includedir}/clan
+%{_infodir}/clan.info*
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libclan.a
This page took 0.117558 seconds and 4 git commands to generate.