]> git.pld-linux.org Git - packages/clamav.git/commitdiff
systemd-cronjobs support added
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Fri, 10 Mar 2017 13:12:52 +0000 (14:12 +0100)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Fri, 10 Mar 2017 13:12:52 +0000 (14:12 +0100)
Release: 2

clamav.spec
cronjob-clamav.service.in [new file with mode: 0644]
cronjob-clamav.timer [new file with mode: 0644]

index cb88e64c5d75716d6c273962b553202d64851f56..23ed6786375c539ab2a0e3a56a7c37e196d4a67f 100644 (file)
@@ -20,7 +20,7 @@ Summary:      An anti-virus utility for Unix
 Summary(pl.UTF-8):     Narzędzie antywirusowe dla Uniksów
 Name:          clamav
 Version:       0.99.2
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         Daemons
 Source0:       http://www.clamav.net/downloads/production/%{name}-%{version}.tar.gz
@@ -34,6 +34,8 @@ Source8:      %{name}-post-updatedb
 Source9:       %{name}-milter.sysconfig
 Source10:      %{name}.tmpfiles
 Source11:      clamd.service
+Source12:      cronjob-clamav.timer
+Source13:      cronjob-clamav.service.in
 Patch0:                %{name}-pld_config.patch
 Patch1:                %{name}-nolibs.patch
 %if "%{pld_release}" == "ac"
@@ -241,6 +243,8 @@ install -p %{SOURCE8} $RPM_BUILD_ROOT%{_sbindir}
 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
+cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/cronjob-%{name}.timer
+sed -e's#@sbindir@#%{_sbindir}#' <  %{SOURCE13} > $RPM_BUILD_ROOT%{systemdunitdir}/cronjob-%{name}.service
 
 # NOTE: clamd uses sane rights to it's clamd.pid file
 # So better keep it dir
@@ -271,14 +275,14 @@ rm -rf $RPM_BUILD_ROOT
 touch /var/log/freshclam.log
 chown clamav:root /var/log/freshclam.log
 chmod 640 /var/log/freshclam.log
-%systemd_post clamd.service
+%systemd_post clamd.service cronjob-clamav.timer
 
 %preun
 if [ "$1" = "0" ]; then
        %service clamd stop
        /sbin/chkconfig --del clamd
 fi
-%systemd_preun clamd.service
+%systemd_preun clamd.service cronjob-clamav.timer
 
 %postun
 if [ "$1" = "0" ]; then
@@ -321,6 +325,9 @@ touch /var/lock/subsys/clamd
 %triggerpostun -- %{name} < 0.97.7-4
 %systemd_trigger clamd.service
 
+%triggerpostun -- %{name} < 0.99.2-2
+%systemd_service_enable cronjob-clamav.timer
+
 %post milter
 /sbin/chkconfig --add clamav-milter
 %service clamav-milter restart "Clam Antivirus daemon"
@@ -350,6 +357,8 @@ fi
 %attr(755,root,root) %{_sbindir}/clamav-post-updatedb
 %{systemdtmpfilesdir}/%{name}.conf
 %{systemdunitdir}/clamd.service
+%{systemdunitdir}/cronjob-clamav.service
+%{systemdunitdir}/cronjob-clamav.timer
 %attr(755,clamav,root) %dir /var/lib/%{name}
 %attr(640,clamav,root) %ghost /var/log/freshclam.log
 %attr(750,clamav,clamav) %dir /var/run/%{name}
diff --git a/cronjob-clamav.service.in b/cronjob-clamav.service.in
new file mode 100644 (file)
index 0000000..3674278
--- /dev/null
@@ -0,0 +1,5 @@
+[Unit]
+Description=clamav cronjob
+
+[Service]
+ExecStart=@sbindir@/clamav-cron-updatedb
diff --git a/cronjob-clamav.timer b/cronjob-clamav.timer
new file mode 100644 (file)
index 0000000..1de41b1
--- /dev/null
@@ -0,0 +1,8 @@
+[Unit]
+Description=clamav cronjob timer
+
+[Timer]
+OnCalendar=*:05
+
+[Install]
+WantedBy=cronjobs.timer
This page took 0.062225 seconds and 4 git commands to generate.