]> git.pld-linux.org Git - packages/clamav.git/commitdiff
- rel 2; avoid daemon segfault on some pdfs auto/th/clamav-0_96_4-2 auto/ti/clamav-0_96_4-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 15 Nov 2010 07:25:06 +0000 (07:25 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    clamav-segv.patch -> 1.1
    clamav.spec -> 1.288

clamav-segv.patch [new file with mode: 0644]
clamav.spec

diff --git a/clamav-segv.patch b/clamav-segv.patch
new file mode 100644 (file)
index 0000000..3859711
--- /dev/null
@@ -0,0 +1,13 @@
+--- clamav-0.96.4/libclamav/pdf.c~     2010-10-19 16:14:41.000000000 +0200
++++ clamav-0.96.4/libclamav/pdf.c      2010-11-15 08:23:09.826782407 +0100
+@@ -468,6 +468,10 @@
+               return 0;
+           }
+           q = pdf_nextobject(pdf->map+obj->start, pdf->size - obj->start);
++          if (!q) {
++              cli_dbgmsg("cli_pdf: next object not found\n");
++              return 0;
++          }
+           length = atoi(q);
+       }
+     }
index 2d074d8507bd7c784d7225a908aac5b9414bd149..00dafca81838906a2fa49f816f2262f110fd311f 100644 (file)
@@ -9,7 +9,7 @@ Summary:        An anti-virus utility for Unix
 Summary(pl.UTF-8):     Narzędzie antywirusowe dla Uniksów
 Name:          clamav
 Version:       0.96.4
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         Daemons
 Source0:       http://downloads.sourceforge.net/clamav/0.96rc1/%{name}-%{version}.tar.gz
@@ -25,6 +25,7 @@ Patch0:               %{name}-pld_config.patch
 Patch1:                %{name}-nolibs.patch
 Patch2:                am-nosilentrules.patch
 Patch3:                %{name}-link.patch
+Patch4:                %{name}-segv.patch
 URL:           http://www.clamav.net/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -154,6 +155,7 @@ Biblioteki statyczne clamav.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
This page took 0.181795 seconds and 4 git commands to generate.