]> git.pld-linux.org Git - packages/clamav.git/commitdiff
- rel 2 auto/th/clamav-0_97_5-2
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 28 Jun 2012 09:14:34 +0000 (09:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix build problems caused by autoconf 2.68

Changed files:
    ac2.68.patch -> 1.1
    clamav.spec -> 1.308

ac2.68.patch [new file with mode: 0644]
clamav.spec

diff --git a/ac2.68.patch b/ac2.68.patch
new file mode 100644 (file)
index 0000000..f7a2362
--- /dev/null
@@ -0,0 +1,104 @@
+diff -ur clamav-0.97.5/clamav-milter/Makefile.am clamav-0.97.5-am/clamav-milter/Makefile.am
+--- clamav-0.97.5/clamav-milter/Makefile.am    2012-06-12 15:36:05.000000000 +0200
++++ clamav-0.97.5-am/clamav-milter/Makefile.am 2012-06-28 11:10:21.205378306 +0200
+@@ -45,7 +45,7 @@
+ endif
+ DEFS = @DEFS@ -DCL_NOLIBCLAMAV
+-CFLAGS=`echo "@CFLAGS@" | sed -e 's/-Wwrite-strings//' -e 's/-Werror /-Werror -Wno-error=format-nonliteral /'`
++AM_CFLAGS=`echo "@CFLAGS@" | sed -e 's/-Wwrite-strings//' -e 's/-Werror /-Werror -Wno-error=format-nonliteral /'`
+ LIBS = $(top_builddir)/libclamav/libclamav_internal_utils.la @CLAMAV_MILTER_LIBS@ @THREAD_LIBS@
+ AM_CPPFLAGS = -I$(top_srcdir)/clamd -I$(top_srcdir)/libclamav -I$(top_srcdir)/shared -I$(top_srcdir)
+ CLEANFILES=*.gcda *.gcno
+diff -ur clamav-0.97.5/configure.in clamav-0.97.5-am/configure.in
+--- clamav-0.97.5/configure.in 2012-06-28 11:10:46.795377403 +0200
++++ clamav-0.97.5-am/configure.in      2012-06-28 11:01:44.658245193 +0200
+@@ -54,6 +54,8 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
++AM_PROG_AR
++AM_PROG_CC_C_O
+ LT_CONFIG_LTDL_DIR([libltdl])
+ LT_INIT([dlopen disable-static])
+@@ -469,7 +471,7 @@
+ if test "$enable_check_ut" != "no" ; then
+       AC_LIB_FIND([check],[check.h],
+-                      AC_LANG_PROGRAM([#include <check.h>],[srunner_create(0)]),
++                      [AC_LANG_PROGRAM([#include <check.h>],[srunner_create(0)])],
+                       [CHECK_CPPFLAGS="$INCCHECK"; CHECK_LIBS="$LTLIBCHECK"],
+                       [])
+ fi
+@@ -1549,8 +1551,8 @@
+ if test "$enable_clamdtop" != "no"; then
+ AC_LIB_FIND([ncurses], [ncurses/ncurses.h],
+-          AC_LANG_PROGRAM([#include <ncurses/ncurses.h>],
+-                          [initscr(); KEY_RESIZE;]),
++          [AC_LANG_PROGRAM([#include <ncurses/ncurses.h>],
++                          [initscr(); KEY_RESIZE;])],
+           [CURSES_CPPFLAGS="$INCNCURSES"; CURSES_LIBS="$LTLIBNCURSES";
+            CURSES_INCLUDE="<ncurses/ncurses.h>"],
+           [])
+@@ -1558,8 +1560,8 @@
+ if test "X$HAVE_LIBNCURSES" != "Xyes"; then
+     HAVE_LIBNCURSES=
+     AC_LIB_FIND([ncurses], [ncurses.h],
+-          AC_LANG_PROGRAM([#include <ncurses.h>],
+-                          [initscr(); KEY_RESIZE;]),
++          [AC_LANG_PROGRAM([#include <ncurses.h>],
++                          [initscr(); KEY_RESIZE;])],
+           [CURSES_CPPFLAGS="$INCNCURSES"; CURSES_LIBS="$LTLIBNCURSES";
+            CURSES_INCLUDE="<ncurses.h>"],
+           [])
+@@ -1567,8 +1569,8 @@
+ if test "X$HAVE_LIBNCURSES" != "Xyes"; then
+     AC_LIB_FIND([pdcurses],[curses.h],
+-                          AC_LANG_PROGRAM([#include <curses.h>],
+-                                          [initscr(); KEY_RESIZE;]),
++                          [AC_LANG_PROGRAM([#include <curses.h>],
++                                          [initscr(); KEY_RESIZE;])],
+                           [CURSES_CPPFLAGS="$INCPDCURSES";
+                            CURSES_LIBS="$LTLIBPDCURSES";
+                            CURSES_INCLUDE="<curses.h>"],
+diff -ur clamav-0.97.5/m4/resolv.m4 clamav-0.97.5-am/m4/resolv.m4
+--- clamav-0.97.5/m4/resolv.m4 2012-06-12 15:36:05.000000000 +0200
++++ clamav-0.97.5-am/m4/resolv.m4      2012-06-28 11:09:01.312047789 +0200
+@@ -18,7 +18,7 @@
+       [
+           AC_CACHE_CHECK([for dn_expand in std libs], [ac_cv_have_lresolv_std], [
+               ac_cv_have_lresolv_std='no'
+-              AC_LINK_IFELSE([
++              AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/nameser.h>
+@@ -28,14 +28,14 @@
+               [
+                   ac_cv_have_lresolv_std='yes'
+                   ac_cv_have_lresolv=''
+-              ])
++              ])])
+           ])
+           if test "x$ac_cv_have_lresolv" = "xno"; then
+           bklibs=$LIBS
+           LIBS=-lresolv
+           AC_CACHE_CHECK([for dn_expand in -lresolv], [ac_cv_have_lresolv_lresolv], [
+               ac_cv_have_lresolv_lresolv='yes'
+-              AC_LINK_IFELSE([
++              AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/nameser.h>
+@@ -45,7 +45,7 @@
+               [
+                   ac_cv_have_lresolv_lresolv='yes'
+                   ac_cv_have_lresolv=' -lresolv'
+-              ])
++              ])])
+           ])
+           LIBS=$bklibs;
+           fi
index da766ea6d646ec97e70e6de0ae2e41ff916fd417..d85aa6bf19ffcc606831d77e96b0a522d729d60d 100644 (file)
@@ -14,7 +14,7 @@ Summary:      An anti-virus utility for Unix
 Summary(pl.UTF-8):     Narzędzie antywirusowe dla Uniksów
 Name:          clamav
 Version:       0.97.5
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         Daemons
 Source0:       http://downloads.sourceforge.net/clamav/%{name}-%{version}.tar.gz
@@ -30,6 +30,7 @@ Source10:     %{name}.tmpfiles
 Patch0:                %{name}-pld_config.patch
 Patch1:                %{name}-nolibs.patch
 Patch2:                am-nosilentrules.patch
+Patch3:                ac2.68.patch
 URL:           http://www.clamav.net/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -157,6 +158,7 @@ Biblioteki statyczne clamav.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
This page took 0.164398 seconds and 4 git commands to generate.