]> git.pld-linux.org Git - packages/cityhash.git/blob - cityhash.spec
up to 1.1.0
[packages/cityhash.git] / cityhash.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 Summary:        Fast hash functions for strings
6 Name:           cityhash
7 Version:        1.1.0
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 URL:            http://code.google.com/p/cityhash
12 Source0:        http://cityhash.googlecode.com/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  e591cfb40db0f71f39c73988cefdc14f
14 BuildRequires:  libstdc++-devel
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 CityHash provides hash functions for strings. The functions mix the
19 input bits thoroughly but are not suitable for cryptography.
20
21 %package devel
22 Summary:        Development files for %{name}
23 Group:          Development/Libraries
24 Requires:       %{name} = %{version}-%{release}
25
26 %description devel
27 The %{name}-devel package contains libraries and header files for
28 developing applications that use %{name}.
29
30 %package static
31 Summary:        Static %{name} library
32 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
33 Group:          Development/Libraries
34 Requires:       %{name}-devel = %{version}-%{release}
35
36 %description static
37 Static %{name} library.
38
39 %description static -l pl.UTF-8
40 Statyczna biblioteka %{name}.
41
42 %prep
43 %setup -q
44
45 %build
46 %configure \
47         %{!?with_static_libs:--disable-static}
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post   -p /sbin/ldconfig
61 %postun -p /sbin/ldconfig
62
63 %files
64 %defattr(644,root,root,755)
65 %doc NEWS README
66 %attr(755,root,root) %{_libdir}/libcityhash.so.*.*.*
67 %ghost %{_libdir}/libcityhash.so.0
68
69 %files devel
70 %defattr(644,root,root,755)
71 %{_includedir}/city.h
72 %{_libdir}/libcityhash.so
73 %{_libdir}/libcityhash.la
74
75 %if %{with static_libs}
76 %files static
77 %defattr(644,root,root,755)
78 %{_libdir}/libcityhash.a
79 %endif
This page took 0.057261 seconds and 3 git commands to generate.