]> git.pld-linux.org Git - packages/cipe.git/commitdiff
278079c78f4baa0c7601e781021c1820 cipe-1.5.2.tar.gz
authorSebastian Zagrodzki <sebek@zagrodzki.net>
Wed, 7 Nov 2001 15:56:03 +0000 (15:56 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cipe-autoconf.patch -> 1.1
    cipe-makefile.patch -> 1.1

cipe-autoconf.patch [new file with mode: 0644]
cipe-makefile.patch [new file with mode: 0644]

diff --git a/cipe-autoconf.patch b/cipe-autoconf.patch
new file mode 100644 (file)
index 0000000..3182221
--- /dev/null
@@ -0,0 +1,50 @@
+diff -Naur cipe-1.5.2/configure.in cipe-1.5.2-p/configure.in
+--- cipe-1.5.2/configure.in    Tue May  1 23:23:38 2001
++++ cipe-1.5.2-p/configure.in  Tue Nov  6 17:58:33 2001
+@@ -13,8 +13,6 @@
+ dnl
+ AC_PREREQ(2.13)
+ AC_INIT(cipe/ciped.c)
+-AC_CONFIG_HEADER($BUILD/config.h:conf/config.h.in pkcipe/config.h)
+-dnl $BUILD is set below - this works for autoconf 2.13, somewhat undocumented
+ AC_SUBST(VERSION)
+ VERSION=1.5.2
+ AC_SUBST(PVERSION)
+@@ -351,6 +349,8 @@
+ else
+   BUILD=$KVERS-$ARCH-$verl$crypt$name
+ fi
++
++AC_CONFIG_HEADER($BUILD/config.h:conf/config.h.in pkcipe/config.h)
+ AC_SUBST(BUILD_PKCIPE)
+ set `echo $VERSION | tr . ' '`
+--- cipe-1.5.2/configure.in    Wed Nov  7 16:00:26 2001
++++ cipe-1.5.2-p/configure.in  Wed Nov  7 15:59:28 2001
+@@ -136,23 +136,10 @@
+   fi
+ fi
+-AC_MSG_CHECKING(for SMP)
+-smp=0
+-case "$KVERS" in
+-2.[[01]].*)
+-  AX_EGREP([^ *SMP *= *1], $KSRC/Makefile, smp=1)
+-  ;;
+-*)
+-  AC_EGREP_CPP(yes, [
+-      #include <linux/autoconf.h>
+-      #ifdef CONFIG_SMP
+-       yes
+-      #endif
+-  ], smp=1)
+-  ;;
+-esac
++AC_ARG_ENABLE(smp,
++[  --enable-smp            Build CIPE for SMP architecture],
++smp=1, smp=0)
+ test "$smp" = 1 && AC_DEFINE(__SMP__)
+-AX_MSG_RESULT_YN($smp)
+ AC_SUBST(KCC)
+ CPPFLAGS="$oldcppflags"
diff --git a/cipe-makefile.patch b/cipe-makefile.patch
new file mode 100644 (file)
index 0000000..d24ea7f
--- /dev/null
@@ -0,0 +1,20 @@
+--- cipe-1.5.2/pkcipe/Makefile.in      Sat Dec 16 19:27:35 2000
++++ cipe-1.5.2-p/pkcipe/Makefile.in    Wed Nov  7 16:19:10 2001
+@@ -40,12 +40,12 @@
+       -mkdir -p $(bindir) $(sbindir)
+       $(INSTALL) -m 755 rsa-keygen $(bindir)
+       $(INSTALL) -m 755 pkcipe $(sbindir)
+-      [ -d /etc/cipe/pk ] || mkdir -p /etc/cipe/pk
+-      [ -d /var/run/cipe ] || mkdir -p /var/run/cipe
+-      chmod 700 /etc/cipe /etc/cipe/pk /var/run/cipe
+-      @if [ ! -f /etc/cipe/identity.priv ] ; then \
++      [ -d $(SYSCONFDIR)/pk ] || mkdir -p $(SYSCONFDIR)/pk
++      [ -d $(LOCALSTATEDIR)/run/cipe ] || mkdir -p $(LOCALSTATEDIR)/run/cipe
++      chmod 700 $(SYSCONFDIR) $(SYSCONFDIR)/pk $(LOCALSTATEDIR)/run/cipe
++      @if [ ! -f $(SYSCONFDIR)/identity.priv ] ; then \
+               echo "*** Generating new identity (host) key ***" ;\
+-              rsa-keygen /etc/cipe/identity ;\
++              echo rsa-keygen $(SYSCONFDIR)/identity ;\
+       fi
+ clean:
This page took 0.052579 seconds and 4 git commands to generate.