]> git.pld-linux.org Git - packages/cipe.git/blobdiff - cipe.spec
- adapterized (sorted %verify flags)
[packages/cipe.git] / cipe.spec
index 3ac6b47eb5198be20ff0a8c102438932c66f41f7..024495f05938a856cc8be8a3e3393b0f460d63cb 100644 (file)
--- a/cipe.spec
+++ b/cipe.spec
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+# _without_dist_kernel - without kernel from distribution
+#
 Summary:       CIPE - encrypted IP over UDP tunneling
 Summary(pl):   CIPE - szyfrowany tunel IP po UDP
 Name:          cipe
@@ -7,6 +11,7 @@ Release:       %{_rel}
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://sites.inka.de/bigred/sw/%{name}-%{version}.tar.gz
+# Source0-md5: 9d88f2d090fcafcd0e2fa73b018b6e16
 Source1:       %{name}.inetd
 Patch0:                %{name}-autoconf.patch
 Patch1:                %{name}-makefile.patch
@@ -14,16 +19,15 @@ Patch2:             %{name}-pk%{name}-real-peer.patch
 Patch3:                %{name}-get_fast_time.patch
 Patch4:                %{name}-alpha.patch
 URL:           http://sites.inka.de/bigred/devel/cipe.html
-%{!?_without_dist_kernel:BuildRequires: kernel-headers}
+BuildRequires: %{kgcc_package}
+BuildRequires: /usr/bin/openssl
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: openssl-devel >= 0.9.7
-BuildRequires: /usr/bin/openssl
-BuildRequires: %{kgcc_package}
-
+%{!?_without_dist_kernel:BuildRequires:        kernel-headers}
+BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: rpmbuild(macros) >= 1.118
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     /etc
 %define                __cc            %{kgcc}
 
 %description
@@ -42,7 +46,7 @@ podobnych zastosowaniach.
 Summary:       The PKCIPE public key tool for CIPE
 Summary(pl):   PKCIPE - narzêdzie do wykorzystania kluczy publicznych w CIPE
 Group:         Networking/Daemons
-Prereq:                /usr/bin/openssl
+Requires:      /usr/bin/openssl
 Requires:      %{name} = %{version}
 Obsoletes:     %{name}-pkcipe
 
@@ -91,8 +95,8 @@ Summary:      CIPE kernel module
 Summary(pl):   Modu³ j±dra CIPE
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-Prereq:                /sbin/depmod
 %{!?_without_dist_kernel:%requires_releq_kernel_up}
+Requires(post,postun): /sbin/depmod
 
 %description -n kernel-cipe
 CIPE (the name is shortened from *Crypto IP Encapsulation*) is a
@@ -113,8 +117,8 @@ Summary:    CIPE kernel module
 Summary(pl):   Modu³ j±dra CIPE
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-Prereq:                /sbin/depmod
 %{!?_without_dist_kernel:%requires_releq_kernel_smp}
+Requires(post,postun): /sbin/depmod
 
 %description -n kernel-smp-cipe
 CIPE (the name is shortened from *Crypto IP Encapsulation*) is a
@@ -180,7 +184,6 @@ DEFS="-D__SMP__ -D__KERNEL_SMP=1" \
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_infodir}} \
        $RPM_BUILD_ROOT%{_sysconfdir}/cipe/pk \
        $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc \
@@ -210,9 +213,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %post pkcipe-server
 if [ -f /var/lock/subsys/rc-inetd ]; then
-        /etc/rc.d/init.d/rc-inetd reload 1>&2
+       /etc/rc.d/init.d/rc-inetd reload 1>&2
 else
-        echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
+       echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
 fi
 
 %postun pkcipe-server
@@ -220,17 +223,17 @@ if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
        /etc/rc.d/init.d/rc-inetd reload
 fi
 
-%post -n kernel-cipe
-/sbin/depmod -a
+%post  -n kernel-cipe
+%depmod %{_kernel_ver}
 
 %postun -n kernel-cipe
-/sbin/depmod -a
+%depmod %{_kernel_ver}
 
-%post -n kernel-smp-cipe
-/sbin/depmod -a
+%post  -n kernel-smp-cipe
+%depmod %{_kernel_ver}smp
 
 %postun -n kernel-smp-cipe
-/sbin/depmod -a
+%depmod %{_kernel_ver}smp
 
 %files
 %defattr(644,root,root,755)
@@ -248,7 +251,7 @@ fi
 
 %files pkcipe-server
 %defattr(644,root,root,755)
-%attr(640,root,root) %config %verify(not size mtime md5) /etc/sysconfig/rc-inetd/pkcipe
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/pkcipe
 
 %files -n kernel-cipe
 %defattr(644,root,root,755)
This page took 0.071175 seconds and 4 git commands to generate.