]> git.pld-linux.org Git - packages/cinelerra.git/commitdiff
- updated for 2.1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 5 Jul 2006 10:18:28 +0000 (10:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cinelerra-guicast_bootstrap.patch -> 1.5
    cinelerra-system-libs.patch -> 1.10

cinelerra-guicast_bootstrap.patch
cinelerra-system-libs.patch

index 613ef8201773098d00f1c9c4a8793f2750df702e..7d995370d7e499ddc9a939906fb2c65b6e9bef0d 100644 (file)
@@ -19,10 +19,9 @@ diff -dur cinelerra-2.0.orig/guicast/Makefile cinelerra-2.0/guicast/Makefile
  
  $(shell sh -c 'if ! test -d $(OBJDIR)\; then mkdir $(OBJDIR)\; fi' )
  
-diff -dur cinelerra-2.0.orig/guicast/bootstrap.c cinelerra-2.0/guicast/bootstrap.c
---- cinelerra-2.0.orig/guicast/bootstrap.c     2005-04-20 20:15:14.000000000 +0000
-+++ cinelerra-2.0/guicast/bootstrap.c  2006-06-13 18:16:44.413604791 +0000
-@@ -41,7 +41,7 @@
+--- cinelerra-2.1/guicast/bootstrap.c.orig     2006-03-31 07:51:03.000000000 +0200
++++ cinelerra-2.1/guicast/bootstrap.c  2006-07-05 11:35:14.014440000 +0200
+@@ -54,7 +54,7 @@
  
        *buffer_size += strlen(string) + 1;
        
@@ -31,10 +30,10 @@ diff -dur cinelerra-2.0.orig/guicast/bootstrap.c cinelerra-2.0/guicast/bootstrap
        *buffer_size += sizeof(int);
  }
  
-@@ -152,7 +152,7 @@
+@@ -195,7 +195,7 @@
  
  // Run system command on it
-       sprintf(system_command, "%s %s %s", BOOTSTRAP, temp_path, argv[1]);
+       sprintf(system_command, "%s %s %s", BOOTSTRAP, temp_path, out_path);
 -      system(system_command);
 +      return system(system_command);
  }
index 9ec152e752c75886ae85c0b790dfca465527b333..63f49235c16c2dfb19e55ab9e2b2540ee1772beb 100644 (file)
@@ -1,9 +1,8 @@
---- cinelerra-2.0/cinelerra/Makefile.orig      2005-09-07 23:25:21.000000000 +0200
-+++ cinelerra-2.0/cinelerra/Makefile   2005-11-01 13:25:17.219148368 +0100
-@@ -1,27 +1,27 @@
+--- cinelerra-2.1/cinelerra/Makefile.orig      2006-06-01 06:12:23.000000000 +0200
++++ cinelerra-2.1/cinelerra/Makefile   2006-07-05 11:30:45.264440000 +0200
+@@ -1,27 +1,13 @@
  include ../global_config
  
--ALSA_DIR := ../alsa-lib-1.0.8
 -AVC_DIR := $(shell expr ../libavc1394* )
 -DV_DIR := ../quicktime/libdv-0.104
 -EXR_DIR := ../OpenEXR-1.2.1/
 -SNDFILE_DIR := $(shell expr ../libsndfile* )
 -THEORA_DIR := $(shell expr ../libtheora* )
 -TIFF_DIR := ../tiff-v3.5.7
-+#ALSA_DIR := ../alsa-lib-1.0.8
-+#AVC_DIR := $(shell expr ../libavc1394* )
-+#DV_DIR := ../quicktime/libdv-0.104
-+#EXR_DIR := ../OpenEXR-1.2.1/
-+#FFMPEG_DIR := $(shell expr ../quicktime/ffmpeg* )
-+#JPEG_DIR := $(shell expr ../quicktime/jpeg-mmx* )
-+#LAME_DIR := ../quicktime/lame-3.93.1/include
-+#LIBIEC_DIR := $(shell expr ../libiec61883* )
-+#LIBRAW_DIR := $(shell expr ../libraw1394* )
-+#OGG_DIR := $(shell expr ../quicktime/libogg* )
-+#SNDFILE_DIR := $(shell expr ../libsndfile* )
-+#THEORA_DIR := $(shell expr ../libtheora* )
-+#TIFF_DIR := ../tiff-v3.5.7
  TOOLAME_DIR := ../toolame-02l
 -UUID_DIR := ../uuid
 -VORBIS_DIR := $(shell expr ../quicktime/libvorbis* )
-+#UUID_DIR := ../uuid
-+#VORBIS_DIR := $(shell expr ../quicktime/libvorbis* )
+-
 -AVC_LIB := $(AVC_DIR)/libavc1394/.libs/libavc1394.a $(AVC_DIR)/librom1394/.libs/librom1394.a
 -RAW_LIB := $(LIBRAW_DIR)/src/.libs/libraw1394.a
 -IEC_LIB := $(LIBIEC_DIR)/src/.libs/libiec61883.a
 -SNDFILE_LIB := $(SNDFILE_DIR)/src/.libs/libsndfile.a
 -THEORA_LIB := $(THEORA_DIR)/lib/.libs/libtheora.a
 +AVC_LIB := -lavc1394 -lrom1394
 +RAW_LIB := -lraw1394
 +IEC_LIB := -liec61883
 +SNDFILE_LIB := -lsndfile
 +THEORA_LIB := -ltheora
++  
  OBJS = \
        $(OBJDIR)/aattachmentpoint.o \
-@@ -305,29 +305,17 @@
- #endif
- ifeq ($(HAVE_ALSA), y)
--ALSA_CFLAGS := -DHAVE_ALSA -I$(ALSA_DIR)/include
--ALSA_LIBS := $(ALSA_DIR)/$(OBJDIR)/libasound.a
-+ALSA_CFLAGS := -DHAVE_ALSA
-+ALSA_LIBS := -lasound
- endif
+       $(OBJDIR)/aautomation.o \
+@@ -318,21 +304,10 @@
  
  
  STATICLIBS = \
--      $(ALSA_LIBS) \
 -      $(AVC_LIB) \
 -      $(RAW_LIB) \
 -      $(IEC_LIB) \
  
  LIBS := \
        -L./ \
-@@ -344,6 +332,18 @@
+@@ -358,6 +333,17 @@
  
  
  LIBS += \
-+      $(ALSA_LIBS) \
 +      $(AVC_LIB) \
 +      $(RAW_LIB) \
 +      $(IEC_LIB) \
 +      -lquicktime -lvorbisfile \
-+        $(ESOUNDLIBS) \
++      $(ESOUNDLIBS) \
 +      -lIlmImf -lImath -lHalf -lIex \
 +      -ltiff \
 +      -lmpeg3 \
 +      $(SNDFILE_LIB) \
 +      -luuid \
 +      $(THEORA_LIB) \
-       $(GLLIBS) \
        -lX11 \
        -lXext \
-@@ -361,29 +361,22 @@
+       -lXv \
+@@ -374,28 +360,21 @@
  
  CFLAGS += \
        -I../guicast \
 +      -I/usr/include/lame \
 +      -I/usr/include/libmpeg3 \
        $(ESOUNDCFLAGS) \
-       $(ALSA_CFLAGS) \
--      -I$(FFMPEG_DIR)/libavcodec \
+-      -I$(FFMPEG_DIR)/libavcodec -I$(FFMPEG_DIR)/libavutil \
 -      -I$(THEORA_DIR)/include
 +      -I/usr/include/ffmpeg \
 +      -I/usr/include/theora
  
  
  
-@@ -489,7 +482,7 @@
+@@ -501,7 +480,7 @@
  
  $(FILEEXR): fileexr.C
        @echo C++ $*.o
        -I../colors \
        -fPIC
  
---- cinelerra-1.2.0/cinelerra/audioalsa.h.orig 2003-10-14 09:53:59.000000000 +0200
-+++ cinelerra-1.2.0/cinelerra/audioalsa.h      2004-06-05 10:26:45.584744408 +0200
-@@ -5,7 +5,7 @@
- #include "audiodevice.h"
- #ifdef HAVE_ALSA
--#include "asoundlib.h"
-+#include <alsa/asoundlib.h>
- class AudioALSA : public AudioLowLevel
- {
 --- cinelerra-2.0/guicast/Makefile.orig        2005-11-01 14:30:52.865839000 +0100
 +++ cinelerra-2.0/guicast/Makefile     2005-11-01 14:41:01.161364152 +0100
 @@ -2,9 +2,9 @@
This page took 0.142424 seconds and 4 git commands to generate.