]> git.pld-linux.org Git - packages/cinelerra.git/commitdiff
- fix building with ffmpeg 0.6 auto/ti/cinelerra-4_1-3
authorhawk <hawk@pld-linux.org>
Wed, 25 Aug 2010 11:49:13 +0000 (11:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cinelerra-ffmpeg.patch -> 1.3
    cinelerra.spec -> 1.41

cinelerra-ffmpeg.patch
cinelerra.spec

index 5e587ece73d8f1b17424518b31eeb36a8b5d1958..0496060f4407d097c30ce58675dd6496de7fed63 100644 (file)
@@ -1,57 +1,34 @@
---- cinelerra-4/quicktime/mpeg4.c~     2008-09-02 14:38:12.000000000 +0300
-+++ cinelerra-4/quicktime/mpeg4.c      2009-07-07 11:53:27.567616978 +0300
-@@ -680,7 +680,11 @@
+Only in cinelerra-4.1.fix/bin: cinelerra
+diff -ur cinelerra-4.1.orig/cinelerra/fileac3.C cinelerra-4.1.fix/cinelerra/fileac3.C
+--- cinelerra-4.1.orig/cinelerra/fileac3.C     2010-08-25 13:18:55.974081519 +0200
++++ cinelerra-4.1.fix/cinelerra/fileac3.C      2010-08-25 13:36:19.960436542 +0200
+@@ -19,6 +19,8 @@
+  * 
+  */
  
- //            context->b_quant_factor = 1.25;
- //            context->b_quant_offset = 1.25;
-+//              #if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
- //                    context->error_resilience = FF_ER_CAREFUL;
-+//              #else
-+//                    context->error_recognition = FF_ER_CAREFUL;
-+//              #endif
- //                    context->error_concealment = 3;
- //                    context->frame_skip_cmp = FF_CMP_DCTMAX;
- //                    context->ildct_cmp = FF_CMP_VSAD;
---- cinelerra-4/quicktime/wma.c        2007-01-09 08:09:49.000000000 +0100
-+++ cinelerra-4-new/quicktime/wma.c    2008-10-11 18:57:13.831898263 +0200
-@@ -187,11 +187,20 @@ printf("decode 2 %x %llx %llx\n", chunk_
++#define __STDC_CONSTANT_MACROS
++
+ #include "asset.h"
  
- // Decode chunk into work buffer.
-               pthread_mutex_lock(&ffmpeg_lock);
-+       #if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
-               result = avcodec_decode_audio(codec->decoder_context, 
-                       (int16_t*)(codec->work_buffer + codec->output_size * sample_size), 
-             &bytes_decoded,
-             codec->packet_buffer, 
-                       chunk_size);
-+       #else
-+              bytes_decoded = AVCODEC_MAX_AUDIO_FRAME_SIZE;
-+              result = avcodec_decode_audio2(codec->decoder_context, 
-+                      (int16_t*)(codec->work_buffer + codec->output_size * sample_size),
-+                      &bytes_decoded,
-+                      codec->packet_buffer,
-+                      chunk_size);
-+       #endif
-               pthread_mutex_unlock(&ffmpeg_lock);
-               if(bytes_decoded <= 0)
-               {
---- cinelerra-4/cinelerra/fileffmpeg.C 2008-08-06 10:58:43.000000000 +0200
-+++ cinelerra-4-new/cinelerra/fileffmpeg.C     2008-10-11 19:10:39.978678517 +0200
-@@ -384,7 +384,7 @@ void FileFFMPEG::dump_context(void *ptr)
-       printf("    codec_id=%d\n", context->codec_id);
-       printf("    codec_tag=%d\n", context->codec_tag);
-       printf("    workaround_bugs=%d\n", context->workaround_bugs);
--      printf("    error_resilience=%d\n", context->error_resilience);
-+      printf("    error_recognition=%d\n", context->error_recognition);
-       printf("    has_b_frames=%d\n", context->has_b_frames);
-       printf("    block_align=%d\n", context->block_align);
-       printf("    parse_only=%d\n", context->parse_only);
-@@ -393,7 +393,7 @@ void FileFFMPEG::dump_context(void *ptr)
-       printf("    slice_offset=%p\n", context->slice_offset);
-       printf("    error_concealment=%d\n", context->error_concealment);
-       printf("    dsp_mask=%p\n", context->dsp_mask);
--      printf("    bits_per_sample=%d\n", context->bits_per_sample);
-+      printf("    bits_per_coded_sample=%d\n", context->bits_per_coded_sample);
-       printf("    slice_flags=%d\n", context->slice_flags);
-       printf("    xvmc_acceleration=%d\n", context->xvmc_acceleration);
-       printf("    antialias_algo=%d\n", context->antialias_algo);
+ extern "C" 
+diff -ur cinelerra-4.1.orig/cinelerra/fileffmpeg.C cinelerra-4.1.fix/cinelerra/fileffmpeg.C
+--- cinelerra-4.1.orig/cinelerra/fileffmpeg.C  2010-08-25 13:18:56.057207183 +0200
++++ cinelerra-4.1.fix/cinelerra/fileffmpeg.C   2010-08-25 13:36:03.847102952 +0200
+@@ -19,6 +19,8 @@
+  * 
+  */
++#define __STDC_CONSTANT_MACROS
++
+ #include "asset.h" 
+ extern "C" 
+ {
+@@ -574,7 +576,7 @@
+                       case PIX_FMT_YUV420P:
+                               input_cmodel = BC_YUV420P;
+                               break;
+-                      case PIX_FMT_YUV422:
++                      case PIX_FMT_YUYV422:
+                               input_cmodel = BC_YUV422;
+                               break;
+                       case PIX_FMT_YUV422P:
index 58e252e56bea775261ff1be455ce6fe18cbc849d..beb5a97213ed59b137d8e04ce753381cdc68b99c 100644 (file)
@@ -9,7 +9,7 @@ Summary:        Cinelerra - capturing, editing and production of audio/video material
 Summary(pl.UTF-8):     Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
 Name:          cinelerra
 Version:       4.1
-Release:       2
+Release:       3
 License:       GPL v2+
 Group:         X11/Applications
 Source0:       http://dl.sourceforge.net/heroines/%{name}-%{version}-src.tar.bz2
@@ -21,6 +21,7 @@ Patch3:               %{name}-locale_h.patch
 Patch4:                %{name}-guicast_bootstrap.patch
 Patch5:                %{name}-fix.patch
 Patch6:                %{name}-libpng.patch
+Patch7:                %{name}-ffmpeg.patch
 URL:           http://www.heroinewarrior.com/cinelerra.php
 BuildRequires: OpenEXR-devel >= 1.6.1
 BuildRequires: OpenGL-GLU-devel
@@ -28,6 +29,7 @@ BuildRequires:        OpenGL-devel >= 2.0
 BuildRequires: alsa-lib-devel >= 1.0.8
 BuildRequires: bzip2-devel
 BuildRequires: esound-devel
+BuildRequires: ffmpeg-devel >= 0.6
 BuildRequires: flac-devel >= 1.1.4
 BuildRequires: freetype-devel >= 2.1.4
 BuildRequires: lame-libs-devel >= 3.93.1
@@ -96,6 +98,7 @@ Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p0
+%patch7 -p1
 
 # assume we have <linux/videodev2.h> and <linux/dvb/*> (present in llh)
 cat > hvirtual_config.h <<EOF
This page took 0.067729 seconds and 4 git commands to generate.