]> git.pld-linux.org Git - packages/cinelerra.git/commitdiff
- 1.1.8, updated system-libs,libsndfile1,strip patches
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 12 Nov 2003 23:28:39 +0000 (23:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cinelerra-libsndfile1.patch -> 1.4
    cinelerra-strip.patch -> 1.2
    cinelerra-system-libs.patch -> 1.5

cinelerra-libsndfile1.patch
cinelerra-strip.patch
cinelerra-system-libs.patch

index fba1b45a5e43b247ae406f30c9e84573bfe93e3b..2461fe99620d185e7b97ae33ba558fc1e8b329d3 100644 (file)
---- cinelerra-1.1.7/cinelerra/filesndfile.C.orig       Sat Nov  2 10:06:39 2002
-+++ cinelerra-1.1.7/cinelerra/filesndfile.C    Fri Mar 21 01:19:58 2003
-@@ -25,7 +25,7 @@
-       SF_INFO fd_config;
-       fd_config.format = 0;
- //printf("FileSndFile::check_sig 1\n");
--      SNDFILE *fd = sf_open_read(asset->path, &fd_config);
-+      SNDFILE *fd = sf_open(asset->path, SFM_READ, &fd_config);
- //printf("FileSndFile::check_sig 1 %p\n", fd);
-       if(fd)
-@@ -56,30 +56,29 @@
-               case BITSLINEAR8:
-               case BITSLINEAR16:
-               case BITSLINEAR24:
--                      if(asset->format != FILE_PCM)
--                      {
--                              fd_config.format |= SF_FORMAT_PCM;
--                      }
--                      else
-+                      if(asset->format == FILE_PCM)
+--- cinelerra-1.1.8/cinelerra/filesndfile.C.orig       2003-10-19 11:51:37.000000000 +0200
++++ cinelerra-1.1.8/cinelerra/filesndfile.C    2003-11-12 22:54:02.284687776 +0100
+@@ -34,7 +34,7 @@
+       FILE *fileptr = fopen(asset->path, "r");
+       if(fileptr)
+       {
+-              SNDFILE *fd = sf_open_fd(fileptr, asset->path, SFM_READ, &fd_config, 0);
++              SNDFILE *fd = sf_open_fd(fileno(fileptr), SFM_READ, &fd_config, 0);
+               if(fd)
+               {
+                       sf_close(fd);
+@@ -209,7 +209,7 @@
+                       fileptr = fopen(asset->path, "r");
+                       if(fileptr)
                        {
-                               if(asset->byte_order)
--                                      fd_config.format |= SF_FORMAT_PCM_LE;
-+                                      fd_config.format |= SF_ENDIAN_LITTLE;
-                               else
--                                      fd_config.format |= SF_FORMAT_PCM_BE;
-+                                      fd_config.format |= SF_ENDIAN_BIG;
+-                              fd = sf_open_fd(fileptr, asset->path, SFM_READ, &fd_config, 0);
++                              fd = sf_open_fd(fileno(fileptr), SFM_READ, &fd_config, 0);
+                               if(fd) format_to_asset();
                        }
--                      fd_config.pcmbitwidth = asset->bits;
--//printf("FileSndFile::asset_to_format 1 %x %d\n", fd_config.format, fd_config.pcmbitwidth);
-+                      if(asset->bits == BITSLINEAR8)
-+                              fd_config.format |= SF_FORMAT_PCM_S8;
-+                      else if(asset->bits == BITSLINEAR16)
-+                              fd_config.format |= SF_FORMAT_PCM_16;
-+                      else
-+                              fd_config.format |= SF_FORMAT_PCM_24;
-+//printf("FileSndFile::asset_to_format 1 %x\n", fd_config.format);
-                       break;
-               case BITSULAW: 
-                       fd_config.format |= SF_FORMAT_ULAW; 
--                      fd_config.pcmbitwidth = 16;
-                       break;
-               case BITSFLOAT: 
- //printf("FileSndFile::asset_to_format 1\n");
-                       fd_config.format |= SF_FORMAT_FLOAT; 
--                      fd_config.pcmbitwidth = 16;
-                       break;
-               case BITS_ADPCM: 
-@@ -87,14 +86,13 @@
-                               fd_config.format |= SF_FORMAT_MS_ADPCM;
-                       else
-                               fd_config.format |= SF_FORMAT_IMA_ADPCM; 
--                      fd_config.pcmbitwidth = 16;
-                       break;
-       }
-       fd_config.seekable = 1;
-       fd_config.samplerate = asset->sample_rate;
-       fd_config.channels  = asset->channels;
--//printf("FileSndFile::asset_to_format %x %d %d\n", fd_config.format, fd_config.pcmbitwidth, fd_config.channels);
-+//printf("FileSndFile::asset_to_format %x %d\n", fd_config.format, fd_config.channels);
- }
- void FileSndFile::format_to_asset()
-@@ -113,7 +111,6 @@
-                               break;
-                       case SF_FORMAT_AIFF: asset->format = FILE_AIFF; break;
-                       case SF_FORMAT_AU:   asset->format = FILE_AU;   break;
--                      case SF_FORMAT_AULE: asset->format = FILE_AU;   break;
-                       case SF_FORMAT_RAW:  asset->format = FILE_PCM;  break;
-                       case SF_FORMAT_PAF:  asset->format = FILE_SND;  break;
-                       case SF_FORMAT_SVX:  asset->format = FILE_SND;  break;
-@@ -132,17 +129,6 @@
-               case SF_FORMAT_MS_ADPCM:
-                       asset->bits = BITS_ADPCM;
-                       break;
--              case SF_FORMAT_PCM:
--                      asset->bits = fd_config.pcmbitwidth;
--                      break;
--              case SF_FORMAT_PCM_BE:
--                      asset->byte_order = 0;
--                      asset->bits = fd_config.pcmbitwidth;
--                      break;
--              case SF_FORMAT_PCM_LE:
--                      asset->byte_order = 1;
--                      asset->bits = fd_config.pcmbitwidth;
--                      break;
-               case SF_FORMAT_PCM_S8:
-                       asset->signed_ = 1;
-                       asset->bits = BITSLINEAR8;
-@@ -151,14 +137,30 @@
-                       asset->signed_ = 0;
-                       asset->bits = BITSLINEAR8;
-                       break;
-+              case SF_FORMAT_PCM_16:
-+                      asset->bits = BITSLINEAR16;
-+                      break;
-+              case SF_FORMAT_PCM_24:
-+                      asset->bits = BITSLINEAR24;
-+                      break;
-+              case SF_FORMAT_PCM_32:
-+                      asset->bits = BITSLINEAR32;
-+                      break;
-+      }
-+      switch(fd_config.format & SF_FORMAT_ENDMASK) {
-+              case SF_ENDIAN_LITTLE:
-+                      asset->byte_order = 1;
-+                      break;
-+              case SF_ENDIAN_BIG:
-+                      asset->byte_order = 0;
-+                      break;
-       }
--
-       asset->audio_data = 1;
--      asset->audio_length = fd_config.samples;
-+      asset->audio_length = fd_config.frames;
-       if(!asset->sample_rate)
-               asset->sample_rate = fd_config.samplerate;
-       asset->channels = fd_config.channels;
--//printf("FileSndFile::format_to_asset %x %d %d %x\n", fd_config.format & SF_FORMAT_TYPEMASK, fd_config.pcmbitwidth, fd_config.samples, fd_config.format & SF_FORMAT_SUBMASK);
-+//printf("FileSndFile::format_to_asset %x %d %x\n", fd_config.format & SF_FORMAT_TYPEMASK, fd_config.frames, fd_config.format & SF_FORMAT_SUBMASK);
- //asset->dump();
- }
-@@ -172,12 +174,12 @@
-               if(asset->format == FILE_PCM)
-               {
-                       asset_to_format();
--                      fd = sf_open_read(asset->path, &fd_config);
-+                      fd = sf_open(asset->path, SFM_READ, &fd_config);
-                       format_to_asset();
                }
-               else
-               {
--                      fd = sf_open_read(asset->path, &fd_config);
-+                      fd = sf_open(asset->path, SFM_READ, &fd_config);
+@@ -218,7 +218,7 @@
+                       fileptr = fopen(asset->path, "r");
+                       if(fileptr)
+                       {
+-                              fd = sf_open_fd(fileptr, asset->path, SFM_READ, &fd_config, 0);
++                              fd = sf_open_fd(fileno(fileptr), SFM_READ, &fd_config, 0);
  // Doesn't calculate the length
-                       format_to_asset();
-               }
-@@ -188,7 +190,7 @@
- //printf("FileSndFile::open_file 1\n");
-               asset_to_format();
- //printf("FileSndFile::open_file 1\n");
--              fd = sf_open_write(asset->path, &fd_config);
-+              fd = sf_open(asset->path, SFM_WRITE, &fd_config);
- //printf("FileSndFile::open_file 2 %p\n", fd);
-       }
-@@ -252,7 +254,7 @@
-       }
- //printf("FileSndFile::read_samples 3\n");
--      result = !sf_read_double(fd, temp_double, len * asset->channels, 1);
-+      result = !sf_read_double(fd, temp_double, len * asset->channels);
- //printf("FileSndFile::read_samples 4\n");
-       if(result)
-@@ -305,7 +307,7 @@
+                               if(fd) format_to_asset();
+                       }
+@@ -231,7 +231,7 @@
+               fileptr = fopen(asset->path, "w");
+               if(fileptr)
+               {
+-                      fd = sf_open_fd(fileptr, asset->path, SFM_WRITE, &fd_config, 0);
++                      fd = sf_open_fd(fileno(fileptr), SFM_WRITE, &fd_config, 0);
                }
        }
-       
--      result = !sf_writef_double(fd, temp_double, len, 1);
-+      result = !sf_writef_double(fd, temp_double, len);
  
-       return result;
- }
index 9cfe0b3d47718a62001f55600c0134c4dd5c8636..aad16420fd483fa1c6712fccf8a5c0bc39fdcdde 100644 (file)
        ../../cinelerra/$(OBJDIR)/bootstrap $(OUTPUT_THEME) data/*.png
  
  include ../../plugin_config
+--- cinelerra-1.1.8/cinelerra/Makefile.orig    2003-11-12 22:55:18.000000000 +0100
++++ cinelerra-1.1.8/cinelerra/Makefile 2003-11-12 23:58:29.493782632 +0100
+@@ -391,7 +391,7 @@
+ # Static linking is not possible because of the way the plugins are loaded
+ $(OUTPUT): $(OBJS) $(BOOTSTRAP)
+       $(LINKER) `cat $(OBJDIR)/objs`
+-      strip $(OUTPUT)
++      $(STRIP) $(OUTPUT)
+       ../guicast/$(OBJDIR)/bootstrap $(OUTPUT) data/mode_*.png
+ $(OBJDIR)/test: 
index eea53b7feefebaeb7500465a602fa937dffd2cff..edc0799ee58c053edcd630875d9c310cd38d2dec 100644 (file)
@@ -1,23 +1,6 @@
---- cinelerra-1.1.5/mplexlo/Makefile.orig      Sat Jul 13 04:19:23 2002
-+++ cinelerra-1.1.5/mplexlo/Makefile   Fri Mar 21 00:41:10 2003
-@@ -2,12 +2,12 @@
- OBJS = $(OBJDIR)/mplex.o
- CC = gcc
--CFLAGS += -I../libmpeg3
-+CFLAGS += -I/usr/include/libmpeg3
- OUTPUT := $(OBJDIR)/mplexlo
- $(OUTPUT): $(OBJS)
--      $(CC) -o $(OUTPUT) $(OBJS) ../libmpeg3/$(OBJDIR)/libmpeg3.a -lpthread -lm
-+      $(CC) -o $(OUTPUT) $(OBJS) -lmpeg3 -lpthread -lm
- $(OBJS):
-       $(CC) -c $(CFLAGS) $(subst $(OBJDIR)/,, $*.c) -o $*.o
---- cinelerra-1.1.7/cinelerra/Makefile.orig    2003-08-09 22:24:28.000000000 +0200
-+++ cinelerra-1.1.7/cinelerra/Makefile 2003-08-16 23:10:48.654994168 +0200
-@@ -1,12 +1,4 @@
+--- cinelerra-1.1.8/cinelerra/Makefile.orig    2003-11-08 08:15:35.000000000 +0100
++++ cinelerra-1.1.8/cinelerra/Makefile 2003-11-12 22:15:55.010406320 +0100
+@@ -1,13 +1,4 @@
 -DV_DIR := ../quicktime/libdv-0.99
 -ALSA_DIR := ../alsa-lib-0.9.0rc2
 -OGG_DIR := ../quicktime/libogg-1.0
 -UUID_DIR := ../uuid
  TOOLAME_DIR := ../toolame-02l
 -LAME_DIR := ../quicktime/lame-3.93.1/include
+-SNDFILE_DIR := $(shell expr ../libsndfile* )
  include ../global_config
  
  OBJS = \
-@@ -271,18 +263,12 @@
+@@ -267,23 +258,17 @@
+ #ifeq ($(HAVE_AVIFILE), y)
+-AVIFILE_DIR := $(shell expr ../avifile* )
++#AVIFILE_DIR := $(shell expr ../avifile* )
+ #endif
  
- ifeq ($(HAVE_ALSA), yes)
- ALSA_CFLAGS := -DHAVE_ALSA -I$(ALSA_DIR)/include
+ ifeq ($(HAVE_ALSA), y)
+-ALSA_CFLAGS := -DHAVE_ALSA -I$(ALSA_DIR)/include
 -ALSA_LIBS := $(ALSA_DIR)/$(OBJDIR)/libasound.a
++ALSA_CFLAGS := -DHAVE_ALSA
 +ALSA_LIBS := -lasound
  endif
  
 -      $(TIFF_DIR)/$(OBJDIR)/libtiff.a \
        ../guicast/$(OBJDIR)/libguicast.a \
 -      ../libmpeg3/$(OBJDIR)/libmpeg3.a \
--      ../libsndfile/$(OBJDIR)/libsndfile.a \
+-      $(SNDFILE_DIR)/$(OBJDIR)/libsndfile.a \
 -      $(UUID_DIR)/$(OBJDIR)/libuuid.a \
        ../mpeg2enc/$(OBJDIR)/mpeg2enc.a \
        $(TOOLAME_DIR)/$(OBJDIR)/toolame.a
  
-@@ -301,8 +287,13 @@
+@@ -303,7 +288,13 @@
  
  LIBS += \
--      $(ALSA_LIBS) \
+       $(ALSA_LIBS) \
 -      $(LIBRAW_DIR)/$(OBJDIR)/libraw1394.a \
 +      -lavc1394 -lrom1394 \
 +      -lquicktime -lvorbisfile \
@@ -66,7 +56,7 @@
        $(GLLIBS) \
        -lX11 \
        -lXext \
-@@ -317,22 +308,14 @@
+@@ -322,22 +313,14 @@
  
  CFLAGS += \
        -I../guicast \
@@ -86,7 +76,7 @@
 -      -I$(LAME_DIR) \
 -      -I../audiofile \
 -      -I../libmpeg3 \
--      -I../libsndfile \
+-      -I$(SNDFILE_DIR)/src \
 -      -I../libavc/common \
 -      -I../libavc/libavc1394 \
 -      -I../libavc/librom1394 \
 +      -I/usr/include/libmpeg3 \
 +      -I/usr/include/libavc1394 \
        $(ESOUNDCFLAGS) \
-       $(ALSA_CFLAGS) \
-       `glib-config --cflags`
---- cinelerra-1.1.5/global_config.orig Wed Jan 29 07:32:31 2003
-+++ cinelerra-1.1.5/global_config      Fri Mar 21 00:53:25 2003
-@@ -15,7 +15,7 @@
- ############################# FINAL DESTINATION FOR INSTALLATION BINARIES
--PREFIX = /usr/local
-+PREFIX = /usr
- LIBPREFIX = $(PREFIX)/lib
- ########################## COMPILER
-@@ -41,8 +41,8 @@
- ifeq ($(HAVE_ESOUND), yes)
--ESOUNDCFLAGS = -DHAVE_ESOUND -I../esound
--ESOUNDLIBS = ../esound/$(OBJDIR)/libesound.a
-+ESOUNDCFLAGS = -DHAVE_ESOUND
-+ESOUNDLIBS = -lesd
- endif
+       $(ALSA_CFLAGS)
  
+--- cinelerra-1.1.8/cinelerra/jpegwrapper.h.orig       2003-10-14 09:54:01.000000000 +0200
++++ cinelerra-1.1.8/cinelerra/jpegwrapper.h    2003-11-12 22:28:31.358423944 +0100
+@@ -7,7 +7,7 @@
+ extern "C" {
+ #endif
  
---- cinelerra-1.1.7/plugin_config.orig 2003-07-26 09:09:41.000000000 +0200
-+++ cinelerra-1.1.7/plugin_config      2003-08-16 23:12:37.860392424 +0200
-@@ -1,6 +1,6 @@
- CFLAGS += -I../ -I../../cinelerra \
-       -I../../guicast \
--      -I../../quicktime \
-+      -I/usr/include/quicktime \
-       -I../colors \
-       -fPIC
+-#include "jpeg/jpeglib.h"
++#include <jpeglib.h>
  
---- cinelerra-1.1.5/mpeg2enc/Makefile.orig     Sat Aug  3 04:18:42 2002
-+++ cinelerra-1.1.5/mpeg2enc/Makefile  Fri Mar 21 01:35:40 2003
+ #ifdef __cplusplus
+ }
+--- cinelerra-1.1.8/mpeg2enc/Makefile.orig     2003-10-14 09:54:43.000000000 +0200
++++ cinelerra-1.1.8/mpeg2enc/Makefile  2003-11-12 22:23:56.387225920 +0100
 @@ -1,6 +1,6 @@
  include ../global_config
  CC = gcc
        -lpthread \
        -lpng \
        -lz \
---- cinelerra-1.1.7/plugins/titler/Makefile.orig       2003-07-20 11:05:04.000000000 +0200
-+++ cinelerra-1.1.7/plugins/titler/Makefile    2003-08-16 23:19:45.490382784 +0200
-@@ -1,5 +1,4 @@
+--- cinelerra-1.1.8/mplexlo/Makefile.orig      2003-10-14 09:54:14.000000000 +0200
++++ cinelerra-1.1.8/mplexlo/Makefile   2003-11-12 22:06:01.235673800 +0100
+@@ -2,12 +2,12 @@
+ OBJS = $(OBJDIR)/mplex.o
+ CC = gcc
+-CFLAGS += -I../libmpeg3
++CFLAGS += -I/usr/include/libmpeg3
+ OUTPUT := $(OBJDIR)/mplexlo
+ $(OUTPUT): $(OBJS)
+-      $(CC) -o $(OUTPUT) $(OBJS) ../libmpeg3/$(OBJDIR)/libmpeg3.a -lpthread -lm
++      $(CC) -o $(OUTPUT) $(OBJS) -lmpeg3 -lpthread -lm
+ $(OBJS):
+       $(CC) -c $(CFLAGS) $(subst $(OBJDIR)/,, $*.c) -o $*.o
+--- cinelerra-1.1.8/plugins/titler/Makefile.orig       2003-10-24 05:22:18.000000000 +0200
++++ cinelerra-1.1.8/plugins/titler/Makefile    2003-11-12 22:28:16.244721576 +0100
+@@ -8,19 +8,18 @@
+ OUTPUT_PLUGIN = ../$(OBJDIR)/titler.plugin
 -FREETYPE_DIR = ../../freetype-2.1.4
 -CFLAGS += -I$(FREETYPE_DIR)/include -I../../
-+CFLAGS += -I/usr/include/freetype2
++FREETYPE_DIR =
++CFLAGS += -I/usr/include/freetype2 -I../../
  
- include ../../global_config
  
-@@ -15,12 +14,11 @@
  $(OUTPUT_PLUGIN): $(OBJS)
        $(LDLINKER) -o $(OUTPUT_PLUGIN) \
                $(OBJS) \
        cp $(OUTPUT_PLUGIN) /usr/lib/cinelerra
        cp -a fonts /usr/lib/cinelerra
  
---- cinelerra-1.1.5/cinelerra/jpegwrapper.h.orig       Fri Jun 21 14:35:24 2002
-+++ cinelerra-1.1.5/cinelerra/jpegwrapper.h    Mon Mar 24 12:53:00 2003
-@@ -7,7 +7,7 @@
- extern "C" {
- #endif
+--- cinelerra-1.1.8/global_config.orig 2003-10-29 10:05:08.000000000 +0100
++++ cinelerra-1.1.8/global_config      2003-11-12 22:22:09.103535520 +0100
+@@ -24,7 +24,7 @@
  
--#include "jpeg/jpeglib.h"
-+#include <jpeglib.h>
+ ############################# FINAL DESTINATION FOR INSTALLATION BINARIES
+-PREFIX = /usr/
++PREFIX = /usr
+ LIBPREFIX = $(PREFIX)/lib
+ ########################## THE COMPILER
+@@ -50,8 +50,8 @@
+ ifeq ($(HAVE_ESOUND), y)
+-ESOUNDCFLAGS = -DHAVE_ESOUND -I../esound
+-ESOUNDLIBS = ../esound/$(OBJDIR)/libesound.a
++ESOUNDCFLAGS = -DHAVE_ESOUND
++ESOUNDLIBS = -lesd
+ endif
+@@ -59,8 +59,8 @@
+ CFLAGS += -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+ #CFLAGS += -I.      # Caused fileavi.C to fail
+-FREETYPE_DIR = ../../freetype-2.1.4
+-CFLAGS += -I$(FREETYPE_DIR)/include -I../../
++FREETYPE_DIR =
++CFLAGS += -I/usr/include/freeetype2
+ ifeq ($(HAVE_OSS), y)
+ CFLAGS += -DHAVE_OSS
+--- cinelerra-1.1.8/plugin_config.orig 2003-10-14 09:53:58.000000000 +0200
++++ cinelerra-1.1.8/plugin_config      2003-11-12 22:22:42.189505688 +0100
+@@ -1,6 +1,6 @@
+ CFLAGS += -I../ -I../../cinelerra \
+       -I../../guicast \
+-      -I../../quicktime \
++      -I/usr/include/quicktime \
+       -I../colors \
+       -fPIC
  
- #ifdef __cplusplus
- }
This page took 0.127221 seconds and 4 git commands to generate.