]> git.pld-linux.org Git - packages/cinelerra.git/blob - cinelerra.spec
- fixed plugindir patch
[packages/cinelerra.git] / cinelerra.spec
1 #
2 # imho, it is pointless to build this app with system libraries until we
3 # start submitting patches to the author (is that possible with his
4 # current development and release strategy?)... anyway, the todo follows
5 # - deal with fonts dir patch
6 # - review existing, but commented out patches
7 # - send the existing patches to the author (so we do not have to maintain
8 #   them forever)
9 # - build with set of current systems libs
10 # - quicktime4linux seems to be dead as separate library, use the provided
11 #   one
12 # - build guicast as separate, shared library to use in xmovie,
13 #   mix2005 and cinelerra
14 #
15 Summary:        Cinelerra - capturing, editing and production of audio/video material
16 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
17 Name:           cinelerra
18 Version:        4.4
19 Release:        0.1
20 License:        GPL v2+
21 Group:          X11/Applications
22 Source0:        http://dl.sourceforge.net/heroines/%{name}-%{version}-src.tar.xz
23 # Source0-md5:  252d811546025470ae4d7fa31c1f52d4
24 Patch0:         %{name}-system-libs.patch
25 Patch1:         %{name}-strip.patch
26 Patch2:         %{name}-fontsdir.patch
27 Patch3:         %{name}-locale_h.patch
28 Patch4:         %{name}-guicast_bootstrap.patch
29 Patch6:         %{name}-libpng.patch
30 Patch7:         %{name}-ffmpeg.patch
31 Patch8:         %{name}-typo.patch
32 # see speech_tools package
33 Patch9:         %{name}-st.patch
34 Patch10:        %{name}-plugindir.patch
35 URL:            http://www.heroinewarrior.com/cinelerra.php
36 BuildRequires:  OpenEXR-devel >= 1.6.1
37 BuildRequires:  OpenGL-GLU-devel
38 BuildRequires:  OpenGL-devel >= 2.0
39 BuildRequires:  alsa-lib-devel >= 1.0.8
40 BuildRequires:  bzip2-devel
41 #x#BuildRequires:       esound-devel
42 BuildRequires:  ffmpeg-devel >= 0.6
43 BuildRequires:  flac-devel >= 1.1.4
44 BuildRequires:  freetype-devel >= 2.1.4
45 BuildRequires:  lame-libs-devel >= 3.93.1
46 BuildRequires:  libavc1394-devel >= 0.5.1
47 BuildRequires:  libiec61883-devel >= 1.0.0
48 BuildRequires:  libmpeg3-devel >= 1.8
49 BuildRequires:  libraw1394-devel >= 1.2.0
50 BuildRequires:  libsndfile-devel >= 1.0.11
51 BuildRequires:  libstdc++-devel >= 5:3.2.2
52 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
53 BuildRequires:  libtiff-devel >= 3.5.7
54 BuildRequires:  libuuid-devel
55 %ifarch %{ix86}
56 BuildRequires:  nasm
57 %endif
58 #x#BuildRequires:       quicktime4linux-devel >= 2.3
59 BuildRequires:  xorg-lib-libX11-devel
60 BuildRequires:  xorg-lib-libXext-devel
61 BuildRequires:  xorg-lib-libXv-devel
62 BuildRequires:  xorg-lib-libXxf86vm-devel
63 Requires:       OpenEXR >= 1.6.1
64 Requires:       alsa-lib >= 1.0.8
65 Requires:       freetype >= 2.1.4
66 Requires:       libavc1394 >= 0.5.1
67 Requires:       libiec61883 >= 1.0.0
68 Requires:       libmpeg3 >= 1.8
69 Requires:       libraw1394 >= 1.2.0
70 Requires:       libsndfile >= 1.0.11
71 Requires:       libtheora >= 1.0-0.alpha4
72 #x#Requires:    quicktime4linux >= 2.3
73 Obsoletes:      bcast
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _noautostrip    .*/microtheme.plugin
77
78 %description
79 There are two types of moviegoers: producers who create new content,
80 going back over their content at future points for further refinement,
81 and consumers who want to acquire the content and watch it. Cinelerra
82 is not intended for consumers. Cinelerra has many features for
83 uncompressed content, high resolution processing, and compositing,
84 with very few shortcuts. Producers need these features because of the
85 need to retouch many generations of footage with alterations to the
86 format, which makes Cinelerra very complex.
87
88 Cinelerra was meant to be a Broadcast 2000 replacement.
89
90 %description -l pl.UTF-8
91 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
92 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
93 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
94 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
95 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
96 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
97 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
98 modyfikacji formatu, co czyni program bardzo złożonym.
99
100 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
101
102 %prep
103 %setup -q
104 #x#%patch0 -p1
105 #x#%patch1 -p1
106 %patch2 -p1
107 #x#%patch3 -p1
108 #x#%patch4 -p1
109 #x#%patch5 -p1
110 %patch6 -p0
111 #x#%patch7 -p1
112 %patch8 -p1
113 %patch9 -p0
114 %patch10 -p1
115
116 #x## assume we have <linux/videodev2.h> and <linux/dvb/*> (present in llh)
117 #x#cat > hvirtual_config.h <<EOF
118 #x##define HAVE_VIDEO4LINUX2
119 #x##define HAVE_DVB
120 #x##define HAVE_GL
121 #x##define PACKAGE_STRING "cinelerra"
122 #x#EOF
123
124 #x#%{__rm} -r libmpeg3 quicktime \
125 #x#        thirdparty/{audiofile,esound,fftw-*,flac-*,freetype-*,ilmbase-*,libavc1394-*,libiec61883-*,libraw1394-*,libsndfile-*,libtheora-*,mjpegtools-*,openexr-*,tiff-*,uuid}
126
127 %build
128 export CFLAGS="%{rpmcflags}"
129 #x#%{__make} -f build/Makefile.toolame \
130 #x#    STRIP="true" \
131 #x#    GCC="%{__cc}"
132 #x#%{__make} -C mpeg2enc \
133 #x#    STRIP="true" \
134 #x#    CC="%{__cc}"
135 #x#%{__make} -C mplexlo \
136 #x#    STRIP="true" \
137 #x#    CC="%{__cc}"
138 #x#%{__make} -C guicast \
139 #x#    STRIP="true" \
140 #x#    GCC="%{__cc}" \
141 #x#    CC="%{__cxx}"
142 #x## cinelerra, defaulttheme and microtheme are stripped before running "bootstrap"
143 #x#%{__make} -C cinelerra \
144 #x#    STRIP="true" \
145 #x#    GCC="%{__cc}" \
146 #x#    CC="%{__cxx}" \
147 #x#    LINKER='%{__cxx} -o $(OUTPUT)'
148 #x#%{__make} -C plugins \
149 #x#    STRIP="true" \
150 #x#    CC="%{__cxx}" \
151
152 unset CFLAGS
153 (
154     # to replace -ltermcap with -tncurses
155     cd thirdparty/speech_tools
156     rm ./config.cache
157     ./configure
158 )
159
160 ./configure
161 make CINELERRA_PLUGIN_DIR='\"%{_libdir}/%{name}/\"'
162
163 (
164     # to link with libva
165     cd cinelerra
166     g++ -o ../bin/cinelerra `cat x86_64/objs` -lva
167 )
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/cinelerra}
172 cp -a bin/* $RPM_BUILD_ROOT%{_libdir}/cinelerra
173 mv $RPM_BUILD_ROOT{%{_libdir}/cinelerra,%{_bindir}}/cinelerra
174 rm -r $RPM_BUILD_ROOT%{_libdir}/cinelerra/c_flags
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %files
180 %defattr(644,root,root,755)
181 %doc doc/{*.png,*.html,press} cinelerra/{CHANGELOG*,TODO}
182 %attr(755,root,root) %{_bindir}/cinelerra
183 %dir %{_libdir}/cinelerra
184 %attr(755,root,root) %{_libdir}/cinelerra/*.plugin
This page took 0.098531 seconds and 3 git commands to generate.