]> git.pld-linux.org Git - packages/cinelerra-cv.git/blob - cinelerra-cv.spec
- release 2
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define         snap    20100109
5 %define         rel             2
6 Summary:        Cinelerra - capturing, editing and production of audio/video material
7 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
8 Name:           cinelerra-cv
9 Version:        2.1
10 Release:        0.%{snap}.%{rel}
11 License:        GPL
12 Group:          X11/Applications
13 # git clone git://git.cinelerra.org/j6t/cinelerra.git cinelerra-cv
14 Source0:        %{name}-%{snap}.tar.bz2
15 # Source0-md5:  e130b134a9e691ae36d2bbb117fc530b
16 Patch0:         %{name}-build.patch
17 URL:            http://cinelerra.org/
18 BuildRequires:  OpenEXR-devel >= 1.2.1
19 BuildRequires:  OpenGL-GLU-devel
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  a52dec-libs-devel
22 BuildRequires:  alsa-lib-devel >= 1.0.8
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  esound-devel
26 BuildRequires:  ffmpeg-devel
27 BuildRequires:  fftw3-devel
28 BuildRequires:  freetype-devel >= 2.1.4
29 BuildRequires:  gettext-devel
30 BuildRequires:  lame-libs-devel >= 3.93.1
31 BuildRequires:  libavc1394-devel >= 0.5.1
32 BuildRequires:  libdv-devel
33 BuildRequires:  libiec61883-devel >= 1.0.0
34 #BuildRequires: libmpeg3-devel >= 1.7
35 BuildRequires:  libpng-devel
36 BuildRequires:  libraw1394-devel >= 1.2.0
37 BuildRequires:  libsndfile-devel >= 1.0.11
38 BuildRequires:  libstdc++-devel >= 5:3.2.2
39 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
40 BuildRequires:  libtiff-devel >= 3.5.7
41 BuildRequires:  libtool
42 BuildRequires:  libuuid-devel
43 BuildRequires:  mjpegtools-devel
44 BuildRequires:  pkgconfig
45 %ifarch %{ix86} %{x8664}
46 BuildRequires:  nasm
47 %endif
48 #BuildRequires: quicktime4linux-devel >= 2.2
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  xorg-lib-libX11-devel
51 BuildRequires:  xorg-lib-libXext-devel
52 BuildRequires:  xorg-lib-libXv-devel
53 BuildRequires:  xorg-lib-libXxf86vm-devel
54 Requires:       OpenEXR >= 1.2.1
55 Requires:       alsa-lib >= 1.0.8
56 Requires:       freetype >= 2.1.4
57 Requires:       libavc1394 >= 0.5.1
58 Requires:       libiec61883 >= 1.0.0
59 #Requires:      libmpeg3 >= 1.7
60 Requires:       libraw1394 >= 1.2.0
61 Requires:       libsndfile >= 1.0.11
62 Requires:       libtheora >= 1.0-0.alpha4
63 #Requires:      quicktime4linux >= 2.2
64 Obsoletes:      bcast
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         _noautostrip    .*/microtheme.plugin
68
69 %description
70 There are two types of moviegoers: producers who create new content,
71 going back over their content at future points for further refinement,
72 and consumers who want to acquire the content and watch it. Cinelerra
73 is not intended for consumers. Cinelerra has many features for
74 uncompressed content, high resolution processing, and compositing,
75 with very few shortcuts. Producers need these features because of the
76 need to retouch many generations of footage with alterations to the
77 format, which makes Cinelerra very complex.
78
79 Cinelerra was meant to be a Broadcast 2000 replacement.
80
81 This is Community Version.
82
83 %description -l pl.UTF-8
84 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
85 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
86 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
87 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
88 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
89 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
90 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
91 modyfikacji formatu, co czyni program bardzo złożonym.
92
93 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
94
95 Wersja społecznościowa.
96
97 %prep
98 %setup -q -n %{name}
99 %patch0 -p1
100
101 find -name Makefile.am | xargs %{__sed} -i -e 's#^LIBTOOL =.*##g'
102
103 %build
104 rm -f m4/*.m4 *.m4
105 touch config.rpath
106 %{__gettextize}
107 %{__libtoolize}
108 %{__aclocal} -I m4
109 %{__autoheader}
110 %{__automake}
111 %{__autoconf}
112
113 %configure \
114         CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2" \
115 %ifarch ppc
116         --enable-altivec \
117 %endif
118 %ifarch %{ix86} %{x8664}
119         --enable-mmx \
120         --enable-3dnow \
121 %endif
122         --enable-freetype2 \
123         --with-external-ffmpeg \
124         --with-alsa-prefix=%{_prefix} \
125         --with-fontsdir=%{_fontsdir} \
126         --with-plugindir=%{_libdir}/cinelerra
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
137
138 %find_lang cinelerra
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files -f cinelerra.lang
147 %defattr(644,root,root,755)
148 %doc doc/* README* TODO
149 %attr(755,root,root) %{_bindir}/*
150 %dir %{_libdir}/cinelerra
151 %attr(755,root,root) %{_libdir}/cinelerra/*.so
152 %{_libdir}/cinelerra/*.la
153 %{_libdir}/cinelerra/shapewipe
154 %{_libdir}/cinelerra/fonts
155 %attr(755,root,root) %{_libdir}/lib*.so.*
156 %{_desktopdir}/*.desktop
157 %{_pixmapsdir}/*.*
This page took 0.06019 seconds and 4 git commands to generate.