]> git.pld-linux.org Git - packages/cinelerra-cv.git/blob - cinelerra-cv.spec
- new snap 20090324
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define snap    20090324
5 Summary:        Cinelerra - capturing, editing and production of audio/video material
6 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
7 Name:           cinelerra-cv
8 Version:        2.1
9 Release:        0.%{snap}.1
10 License:        GPL
11 Group:          X11/Applications
12 # git clone git://git.cinelerra.org/j6t/cinelerra.git cinelerra-cv
13 Source0:        %{name}-%{snap}.tar.bz2
14 # Source0-md5:  5b68bc5a7bdab0ccf5418df1646e8f1a
15 Patch0:         %{name}-build.patch
16 URL:            http://cvs.cinelerra.org/
17 BuildRequires:  OpenEXR-devel >= 1.2.1
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  a52dec-libs-devel
20 BuildRequires:  alsa-lib-devel >= 1.0.8
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  esound-devel
24 BuildRequires:  ffmpeg-devel
25 BuildRequires:  fftw3-devel
26 BuildRequires:  freetype-devel >= 2.1.4
27 BuildRequires:  gettext-devel
28 BuildRequires:  lame-libs-devel >= 3.93.1
29 BuildRequires:  libavc1394-devel >= 0.5.1
30 BuildRequires:  libdv-devel
31 BuildRequires:  libiec61883-devel >= 1.0.0
32 #BuildRequires: libmpeg3-devel >= 1.7
33 BuildRequires:  libraw1394-devel >= 1.2.0
34 BuildRequires:  libsndfile-devel >= 1.0.11
35 BuildRequires:  libstdc++-devel >= 5:3.2.2
36 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
37 BuildRequires:  libtiff-devel >= 3.5.7
38 BuildRequires:  libtool
39 BuildRequires:  libuuid-devel
40 BuildRequires:  mjpegtools-devel
41 %ifarch %{ix86}
42 BuildRequires:  nasm
43 %endif
44 #BuildRequires: quicktime4linux-devel >= 2.2
45 BuildRequires:  sed >= 4.0
46 BuildRequires:  xorg-lib-libX11-devel
47 BuildRequires:  xorg-lib-libXext-devel
48 BuildRequires:  xorg-lib-libXv-devel
49 BuildRequires:  xorg-lib-libXxf86vm-devel
50 Requires:       OpenEXR-devel >= 1.2.1
51 Requires:       alsa-lib >= 1.0.8
52 Requires:       freetype >= 2.1.4
53 Requires:       libavc1394 >= 0.5.1
54 Requires:       libiec61883 >= 1.0.0
55 #Requires:      libmpeg3 >= 1.7
56 Requires:       libraw1394 >= 1.2.0
57 Requires:       libsndfile >= 1.0.11
58 Requires:       libtheora >= 1.0-0.alpha4
59 #Requires:      quicktime4linux >= 2.2
60 Obsoletes:      bcast
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _noautostrip    .*/microtheme.plugin
64
65 %description
66 There are two types of moviegoers: producers who create new content,
67 going back over their content at future points for further refinement,
68 and consumers who want to acquire the content and watch it. Cinelerra
69 is not intended for consumers. Cinelerra has many features for
70 uncompressed content, high resolution processing, and compositing,
71 with very few shortcuts. Producers need these features because of the
72 need to retouch many generations of footage with alterations to the
73 format, which makes Cinelerra very complex.
74
75 Cinelerra was meant to be a Broadcast 2000 replacement.
76
77 This is Community Version.
78
79 %description -l pl.UTF-8
80 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
81 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
82 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
83 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
84 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
85 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
86 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
87 modyfikacji formatu, co czyni program bardzo złożonym.
88
89 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
90
91 Wersja społecznościowa.
92
93 %prep
94 %setup -q -n %{name}
95 %patch0 -p1
96
97 find -name Makefile.am | xargs %{__sed} -i -e 's#^LIBTOOL =.*##g'
98
99 %build
100 rm -f m4/*.m4 *.m4
101 touch config.rpath
102 %{__gettextize}
103 %{__libtoolize}
104 %{__aclocal} -I m4
105 %{__autoheader}
106 %{__automake}
107 %{__autoconf}
108
109 %configure \
110         CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2" \
111 %ifarch ppc
112         --enable-altivec \
113 %endif
114 %ifarch %{ix86} %{x8664}
115         --enable-mmx \
116         --enable-3dnow \
117 %endif
118         --enable-freetype2 \
119         --with-external-ffmpeg \
120         --with-alsa-prefix=%{_prefix} \
121         --with-fontsdir=%{_fontsdir} \
122         --with-plugindir=%{_libdir}/cinelerra
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
133
134 %find_lang cinelerra
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files -f cinelerra.lang
143 %defattr(644,root,root,755)
144 %doc doc/* README* TODO
145 %attr(755,root,root) %{_bindir}/*
146 %dir %{_libdir}/cinelerra
147 %attr(755,root,root) %{_libdir}/cinelerra/*.so
148 %{_libdir}/cinelerra/*.la
149 %{_libdir}/cinelerra/shapewipe
150 %{_libdir}/cinelerra/fonts
151 %attr(755,root,root) %{_libdir}/lib*.so.*
152 %{_desktopdir}/*.desktop
153 %{_pixmapsdir}/*.*
This page took 0.042701 seconds and 4 git commands to generate.