]> git.pld-linux.org Git - packages/cinelerra-cv.git/blob - cinelerra-cv.spec
- fixes for newer libpng, rel .4
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define         snap    20100109
5 %define         rel             4
6 Summary:        Cinelerra - capturing, editing and production of audio/video material
7 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
8 Name:           cinelerra-cv
9 Version:        2.1
10 Release:        0.%{snap}.%{rel}
11 License:        GPL
12 Group:          X11/Applications
13 # git clone git://git.cinelerra.org/j6t/cinelerra.git cinelerra-cv
14 Source0:        %{name}-%{snap}.tar.bz2
15 # Source0-md5:  e130b134a9e691ae36d2bbb117fc530b
16 Patch0:         %{name}-build.patch
17 Patch1:         %{name}-libpng.patch
18 URL:            http://cinelerra.org/
19 BuildRequires:  OpenEXR-devel >= 1.2.1
20 BuildRequires:  OpenGL-GLU-devel
21 BuildRequires:  OpenGL-devel
22 BuildRequires:  a52dec-libs-devel
23 BuildRequires:  alsa-lib-devel >= 1.0.8
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  esound-devel
27 BuildRequires:  ffmpeg-devel
28 BuildRequires:  fftw3-devel
29 BuildRequires:  freetype-devel >= 2.1.4
30 BuildRequires:  gettext-devel
31 BuildRequires:  lame-libs-devel >= 3.93.1
32 BuildRequires:  libavc1394-devel >= 0.5.1
33 BuildRequires:  libdv-devel
34 BuildRequires:  libiec61883-devel >= 1.0.0
35 #BuildRequires: libmpeg3-devel >= 1.7
36 BuildRequires:  libpng-devel >= 2:1.4.0
37 BuildRequires:  libraw1394-devel >= 1.2.0
38 BuildRequires:  libsndfile-devel >= 1.0.11
39 BuildRequires:  libstdc++-devel >= 5:3.2.2
40 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
41 BuildRequires:  libtiff-devel >= 3.5.7
42 BuildRequires:  libtool
43 BuildRequires:  libuuid-devel
44 BuildRequires:  mjpegtools-devel
45 BuildRequires:  pkgconfig
46 %ifarch %{ix86} %{x8664}
47 BuildRequires:  nasm
48 %endif
49 #BuildRequires: quicktime4linux-devel >= 2.2
50 BuildRequires:  sed >= 4.0
51 BuildRequires:  xorg-lib-libX11-devel
52 BuildRequires:  xorg-lib-libXext-devel
53 BuildRequires:  xorg-lib-libXv-devel
54 BuildRequires:  xorg-lib-libXxf86vm-devel
55 Requires:       OpenEXR >= 1.2.1
56 Requires:       alsa-lib >= 1.0.8
57 Requires:       freetype >= 2.1.4
58 Requires:       libavc1394 >= 0.5.1
59 Requires:       libiec61883 >= 1.0.0
60 #Requires:      libmpeg3 >= 1.7
61 Requires:       libraw1394 >= 1.2.0
62 Requires:       libsndfile >= 1.0.11
63 Requires:       libtheora >= 1.0-0.alpha4
64 #Requires:      quicktime4linux >= 2.2
65 Obsoletes:      bcast
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _noautostrip    .*/microtheme.plugin
69
70 %description
71 There are two types of moviegoers: producers who create new content,
72 going back over their content at future points for further refinement,
73 and consumers who want to acquire the content and watch it. Cinelerra
74 is not intended for consumers. Cinelerra has many features for
75 uncompressed content, high resolution processing, and compositing,
76 with very few shortcuts. Producers need these features because of the
77 need to retouch many generations of footage with alterations to the
78 format, which makes Cinelerra very complex.
79
80 Cinelerra was meant to be a Broadcast 2000 replacement.
81
82 This is Community Version.
83
84 %description -l pl.UTF-8
85 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
86 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
87 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
88 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
89 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
90 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
91 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
92 modyfikacji formatu, co czyni program bardzo złożonym.
93
94 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
95
96 Wersja społecznościowa.
97
98 %prep
99 %setup -q -n %{name}
100 %patch0 -p1
101 %patch1 -p1
102
103 find -name Makefile.am | xargs %{__sed} -i -e 's#^LIBTOOL =.*##g'
104 %{__sed} -i -e 's/png_check_sig((unsigned char\*)test, 8)/!png_sig_cmp((unsigned char\*)test, 0, 8)/g' cinelerra/filepng.C
105
106 %build
107 rm -f m4/*.m4 *.m4
108 touch config.rpath
109 %{__gettextize}
110 %{__libtoolize}
111 %{__aclocal} -I m4
112 %{__autoheader}
113 %{__automake}
114 %{__autoconf}
115
116 %configure \
117         CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2" \
118 %ifarch ppc
119         --enable-altivec \
120 %endif
121 %ifarch %{ix86} %{x8664}
122         --enable-mmx \
123         --enable-3dnow \
124 %endif
125         --enable-freetype2 \
126         --with-external-ffmpeg \
127         --with-alsa-prefix=%{_prefix} \
128         --with-fontsdir=%{_fontsdir} \
129         --with-plugindir=%{_libdir}/cinelerra
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
140
141 %find_lang cinelerra
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files -f cinelerra.lang
150 %defattr(644,root,root,755)
151 %doc doc/* README* TODO
152 %attr(755,root,root) %{_bindir}/*
153 %dir %{_libdir}/cinelerra
154 %attr(755,root,root) %{_libdir}/cinelerra/*.so
155 %{_libdir}/cinelerra/*.la
156 %{_libdir}/cinelerra/shapewipe
157 %{_libdir}/cinelerra/fonts
158 %attr(755,root,root) %{_libdir}/lib*.so.*
159 %{_desktopdir}/*.desktop
160 %{_pixmapsdir}/*.*
This page took 0.067135 seconds and 4 git commands to generate.