]> git.pld-linux.org Git - packages/cinelerra-cv.git/blob - cinelerra-cv.spec
- up to 20110704
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define         snap    20110704
5 %define         rel     1
6 Summary:        Cinelerra - capturing, editing and production of audio/video material
7 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
8 Name:           cinelerra-cv
9 Version:        2.1
10 Release:        0.%{snap}.%{rel}
11 License:        GPL
12 Group:          X11/Applications
13 # git clone git://git.cinelerra.org/j6t/cinelerra.git cinelerra-cv
14 Source0:        %{name}-%{snap}.tar.bz2
15 # Source0-md5:  99a1936170a2e5d211bea0fd628b09ae
16 Patch0:         %{name}-build.patch
17 Patch1:         %{name}-desktop.patch
18 # http://bugs.cinelerra.org/raw-attachment/ticket/949/remove-support-v4l-buzz-k2-6-38.diff
19 Patch2:         remove-support-v4l-buzz-k2-6-38.diff
20 URL:            http://cinelerra.org/
21 BuildRequires:  OpenEXR-devel >= 1.2.1
22 BuildRequires:  OpenGL-GLU-devel
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  a52dec-libs-devel
25 BuildRequires:  alsa-lib-devel >= 1.0.8
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  ffmpeg-devel
29 BuildRequires:  fftw3-devel
30 BuildRequires:  freetype-devel >= 2.1.4
31 BuildRequires:  gettext-devel
32 BuildRequires:  lame-libs-devel >= 3.93.1
33 BuildRequires:  libavc1394-devel >= 0.5.1
34 BuildRequires:  libdv-devel
35 BuildRequires:  libiec61883-devel >= 1.0.0
36 #BuildRequires: libmpeg3-devel >= 1.7
37 BuildRequires:  libpng-devel >= 2:1.4.0
38 BuildRequires:  libraw1394-devel >= 1.2.0
39 BuildRequires:  libsndfile-devel >= 1.0.11
40 BuildRequires:  libstdc++-devel >= 5:3.2.2
41 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
42 BuildRequires:  libtiff-devel >= 3.5.7
43 BuildRequires:  libtool
44 BuildRequires:  libuuid-devel
45 BuildRequires:  mjpegtools-devel
46 BuildRequires:  pkgconfig
47 %ifarch %{ix86} %{x8664}
48 BuildRequires:  nasm
49 %endif
50 #BuildRequires: quicktime4linux-devel >= 2.2
51 BuildRequires:  sed >= 4.0
52 BuildRequires:  xorg-lib-libX11-devel
53 BuildRequires:  xorg-lib-libXext-devel
54 BuildRequires:  xorg-lib-libXv-devel
55 BuildRequires:  xorg-lib-libXxf86vm-devel
56 Requires:       OpenEXR >= 1.2.1
57 Requires:       alsa-lib >= 1.0.8
58 Requires:       freetype >= 2.1.4
59 Requires:       libavc1394 >= 0.5.1
60 Requires:       libiec61883 >= 1.0.0
61 #Requires:      libmpeg3 >= 1.7
62 Requires:       libraw1394 >= 1.2.0
63 Requires:       libsndfile >= 1.0.11
64 Requires:       libtheora >= 1.0-0.alpha4
65 #Requires:      quicktime4linux >= 2.2
66 Obsoletes:      bcast
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _noautostrip    .*/microtheme.plugin
70
71 %description
72 There are two types of moviegoers: producers who create new content,
73 going back over their content at future points for further refinement,
74 and consumers who want to acquire the content and watch it. Cinelerra
75 is not intended for consumers. Cinelerra has many features for
76 uncompressed content, high resolution processing, and compositing,
77 with very few shortcuts. Producers need these features because of the
78 need to retouch many generations of footage with alterations to the
79 format, which makes Cinelerra very complex.
80
81 Cinelerra was meant to be a Broadcast 2000 replacement.
82
83 This is Community Version.
84
85 %description -l pl.UTF-8
86 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
87 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
88 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
89 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
90 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
91 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
92 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
93 modyfikacji formatu, co czyni program bardzo złożonym.
94
95 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
96
97 Wersja społecznościowa.
98
99 %prep
100 %setup -q -n %{name}
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104
105 find -name Makefile.am | xargs %{__sed} -i -e 's#^LIBTOOL =.*##g'
106
107 %build
108 rm -f m4/*.m4 *.m4
109 touch config.rpath
110 %{__gettextize}
111 %{__libtoolize}
112 %{__aclocal} -I m4
113 %{__autoheader}
114 %{__automake}
115 %{__autoconf}
116
117 %configure \
118         CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2" \
119         CXXFLAGS="%{rpmcxxflags} -D__STDC_CONSTANT_MACROS=1" \
120 %ifarch ppc
121         --enable-altivec \
122 %endif
123 %ifarch %{ix86} %{x8664}
124         --enable-mmx \
125         --enable-3dnow \
126 %endif
127         --disable-esd \
128         --enable-freetype2 \
129         --with-external-ffmpeg \
130         --with-alsa-prefix=%{_prefix} \
131         --with-fontsdir=%{_fontsdir} \
132         --with-plugindir=%{_libdir}/cinelerra
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
143
144 %find_lang cinelerra
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files -f cinelerra.lang
153 %defattr(644,root,root,755)
154 %doc doc/* README* TODO
155 %attr(755,root,root) %{_bindir}/*
156 %dir %{_libdir}/cinelerra
157 %attr(755,root,root) %{_libdir}/cinelerra/*.so
158 %{_libdir}/cinelerra/*.la
159 %{_libdir}/cinelerra/shapewipe
160 %{_libdir}/cinelerra/fonts
161 %attr(755,root,root) %{_libdir}/lib*.so.*
162 %{_desktopdir}/*.desktop
163 %{_pixmapsdir}/*.*
This page took 0.078389 seconds and 4 git commands to generate.