]> git.pld-linux.org Git - packages/cinelerra-cv.git/blob - cinelerra-cv.spec
- partial update to 20121104
[packages/cinelerra-cv.git] / cinelerra-cv.spec
1 # TODO:
2 # - external libraries packages (is there any sense in that?)
3 #
4 %define         snap    20121104
5 %define         rel     1
6 Summary:        Cinelerra - capturing, editing and production of audio/video material
7 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
8 Name:           cinelerra-cv
9 Version:        2.2
10 Release:        0.%{snap}.%{rel}
11 License:        GPL
12 Group:          X11/Applications
13 # git clone git://git.cinelerra.org/j6t/cinelerra.git cinelerra-cv
14 Source0:        %{name}-%{snap}.tar.bz2
15 # Source0-md5:  06b92b01fa6ba32ca4622922f2cbaa68
16 Patch0:         %{name}-build.patch
17 Patch1:         %{name}-desktop.patch
18 # http://bugs.cinelerra.org/raw-attachment/ticket/949/remove-support-v4l-buzz-k2-6-38.diff
19 Patch2:         remove-support-v4l-buzz-k2-6-38.diff
20 Patch3:         %{name}-ffmpeg.patch
21 URL:            http://cinelerra.org/
22 BuildRequires:  OpenEXR-devel >= 1.2.1
23 BuildRequires:  OpenGL-GLU-devel
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  a52dec-libs-devel
26 BuildRequires:  alsa-lib-devel >= 1.0.8
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  ffmpeg-devel >= 0.7.1
30 BuildRequires:  fftw3-devel
31 BuildRequires:  freetype-devel >= 2.1.4
32 BuildRequires:  gettext-devel
33 BuildRequires:  lame-libs-devel >= 3.93.1
34 BuildRequires:  libavc1394-devel >= 0.5.1
35 BuildRequires:  libdv-devel
36 BuildRequires:  libiec61883-devel >= 1.0.0
37 #BuildRequires: libmpeg3-devel >= 1.7
38 BuildRequires:  libpng-devel >= 2:1.4.0
39 BuildRequires:  libraw1394-devel >= 1.2.0
40 BuildRequires:  libsndfile-devel >= 1.0.11
41 BuildRequires:  libstdc++-devel >= 5:3.2.2
42 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
43 BuildRequires:  libtiff-devel >= 3.5.7
44 BuildRequires:  libtool
45 BuildRequires:  libuuid-devel
46 BuildRequires:  mjpegtools-devel
47 BuildRequires:  pkgconfig
48 %ifarch %{ix86} %{x8664}
49 BuildRequires:  nasm
50 %endif
51 #BuildRequires: quicktime4linux-devel >= 2.2
52 BuildRequires:  sed >= 4.0
53 BuildRequires:  xorg-lib-libX11-devel
54 BuildRequires:  xorg-lib-libXext-devel
55 BuildRequires:  xorg-lib-libXv-devel
56 BuildRequires:  xorg-lib-libXxf86vm-devel
57 Requires:       OpenEXR >= 1.2.1
58 Requires:       alsa-lib >= 1.0.8
59 Requires:       freetype >= 2.1.4
60 Requires:       libavc1394 >= 0.5.1
61 Requires:       libiec61883 >= 1.0.0
62 #Requires:      libmpeg3 >= 1.7
63 Requires:       libraw1394 >= 1.2.0
64 Requires:       libsndfile >= 1.0.11
65 Requires:       libtheora >= 1.0-0.alpha4
66 #Requires:      quicktime4linux >= 2.2
67 Obsoletes:      bcast
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %define         _noautostrip    .*/microtheme.plugin
71
72 %description
73 There are two types of moviegoers: producers who create new content,
74 going back over their content at future points for further refinement,
75 and consumers who want to acquire the content and watch it. Cinelerra
76 is not intended for consumers. Cinelerra has many features for
77 uncompressed content, high resolution processing, and compositing,
78 with very few shortcuts. Producers need these features because of the
79 need to retouch many generations of footage with alterations to the
80 format, which makes Cinelerra very complex.
81
82 Cinelerra was meant to be a Broadcast 2000 replacement.
83
84 This is Community Version.
85
86 %description -l pl.UTF-8
87 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
88 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
89 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
90 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
91 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
92 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
93 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
94 modyfikacji formatu, co czyni program bardzo złożonym.
95
96 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
97
98 Wersja społecznościowa.
99
100 %prep
101 %setup -q -n %{name}
102 %patch0 -p1
103 %patch1 -p1
104 #%patch2 -p1
105 %patch3 -p1
106
107 find -name Makefile.am | xargs %{__sed} -i -e 's#^LIBTOOL =.*##g'
108
109 %build
110 rm -f m4/*.m4 *.m4
111 touch config.rpath
112 %{__gettextize}
113 %{__libtoolize}
114 %{__aclocal} -I m4
115 %{__autoheader}
116 %{__automake}
117 %{__autoconf}
118
119 %configure \
120         CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2" \
121         CXXFLAGS="%{rpmcxxflags} -D__STDC_CONSTANT_MACROS=1" \
122 %ifarch ppc
123         --enable-altivec \
124 %endif
125 %ifarch %{ix86} %{x8664}
126         --enable-mmx \
127         --enable-3dnow \
128 %endif
129         --disable-esd \
130         --enable-freetype2 \
131         --with-external-ffmpeg \
132         --with-alsa-prefix=%{_prefix} \
133         --with-fontsdir=%{_fontsdir} \
134         --with-plugindir=%{_libdir}/cinelerra
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 install -d $RPM_BUILD_ROOT%{_libdir}/cinelerra/fonts
145
146 %find_lang cinelerra
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files -f cinelerra.lang
155 %defattr(644,root,root,755)
156 %doc doc/* README* TODO
157 %attr(755,root,root) %{_bindir}/*
158 %dir %{_libdir}/cinelerra
159 %attr(755,root,root) %{_libdir}/cinelerra/*.so
160 %{_libdir}/cinelerra/*.la
161 %{_libdir}/cinelerra/shapewipe
162 %{_libdir}/cinelerra/fonts
163 %attr(755,root,root) %{_libdir}/lib*.so.*
164 %{_desktopdir}/*.desktop
165 %{_pixmapsdir}/*.*
This page took 0.057282 seconds and 3 git commands to generate.